You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@oozie.apache.org by "Alejandro Abdelnur (JIRA)" <ji...@apache.org> on 2012/07/24 23:35:33 UTC

[jira] [Commented] (OOZIE-913) Add Name Node, job-xml, and configuration Elements to FS action

    [ https://issues.apache.org/jira/browse/OOZIE-913?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13421783#comment-13421783 ] 

Alejandro Abdelnur commented on OOZIE-913:
------------------------------------------

* FsActionExecutor.validatePathWithNameNode()

By seeing where this method is being used, shouldn't a better name for this method be resolveToFullPath() or something like that?

There should be a single return at the end of method, then is easier to follow the method flow.

Not sure if we should support relative path. I think they should be always absolute. For WF app files relative means within the WF app directory. But I doubt that for data users would be doing stuff within the WF app directory.

* FsActionExecutor.doOperations()

Why are we parsing the full JobXML again? are you after the global configuration? if so, the action protoconfiguration available thru the context should have all those properties.

                
> Add Name Node, job-xml, and configuration Elements to FS action
> ---------------------------------------------------------------
>
>                 Key: OOZIE-913
>                 URL: https://issues.apache.org/jira/browse/OOZIE-913
>             Project: Oozie
>          Issue Type: Improvement
>            Reporter: Robert Kanter
>            Assignee: Robert Kanter
>            Priority: Minor
>         Attachments: OOZIE-913.patch
>
>
> Adding a name node Element to the FS action will allow users to shorten FS actions and avoid specifying the name node (hdfs://HOST:PORT) multiple times.  We can also add job-xml and configuration elements to allow users to set properties when the FS instance is created.  
> e.g.
> {code}
> <action name="fs-node">
>     <fs>
>         <name-node>hdfs://host:port</name-node>
>         <job-xml>fs-info.xml</job-xml>
>         <configuration>
>             <property>
>                 <name>some.property</name>
>                 <value>some.value</value>
>             </property>
>         </configuration>
>         <mkdir path="/user/${wf:user()}/output-data/1"/>
>         <mkdir path="/user/${wf:user()}/output-data/2"/>            
>     </fs>
>     <ok to="end"/>
>     <error to="fail"/>
> </action>
> {code}
> This can then also leverage the global section from OOZIE-874 automatically.  

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira