You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by kf...@collab.net on 2005/09/20 01:02:28 UTC
Re: svn commit: r16100 - trunk/subversion/libsvn_wc
dionisos@tigris.org writes:
> Log:
> Follow up to r16094. Rename function svn_wc__is_magic_props_changed to
> svn_wc__has_magic_property and clarify its comment.
>
> Patch by: Ivan Zhakov <ch...@gmail.com>
> Suggested by: philip
>
> * subversion/libsvn_wc/adm_ops.c:
> (revert_admin_things): Use new function name svn_wc__has_magic_property.
>
> * subversion/libsvn_wc/props.c:
> (svn_wc__is_magic_props_changed): Rename function to
> svn_wc__has_magic_property.
> Rename function argument from propchanges to properties.
Always put the new symbol in the parentheses, thus:
* subversion/libsvn_wc/props.c:
(svn_wc__has_magic_property): New name for
svn_wc__is_magic_props_changed.
...or some language like that.
> * subversion/libsvn_wc/props.h:
> (svn_wc__is_magic_props_changed): Rename function to
> svn_wc__has_magic_property
> and clarify comment.
Same. Plus, odd line-breaking in this log message?
-Karl
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Re: svn commit: r16100 - trunk/subversion/libsvn_wc
Posted by Ivan Zhakov <ch...@gmail.com>.
On 19 Sep 2005 20:02:28 -0500, kfogel@collab.net <kf...@collab.net> wrote:
> dionisos@tigris.org writes:
> > Log:
> > Follow up to r16094. Rename function svn_wc__is_magic_props_changed to
> > svn_wc__has_magic_property and clarify its comment.
> >
> > Patch by: Ivan Zhakov <ch...@gmail.com>
> > Suggested by: philip
> >
> > * subversion/libsvn_wc/adm_ops.c:
> > (revert_admin_things): Use new function name svn_wc__has_magic_property.
> >
> > * subversion/libsvn_wc/props.c:
> > (svn_wc__is_magic_props_changed): Rename function to
> > svn_wc__has_magic_property.
> > Rename function argument from propchanges to properties.
>
> Always put the new symbol in the parentheses, thus:
>
> * subversion/libsvn_wc/props.c:
> (svn_wc__has_magic_property): New name for
> svn_wc__is_magic_props_changed.
>
> ...or some language like that.
Thanks Karl. I had question about log for renamed symbols, but forgot
to ask. Thanks for clarifying and teaching me.
--
Ivan Zhakov
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org