You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@kafka.apache.org by cm...@apache.org on 2024/10/23 03:23:54 UTC
(kafka) 01/01: Revert "KAFKA-17520 align the low bound of ducktape version (#17481)"
This is an automated email from the ASF dual-hosted git repository.
cmccabe pushed a commit to branch 3.9b
in repository https://gitbox.apache.org/repos/asf/kafka.git
commit f92dc67ade1cfeec79204b558a534b9e77c5b1d5
Author: Colin P. McCabe <cm...@apache.org>
AuthorDate: Tue Oct 22 20:23:17 2024 -0700
Revert "KAFKA-17520 align the low bound of ducktape version (#17481)"
This reverts commit 51253e2bf4134c1232ead4ce3666949669d0dea6.
---
tests/docker/Dockerfile | 3 +--
tests/setup.py | 2 +-
2 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/tests/docker/Dockerfile b/tests/docker/Dockerfile
index 57b71bf4fd0..bca82534cdd 100644
--- a/tests/docker/Dockerfile
+++ b/tests/docker/Dockerfile
@@ -63,8 +63,7 @@ LABEL ducker.creator=$ducker_creator
# we have to install git since it is included in openjdk:8 but not openjdk:11
RUN apt update && apt install -y sudo git netcat iptables rsync unzip wget curl jq coreutils openssh-server net-tools vim python3-pip python3-dev libffi-dev libssl-dev cmake pkg-config libfuse-dev iperf traceroute iproute2 iputils-ping && apt-get -y clean
RUN python3 -m pip install -U pip==21.1.1;
-# NOTE: ducktape 0.11.4 requires python3.9
-RUN pip3 install --upgrade cffi virtualenv pyasn1 boto3 pycrypto pywinrm ipaddress enum34 debugpy && pip3 install --upgrade "ducktape==0.11.4"
+RUN pip3 install --upgrade cffi virtualenv pyasn1 boto3 pycrypto pywinrm ipaddress enum34 debugpy && pip3 install --upgrade "ducktape>0.8"
COPY --from=build-native-image /build/kafka-binary/ /opt/kafka-binary/
# Set up ssh
diff --git a/tests/setup.py b/tests/setup.py
index fd3b9738676..f60870dcaa4 100644
--- a/tests/setup.py
+++ b/tests/setup.py
@@ -51,7 +51,7 @@ setup(name="kafkatest",
license="apache2.0",
packages=find_packages(),
include_package_data=True,
- install_requires=["ducktape==0.11.4", "requests==2.31.0"],
+ install_requires=["ducktape==0.8.14", "requests==2.24.0"],
tests_require=["pytest", "mock"],
cmdclass={'test': PyTest},
zip_safe=False