You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@directory.apache.org by el...@apache.org on 2020/12/27 02:08:14 UTC
[directory-site] branch master updated: Fixed some broken links
This is an automated email from the ASF dual-hosted git repository.
elecharny pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/directory-site.git
The following commit(s) were added to refs/heads/master by this push:
new 1d1823a Fixed some broken links
1d1823a is described below
commit 1d1823a5cdc0db49be7a699c827ffa132a582694
Author: emmanuel lecharny <el...@apache.org>
AuthorDate: Sun Dec 27 03:07:56 2020 +0100
Fixed some broken links
---
source/apacheds/basic-ug/1.4.4-configure-logging.md | 14 +++++++-------
source/api/user-guide/6.7-control.md | 2 +-
source/api/user-guide/8-ldap-rfcs.md | 4 ++--
3 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/source/apacheds/basic-ug/1.4.4-configure-logging.md b/source/apacheds/basic-ug/1.4.4-configure-logging.md
index ffa6f01..dedc9d3 100644
--- a/source/apacheds/basic-ug/1.4.4-configure-logging.md
+++ b/source/apacheds/basic-ug/1.4.4-configure-logging.md
@@ -16,11 +16,11 @@ In order to detect and analyze problems, adjusting the log level of a server can
## ApacheDS and logging
-ApacheDS 2.0 uses [SLF4J](http://www.slf4j.org/) as its logging solution. This is a simple facade for various logging APIs. The default for ApacheDS 2.0 is [log4j](http://logging.apache.org/log4j/).
+ApacheDS 2.0 uses [SLF4J](http://www.slf4j.org/) as its logging solution. This is a simple facade for various logging APIs. The default for ApacheDS 2.0 is [log4j](http://logging.apache.org/log4j/1.2/).
## Default behavior after installation
-By default, ApacheDS writes log files in the directory _<APACHEDS_HOME>/var/log/_. Besides stdout, a [RollingFileAppender](http://logging.apache.org/log4j/docs/api/org/apache/log4j/RollingFileAppender.html) is used to collect warnings and errors. It backups the log files when they reach a certain size.
+By default, ApacheDS writes log files in the directory _<APACHEDS_HOME>/var/log/_. Besides stdout, a [RollingFileAppender](http://logging.apache.org/log4j/1.2/apidocs/org/apache/log4j/RollingFileAppender.html) is used to collect warnings and errors. It backups the log files when they reach a certain size.
Here is what the default configuration file _log4j.properties_, which is located in _<APACHEDS_HOME>/conf/_, looks like.
The name of the _RollingFileAppender_ is "R":
@@ -107,7 +107,7 @@ It is possible to configure the logging more fine grained by using categories. W
log4j.logger.org.apache.directory.shared.codec=WARN
log4j.logger.org.apache.directory.shared.asn1=WARN
-If the global level is switched to DEBUG, these definitions override the setting with WARN for certain areas and therefore keep the file a little bit smaller. Learn more about the concept of categories in the [Short introduction to log4j](http://logging.apache.org/log4j/docs/manual.html).
+If the global level is switched to DEBUG, these definitions override the setting with WARN for certain areas and therefore keep the file a little bit smaller. Learn more about the concept of categories in the [Short introduction to log4j](http://logging.apache.org/log4j/1.2/manual.html).
### Format for log messages
@@ -140,7 +140,7 @@ The pattern uses the following conversion characters:
| %m | Application supplied message associated with the logging event |
| %n | Platform dependent line separator |
-The [javadoc of log4j](http://logging.apache.org/log4j/docs/api/org/apache/log4j/PatternLayout.html) contains a table with all valid %-characters and their meaning.
+The [javadoc of log4j](http://logging.apache.org/log4j/1.2/apidocs/org/apache/log4j/PatternLayout.html) contains a table with all valid %-characters and their meaning.
Simple adjust the pattern in the _log4j.properties file_ to get the log format of your choice, for instance
@@ -162,9 +162,9 @@ leads to messages of this form:
### Advanced log4j configuration
-You can take advantage of other features of log4j as well, such as other appenders like the daily rolling file appender. And you can configure logging to make it easier for you to view the messages with tools like Log Factor 5 or [Chainsaw](http://logging.apache.org/log4j/docs/chainsaw.html).
+You can take advantage of other features of log4j as well, such as other appenders like the daily rolling file appender. And you can configure logging to make it easier for you to view the messages with tools like Log Factor 5 or [Chainsaw](https://logging.apache.org/chainsaw/2.x/).
-Learn more about log4j and related tools at its [homepage](http://logging.apache.org/log4j/docs/index.html).
+Learn more about log4j and related tools at its [homepage](http://logging.apache.org/log4j/2.x/index.html).
## Example configurations
@@ -190,6 +190,6 @@ The Tanuki Software Java Service Wrapper web site documents all configuration se
## Resources
-* [Short introduction to log4j](http://logging.apache.org/log4j/docs/manual.html)
+* [Short introduction to log4j](http://logging.apache.org/log4j/1.2/manual.html)
diff --git a/source/api/user-guide/6.7-control.md b/source/api/user-guide/6.7-control.md
index 096c296..8ace0b8 100644
--- a/source/api/user-guide/6.7-control.md
+++ b/source/api/user-guide/6.7-control.md
@@ -51,7 +51,7 @@ The C/S column indicate if the control is sent to the server (S), or back to the
| [PasswordPolicy](#passwordpolicy) | 1.3.6.1.4.1.42.2.27.8.5.1 | The password policy control | C/S | [PasswordPolicy draft](https://tools.ietf.org/html/draft-behera-ldap-password-policy-10) | AP/OL |
| [PermissiveModify](#permissivemodify) | 1.2.840.113556.1.4.1413 | Allows an LDAP modify to work under less restrictive conditions | S | [LDAP_SERVER_PERMISSIVE_MODIFY_OID](https://msdn.microsoft.com/en-us/library/cc223352.aspx) | AD |
| [PersistentSearch](#persistentsearch) | 2.16.840.1.113730.3.4.3 | Provides a simple mechanism by which an LDAP client can receive notification of changes that occur in an LDAP server | S | [Persistent Search](https://tools.ietf.org/html/draft-ietf-ldapext-psearch-03) | AP/OL |
-| [ProxiedAuthz](#proxiedauthz) | 2.16.840.1.113730.3.4.18 | Defines the Proxy Authorization request | S | [RFC 4370](ttps://tools.ietf.org/html/rfc4370) | AP/OL |
+| [ProxiedAuthz](#proxiedauthz) | 2.16.840.1.113730.3.4.18 | Defines the Proxy Authorization request | S | [RFC 4370](https://tools.ietf.org/html/rfc4370) | AP/OL |
| [SortRequest](#sortrequest) | 1.2.840.113556.1.4.473 | Server Side Sort request control | S | [RFC 2891](http://tools.ietf.org/html/rfc2891) | AP/OL |
| [SortResponse](#sortresponse) | 1.2.840.113556.1.4.474 | Server Side Sort request control | C | [RFC 2891](http://tools.ietf.org/html/rfc2891) | AP/OL |
| [Subentries](#subentries) | 1.3.6.1.4.1.4203.1.10.1 | Controls the visibility of entries and subentries | S | [RFC 3672](http://tools.ietf.org/html/rfc3672) | AP/OL |
diff --git a/source/api/user-guide/8-ldap-rfcs.md b/source/api/user-guide/8-ldap-rfcs.md
index 36124c8..a04180b 100644
--- a/source/api/user-guide/8-ldap-rfcs.md
+++ b/source/api/user-guide/8-ldap-rfcs.md
@@ -94,9 +94,9 @@ This page list all the existing **RFCs**, obsolete or not.
| [RFC2587](http://tools.ietf.org/html/rfc2587) | Internet X.509 Public Key Infrastructure LDAPv2 Schema. | [RFC4523](http://tools.ietf.org/html/rfc4523) |  |
| [RFC2596](http://tools.ietf.org/html/rfc2596) | Use of Language Codes in LDAP. | [RFC3866](http://tools.ietf.org/html/rfc3866) |  |
| [RFC2829](http://tools.ietf.org/html/rfc2829) | Authentication Methods for LDAP. | [RFC4513](http://tools.ietf.org/html/rfc4513), [RFC4510](http://tools.ietf.org/html/rfc4510) |  |
-| [RFC2830](http://tools.ietf.org/html/rfc2830) | Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security. | [RFC4511](http://tools.ietf.org/html/rfc), [RFC4513](http://tools.ietf.org/html/rfc), [RFC4510](http://tools.ietf.org/html/rfc4510) |  |
+| [RFC2830](http://tools.ietf.org/html/rfc2830) | Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security. | [RFC4511](http://tools.ietf.org/html/rfc4511), [RFC4513](http://tools.ietf.org/html/rfc451"), [RFC4510](http://tools.ietf.org/html/rfc4510) |  |
| [RFC3377](http://tools.ietf.org/html/rfc3377) | Lightweight Directory Access Protocol (v3): Technical Specification. | [RFC4510](http://tools.ietf.org/html/rfc4510) |  |
-| [RFC3383](http://tools.ietf.org/html/rfc) | Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP). | [RFC4520](http://tools.ietf.org/html/rfc4520) |  |
+| [RFC3383](http://tools.ietf.org/html/rfc3383) | Internet Assigned Numbers Authority (IANA) Considerations for the Lightweight Directory Access Protocol (LDAP). | [RFC4520](http://tools.ietf.org/html/rfc4520) |  |
| [RFC3674](http://tools.ietf.org/html/rfc3674) | Feature Discovery in Lightweight Directory Access Protocol (LDAP). | [RFC4512](http://tools.ietf.org/html/rfc4512) |  |
| [RFC3771](http://tools.ietf.org/html/rfc3771) | The Lightweight Directory Access Protocol (LDAP) Intermediate Response Message. | [RFC4510](http://tools.ietf.org/html/rfc4510), [RFC4511](http://tools.ietf.org/html/rfc4511) |  |