You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Daryn Sharp (JIRA)" <ji...@apache.org> on 2015/04/13 18:21:13 UTC
[jira] [Commented] (HDFS-8133) Improve readability of deleted block
check
[ https://issues.apache.org/jira/browse/HDFS-8133?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14492574#comment-14492574 ]
Daryn Sharp commented on HDFS-8133:
-----------------------------------
Colin recommended I spin this off from HDFS-6658.
> Improve readability of deleted block check
> ------------------------------------------
>
> Key: HDFS-8133
> URL: https://issues.apache.org/jira/browse/HDFS-8133
> Project: Hadoop HDFS
> Issue Type: Improvement
> Components: namenode
> Affects Versions: 2.0.0-alpha
> Reporter: Daryn Sharp
> Assignee: Daryn Sharp
>
> The current means of checking if a block is deleted is checking if its block collection is null. A more readable approach is an isDeleted method.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)