You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@geronimo.apache.org by "David Jencks (JIRA)" <ji...@apache.org> on 2010/01/12 21:34:54 UTC

[jira] Created: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

New module/app/global jndi contexts in javaee 6 spec
----------------------------------------------------

                 Key: GERONIMO-5025
                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
             Project: Geronimo
          Issue Type: New Feature
      Security Level: public (Regular issues)
          Components: deployment, naming
    Affects Versions: 3.0
            Reporter: David Jencks
            Assignee: David Jencks
             Fix For: 3.0


Javaee platform spec describes some new jndi java: contexts that are more shared between components.
java:comp (existing)
java:module
java:app
java:global

My first idea for implementing this:

1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

Posted by "Rick McGuire (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/GERONIMO-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12901396#action_12901396 ] 

Rick McGuire commented on GERONIMO-5025:
----------------------------------------

I believe this work is complete now, correct?

> New module/app/global jndi contexts in javaee 6 spec
> ----------------------------------------------------
>
>                 Key: GERONIMO-5025
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
>             Project: Geronimo
>          Issue Type: Sub-task
>      Security Level: public(Regular issues) 
>          Components: deployment, naming
>    Affects Versions: 3.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 3.0
>
>
> Javaee platform spec describes some new jndi java: contexts that are more shared between components.
> java:comp (existing)
> java:module
> java:app
> java:global
> My first idea for implementing this:
> 1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
> 2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
> 3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

Posted by "David Jencks (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/GERONIMO-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12804196#action_12804196 ] 

David Jencks commented on GERONIMO-5025:
----------------------------------------

rev 902527 moves web app jndi context setup to a different object since jsf needs to be set up before the web app.  Both the myfaces instance construction service and the web context now have a reference to the jndi object.

> New module/app/global jndi contexts in javaee 6 spec
> ----------------------------------------------------
>
>                 Key: GERONIMO-5025
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
>             Project: Geronimo
>          Issue Type: New Feature
>      Security Level: public(Regular issues) 
>          Components: deployment, naming
>    Affects Versions: 3.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 3.0
>
>
> Javaee platform spec describes some new jndi java: contexts that are more shared between components.
> java:comp (existing)
> java:module
> java:app
> java:global
> My first idea for implementing this:
> 1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
> 2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
> 3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

Posted by "David Jencks (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/GERONIMO-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12874475#action_12874475 ] 

David Jencks commented on GERONIMO-5025:
----------------------------------------


rev 950397 (see also GERONIMO-5117) moves jndi support directly into Modules and straightens out when contexts are shared between submodules and ears and modules. 

> New module/app/global jndi contexts in javaee 6 spec
> ----------------------------------------------------
>
>                 Key: GERONIMO-5025
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
>             Project: Geronimo
>          Issue Type: Sub-task
>      Security Level: public(Regular issues) 
>          Components: deployment, naming
>    Affects Versions: 3.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 3.0
>
>
> Javaee platform spec describes some new jndi java: contexts that are more shared between components.
> java:comp (existing)
> java:module
> java:app
> java:global
> My first idea for implementing this:
> 1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
> 2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
> 3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

Posted by "David Jencks (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/GERONIMO-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12870212#action_12870212 ] 

David Jencks commented on GERONIMO-5025:
----------------------------------------

rev 947211 moves around jndi configuration in openejb so that the jndi enc context in openejb is an immutable federation of the global, app, module, and comp context constructed by geronimo, and an additional writable comp context that openejb can bind stuff like TimerService and EJBContext into.  Injections now seem to work in openejb. 

> New module/app/global jndi contexts in javaee 6 spec
> ----------------------------------------------------
>
>                 Key: GERONIMO-5025
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
>             Project: Geronimo
>          Issue Type: Sub-task
>      Security Level: public(Regular issues) 
>          Components: deployment, naming
>    Affects Versions: 3.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 3.0
>
>
> Javaee platform spec describes some new jndi java: contexts that are more shared between components.
> java:comp (existing)
> java:module
> java:app
> java:global
> My first idea for implementing this:
> 1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
> 2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
> 3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

Posted by "David Jencks (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/GERONIMO-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12868788#action_12868788 ] 

David Jencks commented on GERONIMO-5025:
----------------------------------------

Rev 945814 and 945820 add support for jndi configuration in application.xml

> New module/app/global jndi contexts in javaee 6 spec
> ----------------------------------------------------
>
>                 Key: GERONIMO-5025
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
>             Project: Geronimo
>          Issue Type: Sub-task
>      Security Level: public(Regular issues) 
>          Components: deployment, naming
>    Affects Versions: 3.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 3.0
>
>
> Javaee platform spec describes some new jndi java: contexts that are more shared between components.
> java:comp (existing)
> java:module
> java:app
> java:global
> My first idea for implementing this:
> 1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
> 2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
> 3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

Posted by "David Jencks (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/GERONIMO-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12803554#action_12803554 ] 

David Jencks commented on GERONIMO-5025:
----------------------------------------

rev 901935 basically does the work described above.  There aren't really any tests yet.

More stuff to do:

1. detect if an entry is specified twice and object if it is specified differently.
2. find out what is meant for web apps about java:comp and java:module being "the same"
3. figure out if/how to get the global context available to app clients.

Also we could probably have a urlHandler for jca: and ger: contexts.  What we used to do was bogus, treating the "scheme" part as a name component.

> New module/app/global jndi contexts in javaee 6 spec
> ----------------------------------------------------
>
>                 Key: GERONIMO-5025
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
>             Project: Geronimo
>          Issue Type: New Feature
>      Security Level: public(Regular issues) 
>          Components: deployment, naming
>    Affects Versions: 3.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 3.0
>
>
> Javaee platform spec describes some new jndi java: contexts that are more shared between components.
> java:comp (existing)
> java:module
> java:app
> java:global
> My first idea for implementing this:
> 1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
> 2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
> 3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (GERONIMO-5025) New module/app/global jndi contexts in javaee 6 spec

Posted by "Rick McGuire (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/GERONIMO-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Rick McGuire updated GERONIMO-5025:
-----------------------------------

    Issue Type: Sub-task  (was: New Feature)
        Parent: GERONIMO-5066

> New module/app/global jndi contexts in javaee 6 spec
> ----------------------------------------------------
>
>                 Key: GERONIMO-5025
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-5025
>             Project: Geronimo
>          Issue Type: Sub-task
>      Security Level: public(Regular issues) 
>          Components: deployment, naming
>    Affects Versions: 3.0
>            Reporter: David Jencks
>            Assignee: David Jencks
>             Fix For: 3.0
>
>
> Javaee platform spec describes some new jndi java: contexts that are more shared between components.
> java:comp (existing)
> java:module
> java:app
> java:global
> My first idea for implementing this:
> 1. in RootContext, have the thread local represent java:  rather than java:comp.  So all the namespaces will be in the Context object.
> 2. Construct this Context by federating objects for each scope.  We'll have to maintain a global context somewhere.  The others can presumably be constructed during deployment and set up in the existing gbeans for the app components.
> 3. Modify the naming builders to put stuff into the right namespace.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.