You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by Hari Sankar Sivarama Subramaniyan <hs...@hortonworks.com> on 2016/02/03 20:00:44 UTC

Review Request 43143: HIVE-12923 : CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43143/
-----------------------------------------------------------

Review request for hive, Jesús Camacho Rodríguez and John Pullokkaran.


Repository: hive-git


Description
-------

CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure


Diffs
-----

  ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java f6b2d84 

Diff: https://reviews.apache.org/r/43143/diff/


Testing
-------

Precommit runs


Thanks,

Hari Sankar Sivarama Subramaniyan


Re: Review Request 43143: HIVE-12923 : CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure

Posted by Jesús Camacho Rodríguez <jc...@hortonworks.com>.

> On Feb. 5, 2016, 6:21 p.m., Jesús Camacho Rodríguez wrote:
> > ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java, line 153
> > <https://reviews.apache.org/r/43143/diff/2/?file=1231783#file1231783line153>
> >
> >     This rule is only applied over the Project children. Thus, why is the parameter for the method hasAggregateChildWithIndicator e.g. leftJoinChild instead of leftProj?

OK, you still need to check because you might pull up every column from one of the sides...


- Jesús


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43143/#review118045
-----------------------------------------------------------


On Feb. 3, 2016, 8:54 p.m., Hari Sankar Sivarama Subramaniyan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43143/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2016, 8:54 p.m.)
> 
> 
> Review request for hive, Jesús Camacho Rodríguez and John Pullokkaran.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure
> 
> 
> Diffs
> -----
> 
>   ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java f6b2d84 
> 
> Diff: https://reviews.apache.org/r/43143/diff/
> 
> 
> Testing
> -------
> 
> Precommit runs
> 
> 
> Thanks,
> 
> Hari Sankar Sivarama Subramaniyan
> 
>


Re: Review Request 43143: HIVE-12923 : CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure

Posted by Hari Sankar Sivarama Subramaniyan <hs...@hortonworks.com>.

> On Feb. 5, 2016, 6:21 p.m., Jesús Camacho Rodríguez wrote:
> > ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java, line 153
> > <https://reviews.apache.org/r/43143/diff/2/?file=1231783#file1231783line153>
> >
> >     This rule is only applied over the Project children. Thus, why is the parameter for the method hasAggregateChildWithIndicator e.g. leftJoinChild instead of leftProj?
> 
> Jesús Camacho Rodríguez wrote:
>     OK, you still need to check because you might pull up every column from one of the sides...
> 
> Jesús Camacho Rodríguez wrote:
>     Please Hari, mark it as fixed if you agree.

leftJoinChild is indeed obtained from getProjectChild(). I took the variable name/relevant part of the code except hasAggregateChildWithIndicator ()  from super.onMatch(). Maybe I should rename the variables/function name to hasAggregateDescendantWithIndicator().

Thanks
Hari


- Hari Sankar


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43143/#review118045
-----------------------------------------------------------


On Feb. 3, 2016, 8:54 p.m., Hari Sankar Sivarama Subramaniyan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43143/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2016, 8:54 p.m.)
> 
> 
> Review request for hive, Jesús Camacho Rodríguez and John Pullokkaran.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure
> 
> 
> Diffs
> -----
> 
>   ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java f6b2d84 
> 
> Diff: https://reviews.apache.org/r/43143/diff/
> 
> 
> Testing
> -------
> 
> Precommit runs
> 
> 
> Thanks,
> 
> Hari Sankar Sivarama Subramaniyan
> 
>


Re: Review Request 43143: HIVE-12923 : CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure

Posted by Jesús Camacho Rodríguez <jc...@hortonworks.com>.

> On Feb. 5, 2016, 6:21 p.m., Jesús Camacho Rodríguez wrote:
> > ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java, line 153
> > <https://reviews.apache.org/r/43143/diff/2/?file=1231783#file1231783line153>
> >
> >     This rule is only applied over the Project children. Thus, why is the parameter for the method hasAggregateChildWithIndicator e.g. leftJoinChild instead of leftProj?
> 
> Jesús Camacho Rodríguez wrote:
>     OK, you still need to check because you might pull up every column from one of the sides...

Please Hari, mark it as fixed if you agree.


- Jesús


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43143/#review118045
-----------------------------------------------------------


On Feb. 3, 2016, 8:54 p.m., Hari Sankar Sivarama Subramaniyan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43143/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2016, 8:54 p.m.)
> 
> 
> Review request for hive, Jesús Camacho Rodríguez and John Pullokkaran.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure
> 
> 
> Diffs
> -----
> 
>   ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java f6b2d84 
> 
> Diff: https://reviews.apache.org/r/43143/diff/
> 
> 
> Testing
> -------
> 
> Precommit runs
> 
> 
> Thanks,
> 
> Hari Sankar Sivarama Subramaniyan
> 
>


Re: Review Request 43143: HIVE-12923 : CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure

Posted by Jesús Camacho Rodríguez <jc...@hortonworks.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43143/#review118045
-----------------------------------------------------------




ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java (line 153)
<https://reviews.apache.org/r/43143/#comment179316>

    This rule is only applied over the Project children. Thus, why is the parameter for the method hasAggregateChildWithIndicator e.g. leftJoinChild instead of leftProj?


- Jesús Camacho Rodríguez


On Feb. 3, 2016, 8:54 p.m., Hari Sankar Sivarama Subramaniyan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43143/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2016, 8:54 p.m.)
> 
> 
> Review request for hive, Jesús Camacho Rodríguez and John Pullokkaran.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure
> 
> 
> Diffs
> -----
> 
>   ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java f6b2d84 
> 
> Diff: https://reviews.apache.org/r/43143/diff/
> 
> 
> Testing
> -------
> 
> Precommit runs
> 
> 
> Thanks,
> 
> Hari Sankar Sivarama Subramaniyan
> 
>


Re: Review Request 43143: HIVE-12923 : CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure

Posted by Hari Sankar Sivarama Subramaniyan <hs...@hortonworks.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43143/
-----------------------------------------------------------

(Updated Feb. 3, 2016, 8:54 p.m.)


Review request for hive, Jesús Camacho Rodríguez and John Pullokkaran.


Changes
-------

Minor change to fix the diff in cbo_rp_outer_join_ppr.q


Repository: hive-git


Description
-------

CBO: Calcite Operator To Hive Operator (Calcite Return Path): TestCliDriver groupby_grouping_sets4.q failure


Diffs (updated)
-----

  ql/src/java/org/apache/hadoop/hive/ql/optimizer/calcite/rules/HiveJoinProjectTransposeRule.java f6b2d84 

Diff: https://reviews.apache.org/r/43143/diff/


Testing
-------

Precommit runs


Thanks,

Hari Sankar Sivarama Subramaniyan