You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Robert Klaus (JIRA)" <ji...@apache.org> on 2017/01/20 08:58:26 UTC
[jira] [Commented] (MASSEMBLY-846) MASSEMBLY-817 makes some
usecases very inconvenient
[ https://issues.apache.org/jira/browse/MASSEMBLY-846?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15831431#comment-15831431 ]
Robert Klaus commented on MASSEMBLY-846:
----------------------------------------
Sorry, the Jira instance had a problem when we tried to create an issue. Please close this one and use the other
> MASSEMBLY-817 makes some usecases very inconvenient
> ---------------------------------------------------
>
> Key: MASSEMBLY-846
> URL: https://issues.apache.org/jira/browse/MASSEMBLY-846
> Project: Maven Assembly Plugin
> Issue Type: Bug
> Affects Versions: 3.0.0
> Reporter: Robert Klaus
>
> The "improvement" done in MASSEMBLY-817 makes some usecases very inconvenient:
> We need to create an archive with one stable name (independent of e.g. version) so we don't have to propagate these information to a bunch of scripts.
> The general solution (i.e. Stack-overflow) refers exactly to the finalName:
> [http://stackoverflow.com/questions/20697144/can-not-set-the-final-jar-name-with-maven-assembly-plugin]
> *Please change finalName back to a settable property.*
> It being settable does not hurt anyone satisfied with the default naming convention but makes some usecases vastly simpler (otherwise you have to rename the artifact using yet another plugin or propagate version info possibly through a chain of scripts)
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)