You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "Dan Burkert (JIRA)" <ji...@apache.org> on 2013/07/10 08:23:49 UTC

[jira] [Created] (HBASE-8915) protobuf message style

Dan Burkert created HBASE-8915:
----------------------------------

             Summary: protobuf message style
                 Key: HBASE-8915
                 URL: https://issues.apache.org/jira/browse/HBASE-8915
             Project: HBase
          Issue Type: Improvement
          Components: Protobufs
            Reporter: Dan Burkert
            Priority: Minor


Google's protobuf style guide (https://developers.google.com/protocol-buffers/docs/style) lays out the convention that message field names should be underscore_separated and services should be MixedCase. The .proto's in trunk do not follow this style; instead they follow Java naming conventions. The protobuf compiler will automatically change the style of names to match the language it is compiling for, but it is unable to do so if the protobuf style is not used. As a result, using the HBase proto files from languages with different naming conventions than Java is a little bit more painful.

Since a core feature of moving to protobufs is opening the door to wire compatible implementations in other languages, I think this may want to be addressed. This patch changes the naming convention in the protos. The resulting .java files that the protobuf compiler puts out are functionally the same (with the same correct Java naming style).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira