You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@httpd.apache.org by Justin Erenkrantz <je...@ebuilt.com> on 2001/09/20 04:40:17 UTC

[PATCH] Standardize AcceptMutex config

Calling the AcceptMutex proc_pthread is just silly.  1.3 got it 
right by calling it pthread.

This would also be one less thing for a person who uses this new
feature in 1.3 to change when they upgrade to 2.0.  

Would anyone raise a fit if I committed this?  -- justin

Index: server/mpm_common.c
===================================================================
RCS file: /home/cvs/httpd-2.0/server/mpm_common.c,v
retrieving revision 1.67
diff -u -r1.67 mpm_common.c
--- server/mpm_common.c	2001/09/18 22:13:57	1.67
+++ server/mpm_common.c	2001/09/20 02:29:39
@@ -604,7 +604,7 @@
     }
 #endif
 #if APR_HAS_PROC_PTHREAD_SERIALIZE
-    else if (!strcasecmp(arg, "proc_pthread")) {
+    else if (!strcasecmp(arg, "pthread")) {
         ap_accept_lock_mech = APR_LOCK_PROC_PTHREAD;
     }
 #endif
@@ -621,7 +621,7 @@
                            ", sysvsem"
 #endif
 #if APR_HAS_PROC_PTHREAD_SERIALIZE
-                           ", proc_pthread"
+                           ", pthread"
 #endif
                            , NULL);
     }


Re: [PATCH] Standardize AcceptMutex config

Posted by Justin Erenkrantz <je...@ebuilt.com>.
On Wed, Sep 19, 2001 at 08:35:40PM -0700, Ryan Bloom wrote:
> I agree that having them inconsistent is incredibly silly.  I am wondering
> why you think the 1.3 one makes more sense.  I have told you why I think
> calling out that it is a process makes more sense to me.  I am trying to
> understand your point of view.

Since all of the other alternatives (fcntl, flock, etc) are also
process-level, it follows that any pthread accept mutex should be 
in a similar vein.  It wouldn't make sense to have an intraprocess
lock option when all of the others are inherently interprocess
locks.  (Remember that fcntl can't be used to lock within a single 
process.)  Not to mention that we, as a group, don't like single
process MPMs - so having the AcceptMutex be an intraprocess lock 
isn't really feasible as a *common* MPM option.  Therefore,
I think there is no need to make the unnecessary distinction - the 
context in which this mutex is used indicates that it should be an
interprocess lock.

It is something that I can go either way on - I like pthread
better.  But, we should definitely be consistent.  -- justin


Re: [PATCH] Standardize AcceptMutex config

Posted by Ryan Bloom <rb...@covalent.net>.
On Wednesday 19 September 2001 07:56 pm, Justin Erenkrantz wrote:
> On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> > Why is calling it proc_pthread silly?  We are talking about a pthread
> > based process lock.  Personally, I think Apache 1.3 should be changed,
> > especially since it hasn't been released yet.  My concern is that calling
> > it a pthread lock makes it sound like we are just locking threads.
>
> Fine, change one or the other.  Having it inconsistent is *silly*.
> Personally, I think Apache 1.3's pthread makes more sense given the
> context.  -- justin

I agree that having them inconsistent is incredibly silly.  I am wondering
why you think the 1.3 one makes more sense.  I have told you why I think
calling out that it is a process makes more sense to me.  I am trying to
understand your point of view.

Ryan

______________________________________________________________
Ryan Bloom				rbb@apache.org
Covalent Technologies			rbb@covalent.net
--------------------------------------------------------------

Re: [PATCH] Standardize AcceptMutex config

Posted by Aaron Bannert <aa...@clove.org>.
Now we're just decreasing the signal-to-noise ratio. :)

-aaron


On Thu, Sep 20, 2001 at 09:45:57AM -0400, Bill Stoddard wrote:
> Ooops! And the list grows with each post we make :-)
> 
> proc_pthread, proc_pthread, proc_pthread...
> 
> Bill
> 
> > On Wednesday 19 September 2001 09:27 pm, Bill Stoddard wrote:
> > > proc_thread doesn't tell me anything. If I google for proc_thread, I get no
> > > hits. If I google pthread, I at least get hits that I can search through to
> > > find anything to do with a 'lock'. pthread is easier to read than
> > > proc_thread. Yea, not great arguments for using pthread, but at least as
> > > strong as arguments to use proc_thread.
> > 
> > what if we went with proc_pthread?  I just googled it, and there is a page
> >  of hits, all related to this very subject.  :-)
> > 
> > Ryan
> > 
> > >
> > > Bill
> > >
> > > ----- Original Message -----
> > > From: "Ryan Bloom" <rb...@covalent.net>
> > > To: <de...@httpd.apache.org>; "Bill Stoddard" <bi...@wstoddard.com>
> > > Sent: Wednesday, September 19, 2001 11:59 PM
> > > Subject: Re: [PATCH] Standardize AcceptMutex config
> > >
> > > > On Wednesday 19 September 2001 08:56 pm, Bill Stoddard wrote:
> > > > > > On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> > > > > > > Why is calling it proc_pthread silly?  We are talking about a
> > > > > > > pthread based process lock.  Personally, I think Apache 1.3 should
> > > > > > > be changed, especially since it hasn't been released yet.  My
> > > > > > > concern is that calling it a pthread lock makes it sound like we
> > > > > > > are just locking threads.
> > > > > >
> > > > > > Fine, change one or the other.  Having it inconsistent is *silly*.
> > > > > > Personally, I think Apache 1.3's pthread makes more sense given the
> > > > > > context.  -- justin
> > > > >
> > > > > I agree with Justin.
> > > >
> > > > That's fine, could you please explain why?  I am trying to understand
> > > > this POV.  Why don't you think that calling out the proc part is
> > > > important? I don't mind being wrong, but I do mind not knowing why I am
> > > > wrong.  :-)
> > > >
> > > > Ryan
> > > >
> > > > ______________________________________________________________
> > > > Ryan Bloom rbb@apache.org
> > > > Covalent Technologies rbb@covalent.net
> > > > --------------------------------------------------------------
> > 
> > -- 
> > 
> > ______________________________________________________________
> > Ryan Bloom rbb@apache.org
> > Covalent Technologies rbb@covalent.net
> > --------------------------------------------------------------
> > 

Re: [PATCH] Standardize AcceptMutex config

Posted by Bill Stoddard <bi...@wstoddard.com>.
Ooops! And the list grows with each post we make :-)

proc_pthread, proc_pthread, proc_pthread...

Bill

> On Wednesday 19 September 2001 09:27 pm, Bill Stoddard wrote:
> > proc_thread doesn't tell me anything. If I google for proc_thread, I get no
> > hits. If I google pthread, I at least get hits that I can search through to
> > find anything to do with a 'lock'. pthread is easier to read than
> > proc_thread. Yea, not great arguments for using pthread, but at least as
> > strong as arguments to use proc_thread.
> 
> what if we went with proc_pthread?  I just googled it, and there is a page
>  of hits, all related to this very subject.  :-)
> 
> Ryan
> 
> >
> > Bill
> >
> > ----- Original Message -----
> > From: "Ryan Bloom" <rb...@covalent.net>
> > To: <de...@httpd.apache.org>; "Bill Stoddard" <bi...@wstoddard.com>
> > Sent: Wednesday, September 19, 2001 11:59 PM
> > Subject: Re: [PATCH] Standardize AcceptMutex config
> >
> > > On Wednesday 19 September 2001 08:56 pm, Bill Stoddard wrote:
> > > > > On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> > > > > > Why is calling it proc_pthread silly?  We are talking about a
> > > > > > pthread based process lock.  Personally, I think Apache 1.3 should
> > > > > > be changed, especially since it hasn't been released yet.  My
> > > > > > concern is that calling it a pthread lock makes it sound like we
> > > > > > are just locking threads.
> > > > >
> > > > > Fine, change one or the other.  Having it inconsistent is *silly*.
> > > > > Personally, I think Apache 1.3's pthread makes more sense given the
> > > > > context.  -- justin
> > > >
> > > > I agree with Justin.
> > >
> > > That's fine, could you please explain why?  I am trying to understand
> > > this POV.  Why don't you think that calling out the proc part is
> > > important? I don't mind being wrong, but I do mind not knowing why I am
> > > wrong.  :-)
> > >
> > > Ryan
> > >
> > > ______________________________________________________________
> > > Ryan Bloom rbb@apache.org
> > > Covalent Technologies rbb@covalent.net
> > > --------------------------------------------------------------
> 
> -- 
> 
> ______________________________________________________________
> Ryan Bloom rbb@apache.org
> Covalent Technologies rbb@covalent.net
> --------------------------------------------------------------
> 


Re: [PATCH] Standardize AcceptMutex config

Posted by Ryan Bloom <rb...@covalent.net>.
On Wednesday 19 September 2001 09:27 pm, Bill Stoddard wrote:
> proc_thread doesn't tell me anything. If I google for proc_thread, I get no
> hits. If I google pthread, I at least get hits that I can search through to
> find anything to do with a 'lock'. pthread is easier to read than
> proc_thread. Yea, not great arguments for using pthread, but at least as
> strong as arguments to use proc_thread.

what if we went with proc_pthread?  I just googled it, and there is a page
 of hits, all related to this very subject.  :-)

Ryan

>
> Bill
>
> ----- Original Message -----
> From: "Ryan Bloom" <rb...@covalent.net>
> To: <de...@httpd.apache.org>; "Bill Stoddard" <bi...@wstoddard.com>
> Sent: Wednesday, September 19, 2001 11:59 PM
> Subject: Re: [PATCH] Standardize AcceptMutex config
>
> > On Wednesday 19 September 2001 08:56 pm, Bill Stoddard wrote:
> > > > On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> > > > > Why is calling it proc_pthread silly?  We are talking about a
> > > > > pthread based process lock.  Personally, I think Apache 1.3 should
> > > > > be changed, especially since it hasn't been released yet.  My
> > > > > concern is that calling it a pthread lock makes it sound like we
> > > > > are just locking threads.
> > > >
> > > > Fine, change one or the other.  Having it inconsistent is *silly*.
> > > > Personally, I think Apache 1.3's pthread makes more sense given the
> > > > context.  -- justin
> > >
> > > I agree with Justin.
> >
> > That's fine, could you please explain why?  I am trying to understand
> > this POV.  Why don't you think that calling out the proc part is
> > important? I don't mind being wrong, but I do mind not knowing why I am
> > wrong.  :-)
> >
> > Ryan
> >
> > ______________________________________________________________
> > Ryan Bloom rbb@apache.org
> > Covalent Technologies rbb@covalent.net
> > --------------------------------------------------------------

-- 

______________________________________________________________
Ryan Bloom				rbb@apache.org
Covalent Technologies			rbb@covalent.net
--------------------------------------------------------------

Re: [PATCH] Standardize AcceptMutex config

Posted by Bill Stoddard <bi...@wstoddard.com>.
proc_thread doesn't tell me anything. If I google for proc_thread, I get no hits. If I
google pthread, I at least get hits that I can search through to find anything to do with
a 'lock'. pthread is easier to read than proc_thread. Yea, not great arguments for using
pthread, but at least as strong as arguments to use proc_thread.

Bill

----- Original Message -----
From: "Ryan Bloom" <rb...@covalent.net>
To: <de...@httpd.apache.org>; "Bill Stoddard" <bi...@wstoddard.com>
Sent: Wednesday, September 19, 2001 11:59 PM
Subject: Re: [PATCH] Standardize AcceptMutex config


> On Wednesday 19 September 2001 08:56 pm, Bill Stoddard wrote:
> > > On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> > > > Why is calling it proc_pthread silly?  We are talking about a pthread
> > > > based process lock.  Personally, I think Apache 1.3 should be changed,
> > > > especially since it hasn't been released yet.  My concern is that
> > > > calling it a pthread lock makes it sound like we are just locking
> > > > threads.
> > >
> > > Fine, change one or the other.  Having it inconsistent is *silly*.
> > > Personally, I think Apache 1.3's pthread makes more sense given the
> > > context.  -- justin
> >
> > I agree with Justin.
>
> That's fine, could you please explain why?  I am trying to understand this
> POV.  Why don't you think that calling out the proc part is important?
> I don't mind being wrong, but I do mind not knowing why I am wrong.  :-)
>
> Ryan
>
> ______________________________________________________________
> Ryan Bloom rbb@apache.org
> Covalent Technologies rbb@covalent.net
> --------------------------------------------------------------
>


Re: [PATCH] Standardize AcceptMutex config

Posted by Ryan Bloom <rb...@covalent.net>.
On Wednesday 19 September 2001 08:56 pm, Bill Stoddard wrote:
> > On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> > > Why is calling it proc_pthread silly?  We are talking about a pthread
> > > based process lock.  Personally, I think Apache 1.3 should be changed,
> > > especially since it hasn't been released yet.  My concern is that
> > > calling it a pthread lock makes it sound like we are just locking
> > > threads.
> >
> > Fine, change one or the other.  Having it inconsistent is *silly*.
> > Personally, I think Apache 1.3's pthread makes more sense given the
> > context.  -- justin
>
> I agree with Justin.

That's fine, could you please explain why?  I am trying to understand this
POV.  Why don't you think that calling out the proc part is important?
I don't mind being wrong, but I do mind not knowing why I am wrong.  :-)

Ryan

______________________________________________________________
Ryan Bloom				rbb@apache.org
Covalent Technologies			rbb@covalent.net
--------------------------------------------------------------

Re: [PATCH] Standardize AcceptMutex config

Posted by Bill Stoddard <bi...@wstoddard.com>.
> On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> > Why is calling it proc_pthread silly?  We are talking about a pthread based
> > process lock.  Personally, I think Apache 1.3 should be changed, especially
> > since it hasn't been released yet.  My concern is that calling it a pthread lock
> > makes it sound like we are just locking threads.
> 
> Fine, change one or the other.  Having it inconsistent is *silly*.
> Personally, I think Apache 1.3's pthread makes more sense given the
> context.  -- justin
> 

I agree with Justin.

Bill


Re: [PATCH] Standardize AcceptMutex config

Posted by Justin Erenkrantz <je...@ebuilt.com>.
On Wed, Sep 19, 2001 at 07:53:47PM -0700, Ryan Bloom wrote:
> Why is calling it proc_pthread silly?  We are talking about a pthread based
> process lock.  Personally, I think Apache 1.3 should be changed, especially
> since it hasn't been released yet.  My concern is that calling it a pthread lock
> makes it sound like we are just locking threads.

Fine, change one or the other.  Having it inconsistent is *silly*.
Personally, I think Apache 1.3's pthread makes more sense given the
context.  -- justin


Re: [PATCH] Standardize AcceptMutex config

Posted by Ryan Bloom <rb...@covalent.net>.
On Wednesday 19 September 2001 07:40 pm, Justin Erenkrantz wrote:
> Calling the AcceptMutex proc_pthread is just silly.  1.3 got it
> right by calling it pthread.
>
> This would also be one less thing for a person who uses this new
> feature in 1.3 to change when they upgrade to 2.0.
>
> Would anyone raise a fit if I committed this?  -- justin

Why is calling it proc_pthread silly?  We are talking about a pthread based
process lock.  Personally, I think Apache 1.3 should be changed, especially
since it hasn't been released yet.  My concern is that calling it a pthread lock
makes it sound like we are just locking threads.

Ryan

> Index: server/mpm_common.c
> ===================================================================
> RCS file: /home/cvs/httpd-2.0/server/mpm_common.c,v
> retrieving revision 1.67
> diff -u -r1.67 mpm_common.c
> --- server/mpm_common.c	2001/09/18 22:13:57	1.67
> +++ server/mpm_common.c	2001/09/20 02:29:39
> @@ -604,7 +604,7 @@
>      }
>  #endif
>  #if APR_HAS_PROC_PTHREAD_SERIALIZE
> -    else if (!strcasecmp(arg, "proc_pthread")) {
> +    else if (!strcasecmp(arg, "pthread")) {
>          ap_accept_lock_mech = APR_LOCK_PROC_PTHREAD;
>      }
>  #endif
> @@ -621,7 +621,7 @@
>                             ", sysvsem"
>  #endif
>  #if APR_HAS_PROC_PTHREAD_SERIALIZE
> -                           ", proc_pthread"
> +                           ", pthread"
>  #endif
>                             , NULL);
>      }

-- 

______________________________________________________________
Ryan Bloom				rbb@apache.org
Covalent Technologies			rbb@covalent.net
--------------------------------------------------------------