You are viewing a plain text version of this content. The canonical link for it is here.
Posted to m2-dev@maven.apache.org by "Brett Porter (JIRA)" <ji...@codehaus.org> on 2005/03/22 14:22:47 UTC

[jira] Created: (MNG-221) simplify mojo qdox specification

simplify mojo qdox specification
--------------------------------

         Key: MNG-221
         URL: http://jira.codehaus.org/browse/MNG-221
     Project: m2
        Type: Improvement
  Components: maven-plugin-tools  
    Reporter: Brett Porter


now that these are mapped to fields, the name, type and default value can be derived from the field definition instead, simplifying the rest.

validator should no longer be necessary.

The other parameter attributes (required, expression) could be specified on the field themselves. Description can be the javadoc

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


[jira] Commented: (MNG-221) simplify mojo qdox specification

Posted by "Emmanuel Venisse (JIRA)" <ji...@codehaus.org>.
     [ http://jira.codehaus.org/browse/MNG-221?page=comments#action_31439 ]
     
Emmanuel Venisse commented on MNG-221:
--------------------------------------

We can change the plugin parameter definition from class comment to field
comment for obtain a more readable source.

Actually, we have for class :
/**
 ...
 * @parameter name="outputDirectory"
 * type="String"
 * required="true"
 * validator=""
 * expression="#project.build.outputDirectory"
 * description=""
 ...
 */

Can we replace it by :

/**
 * Description is here like a javadoc comment
 * @parameter
 * alias="optional name that replace the field name"
 * required="true"
 * validator=""
 * expression=="#project.build.outputDirectory"
 */
 String outputDirectory="aDefaultValue";

for field.

=> the type isn't an attribute of parameter but the type of field

I'm not sure if it's possible for inherited classes with inherited parameter field.


> simplify mojo qdox specification
> --------------------------------
>
>          Key: MNG-221
>          URL: http://jira.codehaus.org/browse/MNG-221
>      Project: m2
>         Type: Improvement
>   Components: maven-plugin-tools
>     Reporter: Brett Porter
>      Fix For: 1.0-alpha-2

>
>
> now that these are mapped to fields, the name, type and default value can be derived from the field definition instead, simplifying the rest.
> validator should no longer be necessary.
> The other parameter attributes (required, expression) could be specified on the field themselves. Description can be the javadoc

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


[jira] Updated: (MNG-221) simplify mojo qdox specification

Posted by "Brett Porter (JIRA)" <ji...@codehaus.org>.
     [ http://jira.codehaus.org/browse/MNG-221?page=history ]

Brett Porter updated MNG-221:
-----------------------------

    Fix Version: 1.0-alpha-2

slating for alpha-2 as we wil need to nail down the mojo interface

> simplify mojo qdox specification
> --------------------------------
>
>          Key: MNG-221
>          URL: http://jira.codehaus.org/browse/MNG-221
>      Project: m2
>         Type: Improvement
>   Components: maven-plugin-tools
>     Reporter: Brett Porter
>      Fix For: 1.0-alpha-2

>
>
> now that these are mapped to fields, the name, type and default value can be derived from the field definition instead, simplifying the rest.
> validator should no longer be necessary.
> The other parameter attributes (required, expression) could be specified on the field themselves. Description can be the javadoc

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira