You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "HBase Review Board (JIRA)" <ji...@apache.org> on 2010/11/10 08:58:35 UTC

[jira] Commented: (HBASE-3161) Provide option for Stargate to only serve GET requests

    [ https://issues.apache.org/jira/browse/HBASE-3161?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12930543#action_12930543 ] 

HBase Review Board commented on HBASE-3161:
-------------------------------------------

Message from: "Bennett Neale" <be...@gmail.com>

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://review.cloudera.org/r/1204/
-----------------------------------------------------------

Review request for hbase.


Summary
-------

Provided an option to pass a "read-only" argument when starting up the REST server based on the comments provided by apurtell.  Server will only honor GET HTTP method requests in this mode.  Also added "hbase.rest.port" and "hbase.rest.readonly" to the config hbase-default.xml and updated test cases.  


apurtell -- "Add a helper function to RestServlet that checks the configuration, i.e. RestServlet#isReadOnly and use it to do a check at the top of methods tagged with @PUT or @POST, or the common functions they call out to, and if read only do throw new WebApplicationException(Response.Status.FORBIDDEN)."


This addresses bug HBASE-3161.
    http://issues.apache.org/jira/browse/HBASE-3161


Diffs
-----

  /trunk/src/main/java/org/apache/hadoop/hbase/rest/Constants.java 1033370 
  /trunk/src/main/java/org/apache/hadoop/hbase/rest/Main.java 1033370 
  /trunk/src/main/java/org/apache/hadoop/hbase/rest/RESTServlet.java 1033370 
  /trunk/src/main/java/org/apache/hadoop/hbase/rest/RowResource.java 1033370 
  /trunk/src/main/java/org/apache/hadoop/hbase/rest/ScannerInstanceResource.java 1033370 
  /trunk/src/main/java/org/apache/hadoop/hbase/rest/ScannerResource.java 1033370 
  /trunk/src/main/java/org/apache/hadoop/hbase/rest/SchemaResource.java 1033370 
  /trunk/src/main/resources/hbase-default.xml 1033370 
  /trunk/src/test/java/org/apache/hadoop/hbase/rest/TestRowResource.java 1033370 
  /trunk/src/test/java/org/apache/hadoop/hbase/rest/TestScannerResource.java 1033370 
  /trunk/src/test/java/org/apache/hadoop/hbase/rest/TestSchemaResource.java 1033370 

Diff: http://review.cloudera.org/r/1204/diff


Testing
-------


Thanks,

Bennett




> Provide option for Stargate to only serve GET requests
> ------------------------------------------------------
>
>                 Key: HBASE-3161
>                 URL: https://issues.apache.org/jira/browse/HBASE-3161
>             Project: HBase
>          Issue Type: Improvement
>          Components: rest
>    Affects Versions: 0.20.6
>            Reporter: Ted Yu
>
> Provide option for Stargate to only serve GET requests. Hbase health check can utilize this option.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.