You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@velocity.apache.org by "Jarkko Viinamäki (JIRA)" <de...@velocity.apache.org> on 2009/01/20 20:20:59 UTC

[jira] Commented: (VELOCITY-672) add '#for' as a synonym for '#foreach'

    [ https://issues.apache.org/jira/browse/VELOCITY-672?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12665508#action_12665508 ] 

Jarkko Viinamäki commented on VELOCITY-672:
-------------------------------------------

I'd prefer to keep the amount of directives to minimum. I can't see any real benefits of this alias. It just creates a need for additional documentation, tests and requires new lines of code in the parser. Foreach is consistent with several other scripting languages.

> add '#for' as a synonym for '#foreach'
> --------------------------------------
>
>                 Key: VELOCITY-672
>                 URL: https://issues.apache.org/jira/browse/VELOCITY-672
>             Project: Velocity
>          Issue Type: Improvement
>          Components: Engine
>            Reporter: Byron Foster
>            Priority: Minor
>             Fix For: 1.7
>
>
> Add 'for' as a synonym for 'foreach'  such as:
> #for ($order in $orders)
>   $order.price
> #end

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@velocity.apache.org
For additional commands, e-mail: dev-help@velocity.apache.org