You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ant.apache.org by Steve Loughran <st...@iseran.com> on 2002/05/20 07:32:27 UTC

the tomcat 4.1 ant tasks

..finally took a look at the new tomcat deployment tasks; they look pretty
good:

http://jakarta.apache.org/tomcat/tomcat-4.1-doc/manager-howto.html#Executing
%20Manager%20Commands%20With%20Ant

If I have one concern (that i have filed with them), it is that they are
using generic names that effectively stop us from using the same tasknames
ourselves.


  <taskdef name="deploy"    classname="org.apache.catalina.ant.DeployTask"/>
  <taskdef name="install"
classname="org.apache.catalina.ant.InstallTask"/>
  <taskdef name="list"      classname="org.apache.catalina.ant.ListTask"/>
  <taskdef name="reload"    classname="org.apache.catalina.ant.ReloadTask"/>
  <taskdef name="remove"    classname="org.apache.catalina.ant.RemoveTask"/>
  <taskdef name="resources"
classname="org.apache.catalina.ant.ResourcesTask"/>
  <taskdef name="roles"     classname="org.apache.catalina.ant.RolesTask"/>
  <taskdef name="start"     classname="org.apache.catalina.ant.StartTask"/>
  <taskdef name="stop"      classname="org.apache.catalina.ant.StopTask"/>
  <taskdef name="undeploy"
classname="org.apache.catalina.ant.UndeployTask"/>

I am thinking, maybe we should intro the notion of 'reserved' tasknames,
binding them to a reserved task that simply throws a 'reserved' exception if
used. That way in ant1.5 we can pencil out a few task names that we have
plans for in the near future, without creating conflicts down the wire.

-steve



--


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: the tomcat 4.1 ant tasks

Posted by Adam Murdoch <ad...@apache.org>.
On Mon, 20 May 2002 15:32, Steve Loughran wrote:
>
> I am thinking, maybe we should intro the notion of 'reserved' tasknames,
> binding them to a reserved task that simply throws a 'reserved' exception
> if used. That way in ant1.5 we can pencil out a few task names that we have
> plans for in the near future, without creating conflicts down the wire.

Some kind of namespace support might be a better option (for ant1.6, that is).  
Then we don't have to try to guess which names we need to reserve.  We just 
use whatever names we need to, and the namespace stuff provides a way to 
reference the tasks when there's collisions.

-- 
Adam

--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: the tomcat 4.1 ant tasks

Posted by Steve Loughran <st...@iseran.com>.
----- Original Message -----
From: "Erik Hatcher" <ja...@ehatchersolutions.com>
To: "Ant Developers List" <an...@jakarta.apache.org>
Sent: Monday, May 20, 2002 11:22 AM
Subject: Re: the tomcat 4.1 ant tasks


> It sure would be nice if the Tomcat folks built a properties file that is
> included in the distribution so only one <taskdef> is needed rather than
all
> of those shown there.  Anyone from there listening?!  :)
>
>     Erik
>

They are certainly listening, as remy wontfixed my 'please rename' bugrep
(http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9242) with

"I am not in favor of fixing this, as it's not a clean solution. Rather, I
think
Ant should add namespace support, as is currently being discussed on the
ant-dev
mailing list."

IMO the fact that we should do a long term solution does not obviate the
need to use sensible names for your tasks, and the tomcat 4.1 set have just
laid claim to some core verbs <deploy>, <list>. They are lucky we chose the
more verbose <serverdeploy> for our own deployment tasks.

Well, I suppose if we break anything, we know where to direct the bug
reports.

-steve


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>


Re: the tomcat 4.1 ant tasks

Posted by Erik Hatcher <ja...@ehatchersolutions.com>.
It sure would be nice if the Tomcat folks built a properties file that is
included in the distribution so only one <taskdef> is needed rather than all
of those shown there.  Anyone from there listening?!  :)

    Erik


----- Original Message -----
From: "Steve Loughran" <st...@iseran.com>
To: "ant-dev" <an...@jakarta.apache.org>
Sent: Monday, May 20, 2002 1:32 AM
Subject: the tomcat 4.1 ant tasks


> ..finally took a look at the new tomcat deployment tasks; they look pretty
> good:
>
>
http://jakarta.apache.org/tomcat/tomcat-4.1-doc/manager-howto.html#Executing
> %20Manager%20Commands%20With%20Ant
>
> If I have one concern (that i have filed with them), it is that they are
> using generic names that effectively stop us from using the same tasknames
> ourselves.
>
>
>   <taskdef name="deploy"
classname="org.apache.catalina.ant.DeployTask"/>
>   <taskdef name="install"
> classname="org.apache.catalina.ant.InstallTask"/>
>   <taskdef name="list"      classname="org.apache.catalina.ant.ListTask"/>
>   <taskdef name="reload"
classname="org.apache.catalina.ant.ReloadTask"/>
>   <taskdef name="remove"
classname="org.apache.catalina.ant.RemoveTask"/>
>   <taskdef name="resources"
> classname="org.apache.catalina.ant.ResourcesTask"/>
>   <taskdef name="roles"
classname="org.apache.catalina.ant.RolesTask"/>
>   <taskdef name="start"
classname="org.apache.catalina.ant.StartTask"/>
>   <taskdef name="stop"      classname="org.apache.catalina.ant.StopTask"/>
>   <taskdef name="undeploy"
> classname="org.apache.catalina.ant.UndeployTask"/>
>
> I am thinking, maybe we should intro the notion of 'reserved' tasknames,
> binding them to a reserved task that simply throws a 'reserved' exception
if
> used. That way in ant1.5 we can pencil out a few task names that we have
> plans for in the near future, without creating conflicts down the wire.
>
> -steve
>
>
>
> --
>
>
> --
> To unsubscribe, e-mail:   <ma...@jakarta.apache.org>

> For additional commands, e-mail: <ma...@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <ma...@jakarta.apache.org>
For additional commands, e-mail: <ma...@jakarta.apache.org>