You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@buildstream.apache.org by ro...@apache.org on 2020/12/29 13:28:37 UTC

[buildstream] 01/01: Bump coverage requirement to something >= 5.0

This is an automated email from the ASF dual-hosted git repository.

root pushed a commit to branch jjardon/update_coverage
in repository https://gitbox.apache.org/repos/asf/buildstream.git

commit 469f7e7ad4ab75d131bb27310c8956d71b8c62f3
Author: Javier Jardón <jj...@gnome.org>
AuthorDate: Sun Apr 5 11:57:42 2020 +0100

    Bump coverage requirement to something >= 5.0
    
    Following
    https://coverage.readthedocs.io/en/coverage-5.0.4/changes.html#changes:
    
    - Only 5.0a2 pass all python3.8 tests
    - Multiprocessing support in Python 3.8 was fixed in 5.0a6
---
 requirements/cov-requirements.in  | 2 +-
 requirements/cov-requirements.txt | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/requirements/cov-requirements.in b/requirements/cov-requirements.in
index fb582f8..cde964c 100644
--- a/requirements/cov-requirements.in
+++ b/requirements/cov-requirements.in
@@ -1,3 +1,3 @@
-coverage == 4.4.0
+coverage >= 5.0
 pytest-cov >= 2.5.0
 Cython
diff --git a/requirements/cov-requirements.txt b/requirements/cov-requirements.txt
index c700aba..9ede3ab 100644
--- a/requirements/cov-requirements.txt
+++ b/requirements/cov-requirements.txt
@@ -1,4 +1,4 @@
-coverage==4.4
+coverage==5.0.4
 pytest-cov==2.8.1
 Cython==0.29.14
 ## The following requirements were added by pip freeze: