You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@knox.apache.org by "Sandor Molnar (Jira)" <ji...@apache.org> on 2026/02/24 08:09:00 UTC
[jira] [Updated] (KNOX-3261) Avoid code duplication in grant type flow logic
[ https://issues.apache.org/jira/browse/KNOX-3261?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Sandor Molnar updated KNOX-3261:
--------------------------------
Fix Version/s: 3.0.0
> Avoid code duplication in grant type flow logic
> -----------------------------------------------
>
> Key: KNOX-3261
> URL: https://issues.apache.org/jira/browse/KNOX-3261
> Project: Apache Knox
> Issue Type: Improvement
> Reporter: Sandor Molnar
> Assignee: Sandor Molnar
> Priority: Major
> Fix For: 3.0.0
>
>
> KNOX-3259 added an important feature which extends the previous client_credentials support in JWTProvider with token_exchange and refresh_token grant types. This was a great addition.
> In the respective PR I indicated that we can refactor the code to avoid code duplication. We agreed with [~lmccay] , that it's ok to merge those PRs and address the code duplication as a separate work item.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)