You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@airavata.apache.org by "ASF subversion and git services (Jira)" <ji...@apache.org> on 2019/12/05 19:58:00 UTC

[jira] [Commented] (AIRAVATA-3268) BUG: The input file name cannot be changed using value field content in application interface

    [ https://issues.apache.org/jira/browse/AIRAVATA-3268?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16989112#comment-16989112 ] 

ASF subversion and git services commented on AIRAVATA-3268:
-----------------------------------------------------------

Commit 53bd78197c18f4f218146c2934dc162ab3ac670d in airavata-django-portal's branch refs/heads/develop from Marcus Christie
[ https://gitbox.apache.org/repos/asf?p=airavata-django-portal.git;h=53bd781 ]

AIRAVATA-3268 Add overrideFilename for URI type inputs


> BUG: The input file name cannot be changed using value field content in application interface
> ---------------------------------------------------------------------------------------------
>
>                 Key: AIRAVATA-3268
>                 URL: https://issues.apache.org/jira/browse/AIRAVATA-3268
>             Project: Airavata
>          Issue Type: Sub-task
>          Components: Django Portal
>    Affects Versions: 0.18
>            Reporter: Eroma
>            Assignee: Marcus Christie
>            Priority: Critical
>             Fix For: 0.19
>
>
> 1. When creating application inputs in Interface tab user can have the uploading file name changed to the value given in "Value" field.
> 2. This new assigned name will be the one that get added to the job script as well as the name of the file when the file is in the compute resource working directory.
> h5. TODO
> - [x] model/db changes
> - [x] db migration script to copy input.value to input.overrideFilename
> - [ ] Django frontend changes



--
This message was sent by Atlassian Jira
(v8.3.4#803005)