You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@tuscany.apache.org by Jean-Sebastien Delfino <js...@apache.org> on 2007/01/13 23:12:10 UTC

Re: Heads-up - changing CompositeContext interface

Jean-Sebastien Delfino wrote:
> Raymond Feng wrote:
>> Hi,
>>
>> You first need to configure the ssh in <user.home>/.m2/settings.xml 
>> with the following content:
>>
>> <?xml version="1.0" encoding="UTF-8"?>
>> <settings>
>>    <servers>
>>    <server>
>>      <id>apache.snapshots</id>
>>      <username>your_apache_id</username>
>>      <!-- Default value is ~/.ssh/id_dsa -->
>>      <privateKey><user.home>\.ssh\id_dsa</privateKey>
>>      <passphrase>your_password</passphrase>
>>    </server>
>>    </servers>
>> </settings>
>>
>> Then you can run "mvn deploy" under the modules to upload the 
>> SNAPSHOT version of the artifact.
>>
>> Thanks,
>> Raymond
>>
>> ----- Original Message ----- From: "Jean-Sebastien Delfino" 
>> <js...@apache.org>
>> To: <tu...@ws.apache.org>
>> Sent: Thursday, January 11, 2007 8:52 AM
>> Subject: Re: CompositeContext method names
>>
>>
>>> Jeremy Boynes wrote:
>>>> Can't be sure without seeing the changes - including a patch would 
>>>> be helpful.
>>>>
>>>> In general, this sounds like an incompatible change (it's renaming 
>>>> methods) so republishing the snapshots would be a good move. If it 
>>>> was a less intrusive change (e.g. adding a method) then just 
>>>> committing would be enough.
>>>>
>>>> -- 
>>>> Jeremy
>>>>
>>>> On Jan 10, 2007, at 5:56 PM, Jean-Sebastien Delfino wrote:
>>>>
>>>>> Jean-Sebastien Delfino wrote:
>>>>>> Jim Marino wrote:
>>>>>>>
>>>>>>> On Jan 8, 2007, at 4:26 PM, Jean-Sebastien Delfino wrote:
>>>>>>>
>>>>>>>> The names of some of the methods on 
>>>>>>>> org.osoa.sca.CompositeContext do not match the API described in 
>>>>>>>> the 0.95 Java SCA C&I specification (this was reported as 
>>>>>>>> http://issues.apache.org/jira/browse/TUSCANY-909).
>>>>>>>>
>>>>>>>> I have checked the latest SCA spec docs and the spec mailing 
>>>>>>>> lists and could not find any indication that the names on our 
>>>>>>>> definition of CompositeContext are the correct ones. I'm 
>>>>>>>> planning on making the following changes:
>>>>>>>> - rename getCompositeName() to getName()
>>>>>>>> - rename getCompositeURI() to getURI()
>>>>>>>>
>>>>>>>> Jim, you've been following this more closely than me, is this 
>>>>>>>> the right change? are the spec documents up to date and our 
>>>>>>>> code needs to be adjusted? or is it the other way around?
>>>>>>>>
>>>>>>> Those have not changed to my knowledge (or at least I can't 
>>>>>>> remember), so it is probably a simple oversight on our part. 
>>>>>>> There are a number of changes where the spec needs to be updated 
>>>>>>> in other areas (e.g. scopes), that I'm in the process of doing now.
>>>>>>>
>>>>>>> Jim
>>>>>>>
>>>>>>>> Thanks,
>>>>>>>>
>>>>>>>> --Jean-Sebastien
>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>> OK thanks! I'll make the code match the spec then :)
>>>>>>
>>>>>
>>>>> I have the changes ready, affecting CompositeContext in the 
>>>>> spec/sca project and 3 other classes in kernel. What is the best 
>>>>> way to apply the changes? Is committing the spec and kernel 
>>>>> changes sufficient? or do I need to republish the spec and kernel 
>>>>> snapshots?
>>>>>
>>>>> Thanks,
>>>>>
>>>>> --Jean-Sebastien
>>>>>
>>>>>
>>>
>>> I have attached a patch to JIRA TUSCANY-909. The change is trivial, 
>>> except for the fact that it affects two different modules, spec and 
>>> kernel. Could somebody post here how to republish the snapshots and 
>>> I'll try to do it. Thanks.
>>>
>>> -- 
>>> Jean-Sebastien
>>>
>>>
>
> Thanks Raymond,
>
> This is a heads-up that I'm going to commit the changes in the patch 
> attached to JIRA http://issues.apache.org/jira/browse/TUSCANY-909 and 
> republish sca-api-r0.95-1.0-incubator-SNAPSHOT.jar and 
> core-1.0-incubator-SNAPSHOT.jar to incorporate these changes.
>
> CompositeContext.getCompositeName() will be renamed to 
> CompositeContext.getName()
> CompositeContext.getCompositeURI() will be renamed to 
> CompositeContext.getURI()
>
> This will bring CompositeContext in line with the SCA Java C&I 
> specification 0.95.
>
> A build of tuscany/java with the "all" profile did not report any 
> error, but I am sending this heads-up as this is a potentially 
> breaking interface change.
>
> If there's no objection I will apply the changes and republish the 
> snapshots tomorrow.
>

I have committed the changes under revision r495979.

I have republished corresponding snapshot jars of the spec SCA API and 
the Tuscany Kernel core module:
http://people.apache.org/repo/m2-snapshot-repository/org/osoa/sca-api-r0.95/1.0-incubator-SNAPSHOT/
http://people.apache.org/repo/m2-snapshot-repository/org/apache/tuscany/sca/kernel/core/1.0-incubator-SNAPSHOT/

-- 
Jean-Sebastien


---------------------------------------------------------------------
To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: tuscany-dev-help@ws.apache.org


Re: Heads-up - changing CompositeContext interface

Posted by Jeremy Boynes <jb...@apache.org>.
On Jan 17, 2007, at 3:32 PM, Jean-Sebastien Delfino wrote:

> Jeremy Boynes wrote:
>> On Jan 13, 2007, at 2:12 PM, Jean-Sebastien Delfino wrote:
>>
>>>
>>> I have committed the changes under revision r495979.
>>>
>>> I have republished corresponding snapshot jars of the spec SCA  
>>> API and the Tuscany Kernel core module:
>>> http://people.apache.org/repo/m2-snapshot-repository/org/osoa/sca- 
>>> api-r0.95/1.0-incubator-SNAPSHOT/
>>> http://people.apache.org/repo/m2-snapshot-repository/org/apache/ 
>>> tuscany/sca/kernel/core/1.0-incubator-SNAPSHOT/
>>
>> Please can you fix the group permissions on the uploaded files so  
>> that others can update them:
>> -rw-r--r--  1 jsdelfino  apcvs  28405 Jan 13 13:58 sca-api- 
>> r0.95-1.0-incubator-20070113.215809-1.jar
>>
>> You can get mvn to do this for you by configuring it in your  
>> settings.xml file:
>>     <server>
>>       <id>apache.snapshots</id>
>>       <directoryPermissions>775</directoryPermissions>
>>       <filePermissions>664</filePermissions>
>>     </server>
>>
>> Thanks
>> -- 
>> Jeremy
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
>> For additional commands, e-mail: tuscany-dev-help@ws.apache.org
>>
>>
>
> Done. I think I fixed all the permissions but let me know if I  
> missed any. Thanks.

Thanks - I've deployed a new snapshot which adds setContext to  
CurrentCompositeContext (r497187)
--
Jeremy

---------------------------------------------------------------------
To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: tuscany-dev-help@ws.apache.org


Re: Heads-up - changing CompositeContext interface

Posted by Jean-Sebastien Delfino <js...@apache.org>.
Jeremy Boynes wrote:
> On Jan 13, 2007, at 2:12 PM, Jean-Sebastien Delfino wrote:
>
>>
>> I have committed the changes under revision r495979.
>>
>> I have republished corresponding snapshot jars of the spec SCA API 
>> and the Tuscany Kernel core module:
>> http://people.apache.org/repo/m2-snapshot-repository/org/osoa/sca-api-r0.95/1.0-incubator-SNAPSHOT/ 
>>
>> http://people.apache.org/repo/m2-snapshot-repository/org/apache/tuscany/sca/kernel/core/1.0-incubator-SNAPSHOT/ 
>>
>
> Please can you fix the group permissions on the uploaded files so that 
> others can update them:
> -rw-r--r--  1 jsdelfino  apcvs  28405 Jan 13 13:58 
> sca-api-r0.95-1.0-incubator-20070113.215809-1.jar
>
> You can get mvn to do this for you by configuring it in your 
> settings.xml file:
>     <server>
>       <id>apache.snapshots</id>
>       <directoryPermissions>775</directoryPermissions>
>       <filePermissions>664</filePermissions>
>     </server>
>
> Thanks
> -- 
> Jeremy
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: tuscany-dev-help@ws.apache.org
>
>

Done. I think I fixed all the permissions but let me know if I missed 
any. Thanks.

-- 
Jean-Sebastien


---------------------------------------------------------------------
To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: tuscany-dev-help@ws.apache.org


Re: Heads-up - changing CompositeContext interface

Posted by Jeremy Boynes <jb...@apache.org>.
On Jan 13, 2007, at 2:12 PM, Jean-Sebastien Delfino wrote:

>
> I have committed the changes under revision r495979.
>
> I have republished corresponding snapshot jars of the spec SCA API  
> and the Tuscany Kernel core module:
> http://people.apache.org/repo/m2-snapshot-repository/org/osoa/sca- 
> api-r0.95/1.0-incubator-SNAPSHOT/
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/ 
> tuscany/sca/kernel/core/1.0-incubator-SNAPSHOT/

Please can you fix the group permissions on the uploaded files so  
that others can update them:
-rw-r--r--  1 jsdelfino  apcvs  28405 Jan 13 13:58 sca-api-r0.95-1.0- 
incubator-20070113.215809-1.jar

You can get mvn to do this for you by configuring it in your  
settings.xml file:
     <server>
       <id>apache.snapshots</id>
       <directoryPermissions>775</directoryPermissions>
       <filePermissions>664</filePermissions>
     </server>

Thanks
--
Jeremy


---------------------------------------------------------------------
To unsubscribe, e-mail: tuscany-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: tuscany-dev-help@ws.apache.org