You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@commons.apache.org by bo...@apache.org on 2020/05/23 15:55:23 UTC

[commons-compress] branch master updated (46a5be1 -> c3f6b4a)

This is an automated email from the ASF dual-hosted git repository.

bodewig pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/commons-compress.git.


    from 46a5be1  COMPRESS-520 record fix
     new 9e42387  COMPRESS-514 make error message easier to read
     new c3f6b4a  COMPRESS-514 7z UINT64 may turn out to become negative longs

The 2 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 .../java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


[commons-compress] 02/02: COMPRESS-514 7z UINT64 may turn out to become negative longs

Posted by bo...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

bodewig pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-compress.git

commit c3f6b4a5eab979d6e8fac632381b09469c0f9405
Author: Stefan Bodewig <bo...@apache.org>
AuthorDate: Sat May 23 17:52:25 2020 +0200

    COMPRESS-514 7z UINT64 may turn out to become negative longs
---
 .../java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java b/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java
index 9ba9b02..e8f0dce 100644
--- a/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java
+++ b/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java
@@ -1614,7 +1614,7 @@ public class SevenZFile implements Closeable {
     }
 
     private static void assertFitsIntoInt(String what, long value) throws IOException {
-        if (value > Integer.MAX_VALUE) {
+        if (value > Integer.MAX_VALUE || value < Integer.MIN_VALUE) {
             throw new IOException("Cannot handle " + what + " " + value);
         }
     }


[commons-compress] 01/02: COMPRESS-514 make error message easier to read

Posted by bo...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

bodewig pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-compress.git

commit 9e4238713c9a8f9ef16edb1022f81531a705adbc
Author: Stefan Bodewig <bo...@apache.org>
AuthorDate: Sat May 23 17:51:23 2020 +0200

    COMPRESS-514 make error message easier to read
---
 .../java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java b/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java
index 5de9667..9ba9b02 100644
--- a/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java
+++ b/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java
@@ -1615,7 +1615,7 @@ public class SevenZFile implements Closeable {
 
     private static void assertFitsIntoInt(String what, long value) throws IOException {
         if (value > Integer.MAX_VALUE) {
-            throw new IOException("Cannot handle " + what + value);
+            throw new IOException("Cannot handle " + what + " " + value);
         }
     }
 }