You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Ufuk Celebi (JIRA)" <ji...@apache.org> on 2015/09/22 23:36:04 UTC

[jira] [Created] (FLINK-2741) Use single log statement in TestLogger

Ufuk Celebi created FLINK-2741:
----------------------------------

             Summary: Use single log statement in TestLogger
                 Key: FLINK-2741
                 URL: https://issues.apache.org/jira/browse/FLINK-2741
             Project: Flink
          Issue Type: Improvement
          Components: Tests
    Affects Versions: master
            Reporter: Ufuk Celebi
            Priority: Trivial


{{TestLogger}} prints log statements before and after tests. Currently this is done via multiple {{log.info}} statements. Sometimes this leads to interleaved output with failure stack traces.

I would like to change it to a single statements with new lines:

{code}
17:30:31,887 ERROR A  - ---------------------------------------------
17:30:31,891 INFO  B  - Shutting down remote daemon.
17:30:31,895 ERROR A  - Test testJobManagerCleanUp(A) failed with:
...
17:30:31,909 ERROR A  - =============================================
{code}

to

{code}
17:30:31,891 INFO  B  - Shutting down remote daemon.
17:30:31,887 ERROR A  -
---------------------------------------------------------------------
Test testJobManagerCleanUp(A) failed with:
...
=====================================================================
{code}

Any opinions? Does this improve readability?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)