You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Steve Loughran (JIRA)" <ji...@apache.org> on 2019/01/02 22:43:00 UTC

[jira] [Commented] (HADOOP-16022) Increase Compression Buffer Sizes - Remove Magic Numbers

    [ https://issues.apache.org/jira/browse/HADOOP-16022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16732485#comment-16732485 ] 

Steve Loughran commented on HADOOP-16022:
-----------------------------------------

Breaks a couple of tests I'm afraid, probably the tests themselves being brittle.

Fix that up and this will be OK to go in

> Increase Compression Buffer Sizes - Remove Magic Numbers
> --------------------------------------------------------
>
>                 Key: HADOOP-16022
>                 URL: https://issues.apache.org/jira/browse/HADOOP-16022
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: io
>    Affects Versions: 2.10.0, 3.2.0
>            Reporter: BELUGA BEHR
>            Assignee: BELUGA BEHR
>            Priority: Minor
>         Attachments: HADOOP-16022.1.patch
>
>
> {code:java|title=Compression.java}
>     // data input buffer size to absorb small reads from application.
>     private static final int DATA_IBUF_SIZE = 1 * 1024;
>     // data output buffer size to absorb small writes from application.
>     private static final int DATA_OBUF_SIZE = 4 * 1024;
> {code}
> There exists these hard coded buffer sizes in the Compression code.  Instead, use the JVM default sizes, which, this day and age, are usually set for 8K.
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org