You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@httpd.apache.org by Bill Stoddard <bi...@wstoddard.com> on 2003/05/16 16:18:11 UTC

Rename EXPIRATION filter to MOD_EXPIRES?

I think we need to namespace protect this filter. How about changing the name from EXPIRATION to MOD_EXPIRES? (thanks to Jeff for the suggestion)?

Bill

coar        2003/05/14 10:39:14

  Modified:    modules/metadata mod_expires.c
  Log:
  	if there are any ExpiresByType directives for the current
  	scope, defer the setting of the expiration header fields
  	to an output filter, which can then apply any ExpiresByType
  	or ExpiresDefault settings -- including to dynamic documents.
  
  Revision  Changes    Path
  1.41      +145 -50   httpd-2.0/modules/metadata/mod_expires.c
  
<snip>

   static void register_hooks(apr_pool_t *p)
   {
  +    ap_register_output_filter("EXPIRATION", expires_by_type_filter, NULL,
  +                              AP_FTYPE_CONTENT_SET);
       ap_hook_fixups(add_expires,NULL,NULL,APR_HOOK_MIDDLE);
   }