You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cassandra.apache.org by "Jonathan Ellis (JIRA)" <ji...@apache.org> on 2009/04/03 23:45:13 UTC

[jira] Commented: (CASSANDRA-52) Clean up SequenceFile.next to prep for partitioning refactor

    [ https://issues.apache.org/jira/browse/CASSANDRA-52?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12695606#action_12695606 ] 

Jonathan Ellis commented on CASSANDRA-52:
-----------------------------------------

9    combine overloads of SSTable.next; inline getData

8    combine next / getData overloads

7    merge common parts of next(timeRange) and next(columnNames)

6    emphasize that when getting a time-based slice only the CF name is used

5    semantics of TimeFilter (include all columns newer than some timestamp) mean we should use Long.MAX_VALUE as upper range, not current ms

4    refactor SF.next(String key, DataOutputBuffer bufOut, String cf, Coordinate section) to call its overload to reduce code duplication.  this will make auditing the partitioner changes easier.

3    r/m no-op seeks

2    reformat code (mostly whitespace changes) to keep subsequent patches clean

1    CASSANDRA-52 write get_columns_since test to exercise sequenceFile.next(timeRange)


> Clean up SequenceFile.next to prep for partitioning refactor
> ------------------------------------------------------------
>
>                 Key: CASSANDRA-52
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-52
>             Project: Cassandra
>          Issue Type: Improvement
>            Reporter: Jonathan Ellis
>         Attachments: 0001-CASSANDRA-52-write-get_columns_since-test-to-exercise.txt, 0002-reformat-code-mostly-whitespace-changes-to-keep-subs.txt, 0003-r-m-no-op-seeks.txt, 0004-refactor-SF.next-String-key-DataOutputBuffer-bufOut.txt, 0005-semantics-of-TimeFilter-include-all-columns-newer-tha.txt, 0006-emphasize-that-when-getting-a-time-based-slice-only-th.txt, 0007-merge-common-parts-of-next-timeRange-and-next-columnN.txt, 0008-combine-next-getData-overloads.txt, 0009-combine-overloads-of-SSTable.next-inline-getData.txt
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.