You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Pavel Pereslegin (Jira)" <ji...@apache.org> on 2025/12/05 06:18:00 UTC
[jira] [Commented] (IGNITE-27218) Jdbc. Add units of measurement to connection property names
[ https://issues.apache.org/jira/browse/IGNITE-27218?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18042977#comment-18042977 ]
Pavel Pereslegin commented on IGNITE-27218:
-------------------------------------------
[~mzhuravkov], please do a review.
> Jdbc. Add units of measurement to connection property names
> -----------------------------------------------------------
>
> Key: IGNITE-27218
> URL: https://issues.apache.org/jira/browse/IGNITE-27218
> Project: Ignite
> Issue Type: Improvement
> Components: jdbc ai3
> Reporter: Pavel Pereslegin
> Assignee: Pavel Pereslegin
> Priority: Major
> Labels: ignite-3
> Fix For: 3.2
>
> Time Spent: 0.5h
> Remaining Estimate: 0h
>
> Currently we have the following properties that define the time interval. {{queryTimeout}}, {{connectionTimeout}}
> Since {{connectionTimeout}} is set in milliseconds, but {{queryTimeout}} for some reason is in seconds, it's better to rename them to include units in their names.
> Naming suggestions:
> {{connectionTimeout}} -> {{connectionTimeoutMillis}}
> {{queryTimeout}} -> {{queryTimeoutSeconds}}
> *Note*: for backward compatibility, we must keep the old names and add new ones
--
This message was sent by Atlassian Jira
(v8.20.10#820010)