You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flink.apache.org by "Jing Ge (Jira)" <ji...@apache.org> on 2022/05/30 18:07:00 UTC

[jira] [Created] (FLINK-27842) Rename ndv to granularityNumber

Jing Ge created FLINK-27842:
-------------------------------

             Summary: Rename ndv to granularityNumber
                 Key: FLINK-27842
                 URL: https://issues.apache.org/jira/browse/FLINK-27842
             Project: Flink
          Issue Type: Improvement
          Components: Table SQL / API
            Reporter: Jing Ge


Currently ndv, which stands for "number of distinct values", is used in ColumnStats. It is difficult to understand the meaning and should use a professional naming instead. 

 

Suggestion:

replace ndv with granularityNumber:

 

The good news is that the method getNdv() did used within Flink which mean the renaming will have very limited impact.

 

ColumnStats {

/** number of distinct values. */

@Deprecated
private final Long ndv;

 

/**Granularity refers to the level of details used to sort and separate data at column level. Highly granular data is categorized or separated very precisely. For example, the granularity number of gender column is normally 2. In SQL world, it means the number of distinct values. */ 

private final Long granularityNumber;

 

@Deprecated
public Long getNdv() {
return ndv;
}

 

public Long getGranularityNumber() {
return granularityNumber;
}

}

 



--
This message was sent by Atlassian Jira
(v8.20.7#820007)