You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "Chesnay Schepler (JIRA)" <ji...@apache.org> on 2016/06/22 10:13:58 UTC

[jira] [Closed] (FLINK-4076) BoltWrapper#dispose() should call AbstractStreamOperator#dispose()

     [ https://issues.apache.org/jira/browse/FLINK-4076?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chesnay Schepler closed FLINK-4076.
-----------------------------------
       Resolution: Fixed
    Fix Version/s: 1.1.0

Fixed in e7dfa28947f1582ab0b60ab9483b3fe06017f1ff

> BoltWrapper#dispose() should call AbstractStreamOperator#dispose()
> ------------------------------------------------------------------
>
>                 Key: FLINK-4076
>                 URL: https://issues.apache.org/jira/browse/FLINK-4076
>             Project: Flink
>          Issue Type: Bug
>            Reporter: Ted Yu
>            Priority: Minor
>             Fix For: 1.1.0
>
>
> {code}
>   @Override
>   public void dispose() {
>     this.bolt.cleanup();
>   }
> {code}
> AbstractStreamOperator#dispose() should be called first.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)