You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@reef.apache.org by "Sergiy Matusevych (JIRA)" <ji...@apache.org> on 2016/08/14 04:53:20 UTC

[jira] [Created] (REEF-1532) Pass Time object instead of numeric timestamp in Timer methods

Sergiy Matusevych created REEF-1532:
---------------------------------------

             Summary: Pass Time object instead of numeric timestamp in Timer methods
                 Key: REEF-1532
                 URL: https://issues.apache.org/jira/browse/REEF-1532
             Project: REEF
          Issue Type: Improvement
          Components: REEF-Common
            Reporter: Sergiy Matusevych
            Assignee: Sergiy Matusevych


Methods in {{Timer}} interface, e.g. {{Timer.isReady()}} accept long timestamp, but in all contexts where the Timer implementations are used, we operate with Time objects. That leads to awkward chain calls, e.g.
{code:java}
timer.getDuration(event.getTimeStamp())
{code}
instead of shorter and more readable and type safe
{code:java}
timer.getDuration(event)
{code}
We propose to deprecate methods that take {{long}} timestamp in release 0.16 in favor of parameters of type {{Time}} and remove old methods in teh subsequent release.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)