You are viewing a plain text version of this content. The canonical link for it is here.
Posted to c-dev@axis.apache.org by "nadir amra (JIRA)" <ji...@apache.org> on 2010/06/03 06:57:57 UTC

[jira] Assigned: (AXIS2C-1384) axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day

     [ https://issues.apache.org/jira/browse/AXIS2C-1384?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

nadir amra reassigned AXIS2C-1384:
----------------------------------

    Assignee: nadir amra

> axutil_date_time_get_date is misnamed, it should be axutil_date_time_get_day
> ----------------------------------------------------------------------------
>
>                 Key: AXIS2C-1384
>                 URL: https://issues.apache.org/jira/browse/AXIS2C-1384
>             Project: Axis2-C
>          Issue Type: Bug
>          Components: util
>    Affects Versions: 1.6.0
>         Environment: all
>            Reporter: Patrick Cosmo
>            Assignee: nadir amra
>            Priority: Minor
>             Fix For: 1.7.0
>
>         Attachments: axutil_date_time.h, date_time.c, date_time_test.c, rand.c
>
>
> when decoding a date, in axutil_date_time.h there is a method for extracting year, month, etc, but not for "day".
>  
> However, there is a method named: axutil_date_time_get_date( ... )
>  
> If you look at the implementation of this in date_time.c, it's actually extracting the day:
>  
> AXIS2_EXTERN int AXIS2_CALL
> axutil_date_time_get_date(
>     axutil_date_time_t *date_time,
>     const axutil_env_t *env)
> {
>     return (date_time->day);
> }
>  
>  
> I think this function should be named axutil_date_time_get_day

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: c-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: c-dev-help@axis.apache.org