You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hc.apache.org by ol...@apache.org on 2024/09/20 15:10:39 UTC

(httpcomponents-website) branch master updated (74430eb -> 1f4614f)

This is an automated email from the ASF dual-hosted git repository.

olegk pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-website.git


 discard 74430eb  Updated project website for HttpCore 5.3 release
     new f2f8da7  Updated project website for HttpCore 5.3 release
     new 1f4614f  Updated project website for HttpClient 5.4 release

This update added new revisions after undoing existing revisions.
That is to say, some revisions that were in the old version of the
branch are not in the new version.  This situation occurs
when a user --force pushes a change and generates a repository
containing something like this:

 * -- * -- B -- O -- O -- O   (74430eb)
            \
             N -- N -- N   refs/heads/master (1f4614f)

You should already have received notification emails for all of the O
revisions, and so the following emails describe only the N revisions
from the common base, B.

Any revisions marked "omit" are not gone; other references still
refer to them.  Any revisions marked "discard" are gone forever.

The 2 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 .../httpcomponents-client-5.3.x/download.md        |  39 -----
 .../httpcomponents-client-5.3.x/examples-async.md  |  78 ---------
 .../examples-reactive.md                           |  25 ---
 .../httpcomponents-client-5.3.x/examples.md        | 107 ------------
 .../markdown/httpcomponents-client-5.3.x/index.md  |  89 ----------
 .../httpcomponents-client-5.3.x/quickstart.md      | 187 ---------------------
 .../android.md                                     |   0
 .../logging.md                                     |   0
 .../migration-guide/index.md                       |   0
 .../migration-guide/migration-to-async-http2.md    |   0
 .../migration-guide/migration-to-async-simple.md   |   0
 .../migration-to-async-streaming.md                |   0
 .../migration-guide/migration-to-classic.md        |   0
 .../migration-guide/preparation.md                 |   0
 .../related-projects.md                            |   0
 src/site/markdown/news.md                          |  59 ++++---
 src/site/markdown/status.md                        |  31 +---
 src/site/resources/.htaccess                       |  12 +-
 .../documentation.links                            |   3 +-
 src/site/site.xml                                  |  37 ++--
 src/site/xdoc/downloads.xml                        |  62 ++-----
 21 files changed, 75 insertions(+), 654 deletions(-)
 delete mode 100644 src/site/markdown/httpcomponents-client-5.3.x/download.md
 delete mode 100644 src/site/markdown/httpcomponents-client-5.3.x/examples-async.md
 delete mode 100644 src/site/markdown/httpcomponents-client-5.3.x/examples-reactive.md
 delete mode 100644 src/site/markdown/httpcomponents-client-5.3.x/examples.md
 delete mode 100644 src/site/markdown/httpcomponents-client-5.3.x/index.md
 delete mode 100644 src/site/markdown/httpcomponents-client-5.3.x/quickstart.md
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/android.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/logging.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/migration-guide/index.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/migration-guide/migration-to-async-http2.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/migration-guide/migration-to-async-simple.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/migration-guide/migration-to-async-streaming.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/migration-guide/migration-to-classic.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/migration-guide/preparation.md (100%)
 rename src/site/markdown/{httpcomponents-client-5.3.x => httpcomponents-client-5.4.x}/related-projects.md (100%)


(httpcomponents-website) 02/02: Updated project website for HttpClient 5.4 release

Posted by ol...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

olegk pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-website.git

commit 1f4614f46aa1408bef45c653860be1ca7623e752
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Fri Sep 20 17:09:24 2024 +0200

    Updated project website for HttpClient 5.4 release
---
 .../httpcomponents-client-5.3.x/download.md        |  39 -----
 .../httpcomponents-client-5.3.x/examples-async.md  |  78 ---------
 .../examples-reactive.md                           |  25 ---
 .../httpcomponents-client-5.3.x/examples.md        | 107 ------------
 .../markdown/httpcomponents-client-5.3.x/index.md  |  89 ----------
 .../httpcomponents-client-5.3.x/quickstart.md      | 187 ---------------------
 .../android.md                                     |   0
 .../logging.md                                     |   0
 .../migration-guide/index.md                       |   0
 .../migration-guide/migration-to-async-http2.md    |   0
 .../migration-guide/migration-to-async-simple.md   |   0
 .../migration-to-async-streaming.md                |   0
 .../migration-guide/migration-to-classic.md        |   0
 .../migration-guide/preparation.md                 |   0
 .../related-projects.md                            |   0
 src/site/markdown/news.md                          |  59 ++++---
 src/site/markdown/status.md                        |  31 +---
 src/site/resources/.htaccess                       |  12 +-
 .../documentation.links                            |   3 +-
 src/site/site.xml                                  |  37 ++--
 src/site/xdoc/downloads.xml                        |  60 ++-----
 21 files changed, 74 insertions(+), 653 deletions(-)

diff --git a/src/site/markdown/httpcomponents-client-5.3.x/download.md b/src/site/markdown/httpcomponents-client-5.3.x/download.md
deleted file mode 100644
index dee6dbb..0000000
--- a/src/site/markdown/httpcomponents-client-5.3.x/download.md
+++ /dev/null
@@ -1,39 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpClient Downloads
-====================
-
-The latest release available for download:
-
-[Release packages](https://hc.apache.org/downloads.cgi) -
-[Release Notes](https://www.apache.org/dist/httpcomponents/httpclient/RELEASE_NOTES-5.3.x.txt) -
-[License](https://www.apache.org/licenses/LICENSE-2.0.html)
-
-Dependency management
----------------------
-
-If you are using a dependency manager for your project such as [Apache Maven](https://maven.apache.org),
-[Gradle](https://gradle.org/) or [Apache Ivy](https://ant.apache.org/projects/ivy.html), you can create a dependency on
-HttpClient modules by using this information:
-
-- [HttpClient](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5)
-- [HttpClient Fluent](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5-fluent)
-- [HttpClient Cache](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5-cache)
-- [HttpClient Windows extensions](https://search.maven.org/artifact/org.apache.httpcomponents.client5/httpclient5-win)
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/examples-async.md b/src/site/markdown/httpcomponents-client-5.3.x/examples-async.md
deleted file mode 100644
index 5526528..0000000
--- a/src/site/markdown/httpcomponents-client-5.3.x/examples-async.md
+++ /dev/null
@@ -1,78 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpClient Examples (Async)
-===========================
-
-- [Asynchronous HTTP exchange](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttpExchange.java)
-
-  This example demonstrates a basic asynchronous HTTP request / response exchange. Response content is buffered in
-  memory for simplicity.
-
-- [Asynchronous HTTP exchange with content streaming](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttpExchangeStreaming.java)
-
-  This example demonstrates an asynchronous HTTP request / response exchange with a full content streaming.
-
-- [Pipelined HTTP/1.1 exchanges](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientHttp1Pipelining.java)
-
-  This example demonstrates a pipelined execution of multiple HTTP/1.1 request / response exchanges. Response content is
-  buffered in memory for simplicity.
-
-- [Multiplexed HTTP/2 exchanges](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientH2Multiplexing.java)
-
-  This example demonstrates a multiplexed execution of multiple HTTP/2 request / response exchanges. Response content is
-  buffered in memory for simplicity.
-
-- [Request execution interceptors](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientInterceptors.java)
-
-  This example demonstrates how to insert custom request interceptor and an execution interceptor to the request
-  execution chain.
-
-- [Message trailers](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientMessageTrailers.java)
-
-  This example demonstrates how to use a custom execution interceptor to add trailers to all outgoing request enclosing
-  an entity..
-
-- [Multiplexed HTTP/2 exchanges](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientH2ServerPush.java)
-
-This example demonstrates handling of HTTP/2 message exchanges pushed by the server.
-
-- [Client authentication](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientAuthentication.java)
-
-  This example demonstrates execution of an HTTP request against a target site that requires user authentication.
-
-- [Custom SSL context](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientCustomSSL.java)
-
-  This example demonstrates how to create secure connections with a custom SSL context.
-
-- [Connection / TLS configuation per route / host](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientConnectionConfig.java)
-
-  This example demonstrates how to use connection configuration on a per-route or a per-host basis.
-
-- [Connection eviction](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncClientConnectionEviction.java)
-
-  This example demonstrates how to evict expired and idle connections from the connection pool.
-
-- [Preemptive BASIC authentication](https://github.com/apache/httpcomponents-client/blob/master/httpclient5/src/test/java/org/apache/hc/client5/http/examples/AsyncPreemptiveBasicClientAuthentication.java)
-
-  This example shows how HttpClient can be customized to authenticate preemptively using BASIC scheme. Generally,
-  preemptive authentication can be considered less secure than a response to an authentication challenge and therefore
-  discouraged.
-
-
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/examples-reactive.md b/src/site/markdown/httpcomponents-client-5.3.x/examples-reactive.md
deleted file mode 100644
index 08cfe5a..0000000
--- a/src/site/markdown/httpcomponents-client-5.3.x/examples-reactive.md
+++ /dev/null
@@ -1,25 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpClient Examples (Reactive)
-===========================
-
-- [HTTP exchange with Reactive Streams](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ReactiveClientFullDuplexExchange.java)
-
-  This example demonstrates a reactive, full-duplex HTTP/1.1 message exchange using RxJava.
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/examples.md b/src/site/markdown/httpcomponents-client-5.3.x/examples.md
deleted file mode 100644
index b175f71..0000000
--- a/src/site/markdown/httpcomponents-client-5.3.x/examples.md
+++ /dev/null
@@ -1,107 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpClient Examples (Classic)
-=============================
-
-- [Response handling](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientResponseProcessing.java)
-
-  This example demonstrates how to process HTTP responses using a response handler. This is the recommended way of
-  executing HTTP requests and processing HTTP responses. This approach enables the caller to concentrate on the process
-  of digesting HTTP responses and to delegate the task of system resource deallocation to HttpClient. The use of an HTTP
-  response handler guarantees that the underlying HTTP connection will be released back to the connection manager
-  automatically in all cases.
-
-- [Manual connection release](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientConnectionRelease.java)
-
-  This example demonstrates how to ensure the release of the underlying HTTP connection back to the connection manager
-  in case of a manual processing of HTTP responses.
-
-- [HttpClient configuration](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientConfiguration.java)
-
-  This example demonstrates how to customize and configure the most common aspects of HTTP request execution and
-  connection management.
-
-- [Request execution interceptors](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientInterceptors.java)
-
-  This example demonstrates how to insert custom request interceptor and an execution interceptor to the request
-  execution chain.
-
-- [Abort method](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientAbortMethod.java)
-
-  This example demonstrates how to abort an HTTP request before its normal completion.
-
-- [Client authentication](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientAuthentication.java)
-
-  This example uses HttpClient to execute an HTTP request against a target site that requires user authentication.
-
-- [Request via a proxy](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientExecuteProxy.java)
-
-  This example demonstrates how to send an HTTP request via a proxy.
-
-- [Proxy authentication](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientProxyAuthentication.java)
-
-  A simple example showing execution of an HTTP request over a secure connection tunneled through an authenticating
-  proxy.
-
-- [Chunk encoded POST](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientChunkEncodedPost.java)
-
-  This example shows how to stream out a request entity using chunk encoding.
-
-- [Custom execution context](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientCustomContext.java)
-
-  This example demonstrates the use of a local HTTP context populated custom attributes.
-
-- [Form based logon](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientFormLogin.java)
-
-  This example demonstrates how HttpClient can be used to perform form-based logon.
-
-- [Threaded request execution](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientMultiThreadedExecution.java)
-
-  An example that executes HTTP requests from multiple worker threads.
-
-- [Custom SSL context](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientCustomSSL.java)
-
-  This example demonstrates how to create secure connections with a custom SSL context.
-
-- [Connection / TLS configuation per route / host](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientConnectionConfig.java)
-
-  This example demonstrates how to use connection configuration on a per-route or a per-host basis.
-
-- [Preemptive BASIC authentication](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientPreemptiveBasicAuthentication.java)
-
-  This example shows how HttpClient can be customized to authenticate preemptively using BASIC scheme. Generally,
-  preemptive authentication can be considered less secure than a response to an authentication challenge and therefore
-  discouraged.
-
-- [Preemptive DIGEST authentication](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientPreemptiveDigestAuthentication.java)
-
-  This example shows how HttpClient can be customized to authenticate preemptively using DIGEST scheme. Generally,
-  preemptive authentication can be considered less secure than a response to an authentication challenge and therefore
-  discouraged.
-
-- [Proxy tunnel](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ProxyTunnelDemo.java)
-
-  This example shows how to use ProxyClient in order to establish a tunnel through an HTTP proxy for an arbitrary
-  protocol.
-
-- [Multipart encoded request entity](https://github.com/apache/httpcomponents-client/tree/5.3.x/httpclient5/src/test/java/org/apache/hc/client5/http/examples/ClientMultipartFormPost.java)
-
-  This example shows how to execute requests enclosing a multipart encoded entity. 
-
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/index.md b/src/site/markdown/httpcomponents-client-5.3.x/index.md
deleted file mode 100644
index 7d4613f..0000000
--- a/src/site/markdown/httpcomponents-client-5.3.x/index.md
+++ /dev/null
@@ -1,89 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpClient Overview
-===================
-
-The Hyper-Text Transfer Protocol (HTTP) is perhaps the most significant protocol used on the Internet today. Web
-services, network-enabled appliances and the growth of network computing continue to expand the role of the HTTP
-protocol beyond user-driven web browsers, while increasing the number of applications that require HTTP support.
-
-Although the java.net package provides basic functionality for accessing resources via HTTP, it doesn't provide the full
-flexibility or functionality needed by many applications. HttpClient seeks to fill this void by providing an efficient,
-up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations.
-
-Designed for extension while providing robust support for the base HTTP protocol, HttpClient may be of interest to
-anyone building HTTP-aware client applications such as web browsers, web service clients, or systems that leverage or
-extend the HTTP protocol for distributed communication.
-
-Documentation
--------------
-
-1. [Quick Start](quickstart.md) - contains simple, complete examples of request execution with the classic, fluent and
-   async APIs.
-1. Examples demonstrating some common as well as more complex use cases
-
-    * [HttpClient (classic APIs)](examples.md)
-    * [HttpClient (async APIs)](examples-async.md)
-    * [HttpClient (reactive APIs)](examples-reactive.md)
-
-1. Javadocs
-
-    * [HttpClient](./current/httpclient5/apidocs/)
-    * [HC Fluent](./current/httpclient5-fluent/apidocs/)
-    * [HttpClient Cache](./current/httpclient5-cache/apidocs/)
-    * [HttpClient Windows extensions](./current/httpclient5-win/apidocs/)
-
-1. API compatibility reports
-
-    * [HttpClient](./current/httpclient5/japicmp.html)
-    * [HC Fluent](./current/httpclient5-fluent/japicmp.html)
-    * [HttpClient Cache](./current/httpclient5-cache/japicmp.html)
-    * [HttpClient Windows extensions](./current/httpclient5-win/japicmp.html)
-
-Features
---------
-
-- Standards based, pure Java, implementation of HTTP versions 1.0, 1.1, 2.0 (only async APIs)
-- Supports encryption with HTTPS (HTTP over SSL) protocol.
-- Pluggable socket factories and TLS strategies.
-- Transparent message exchanges through HTTP/1.1 and HTTP/1.0 proxies.
-- Tunneled HTTPS connections through HTTP/1.1 and HTTP/1.0 proxies, via the CONNECT method.
-- Basic, Digest, Bearer authentication schemes.
-- HTTP state management and cookie support.
-- Flexible connection management and pooling.
-- Support for HTTP response caching.
-- Source code is freely available under the Apache License.
-
-Standards Compliance
---------------------
-
-HttpClient strives to conform to the following specifications endorsed by the Internet Engineering Task Force (IETF) and
-the internet at large:
-
-- [RFC 7540](https://datatracker.ietf.org/doc/html/rfc7540) - Hypertext Transfer Protocol Version 2 (HTTP/2)
-- [RFC 7541](https://datatracker.ietf.org/doc/html/rfc7541) - HPACK: Header Compression for HTTP/2
-- [RFC 7230](https://datatracker.ietf.org/doc/html/rfc7230) - Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
-- [RFC 7231](https://datatracker.ietf.org/doc/html/rfc7231) - Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content
-- [RFC 1945](https://datatracker.ietf.org/doc/html/rfc1945) - Hypertext Transfer Protocol -- HTTP/1.0
-- [RFC 3986](https://datatracker.ietf.org/doc/html/rfc3986) - Uniform Resource Identifier (URI): Generic Syntax
-- [RFC 2817](https://datatracker.ietf.org/doc/html/rfc2817) - Upgrading to TLS Within HTTP/1.1
-- [RFC 2818](https://datatracker.ietf.org/doc/html/rfc2818) - HTTP Over TLS
-- [RFC 6265](https://datatracker.ietf.org/doc/html/rfc6265) - HTTP State Management Mechanism (Cookies)
-
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/quickstart.md b/src/site/markdown/httpcomponents-client-5.3.x/quickstart.md
deleted file mode 100644
index b945eec..0000000
--- a/src/site/markdown/httpcomponents-client-5.3.x/quickstart.md
+++ /dev/null
@@ -1,187 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpClient Quick Start
-======================
-
-- Download 'Binary' package of the latest HttpClient 5.3 release or configure dependency on `HttpClient` and `Fluent HC`
-  modules using a dependency manager of your choice as described [here](../httpcomponents-client-5.3.x/download.md).
-
-- HttpClient 5.3 requires Java 1.8 or newer.
-
-- The below code fragment illustrates the execution of HTTP GET and POST requests using the HttpClient native API.
-
-    ```
-    try (CloseableHttpClient httpclient = HttpClients.createDefault()) {
-        ClassicHttpRequest httpGet = ClassicRequestBuilder.get("http://httpbin.org/get")
-                .build();
-        // The underlying HTTP connection is still held by the response object
-        // to allow the response content to be streamed directly from the network socket.
-        // In order to ensure correct deallocation of system resources
-        // the user MUST call CloseableHttpResponse#close() from a finally clause.
-        // Please note that if response content is not fully consumed the underlying
-        // connection cannot be safely re-used and will be shut down and discarded
-        // by the connection manager.
-        httpclient.execute(httpGet, response -> {
-            System.out.println(response.getCode() + " " + response.getReasonPhrase());
-            final HttpEntity entity1 = response.getEntity();
-            // do something useful with the response body
-            // and ensure it is fully consumed
-            EntityUtils.consume(entity1);
-            return null;
-        });
-
-        ClassicHttpRequest httpPost = ClassicRequestBuilder.post("http://httpbin.org/post")
-                .setEntity(new UrlEncodedFormEntity(Arrays.asList(
-                        new BasicNameValuePair("username", "vip"),
-                        new BasicNameValuePair("password", "secret"))))
-                .build();
-        httpclient.execute(httpPost, response -> {
-            System.out.println(response.getCode() + " " + response.getReasonPhrase());
-            final HttpEntity entity2 = response.getEntity();
-            // do something useful with the response body
-            // and ensure it is fully consumed
-            EntityUtils.consume(entity2);
-            return null;
-        });
-    }
-    ```
-
-  Source can be found here
-  [here](https://github.com/apache/httpcomponents-website/blob/master/samples/src/main/java/org/apache/hc/client5/http/examples/QuickStart.java)
-
-- The same requests can be executed using a simpler, albeit less flexible, fluent API.
-
-    ```
-    // The fluent API relieves the user from having to deal with manual deallocation of system
-    // resources at the cost of having to buffer response content in memory in some cases.
-    
-    Request.Get("http://targethost/homepage")
-        .execute().returnContent();
-    Request.Post("http://targethost/login")
-        .bodyForm(Form.form().add("username",  "vip").add("password",  "secret").build())
-        .execute().returnContent();
-    ```
-
-  Source can be found here
-  [here](https://github.com/apache/httpcomponents-website/blob/master/samples/src/main/java/org/apache/hc/client5/http/examples/fluent/FluentQuickStart.java)
-
-- The below code fragment illustrates the execution of HTTP requests using HttpClient async API.
-
-    ```
-    try (CloseableHttpAsyncClient httpclient = HttpAsyncClients.createDefault()) {
-        // Start the client
-        httpclient.start();
-    
-        // Execute request
-        SimpleHttpRequest request1 = SimpleRequestBuilder.get("http://httpbin.org/get").build();
-        Future<SimpleHttpResponse> future = httpclient.execute(request1, null);
-        // and wait until response is received
-        SimpleHttpResponse response1 = future.get();
-        System.out.println(request1.getRequestUri() + "->" + response1.getCode());
-    
-        // One most likely would want to use a callback for operation result
-        CountDownLatch latch1 = new CountDownLatch(1);
-        SimpleHttpRequest request2 = SimpleRequestBuilder.get("http://httpbin.org/get").build();
-        httpclient.execute(request2, new FutureCallback<SimpleHttpResponse>() {
-    
-            @Override
-            public void completed(SimpleHttpResponse response2) {
-                latch1.countDown();
-                System.out.println(request2.getRequestUri() + "->" + response2.getCode());
-            }
-    
-            @Override
-            public void failed(Exception ex) {
-                latch1.countDown();
-                System.out.println(request2.getRequestUri() + "->" + ex);
-            }
-    
-            @Override
-            public void cancelled() {
-                latch1.countDown();
-                System.out.println(request2.getRequestUri() + " cancelled");
-            }
-    
-        });
-        latch1.await();
-    
-        // In real world one most likely would want also want to stream
-        // request and response body content
-        CountDownLatch latch2 = new CountDownLatch(1);
-        AsyncRequestProducer producer3 = AsyncRequestBuilder.get("http://httpbin.org/get").build();
-        AbstractCharResponseConsumer<HttpResponse> consumer3 = new AbstractCharResponseConsumer<HttpResponse>() {
-    
-            HttpResponse response;
-    
-            @Override
-            protected void start(HttpResponse response, ContentType contentType) throws HttpException, IOException {
-                this.response = response;
-            }
-    
-            @Override
-            protected int capacityIncrement() {
-                return Integer.MAX_VALUE;
-            }
-    
-            @Override
-            protected void data(CharBuffer data, boolean endOfStream) throws IOException {
-                // Do something useful
-            }
-    
-            @Override
-            protected HttpResponse buildResult() throws IOException {
-                return response;
-            }
-    
-            @Override
-            public void releaseResources() {
-            }
-    
-        };
-        httpclient.execute(producer3, consumer3, new FutureCallback<HttpResponse>() {
-    
-            @Override
-            public void completed(HttpResponse response3) {
-                latch2.countDown();
-                System.out.println(request2.getRequestUri() + "->" + response3.getCode());
-            }
-    
-            @Override
-            public void failed(Exception ex) {
-                latch2.countDown();
-                System.out.println(request2.getRequestUri() + "->" + ex);
-            }
-    
-            @Override
-            public void cancelled() {
-                latch2.countDown();
-                System.out.println(request2.getRequestUri() + " cancelled");
-            }
-    
-        });
-        latch2.await();
-    
-    }
-    ```    
-
-  Source can be found here
-  [here](https://github.com/apache/httpcomponents-website/blob/master/samples/src/main/java/org/apache/hc/client5/http/examples/AsyncQuickStart.java)
-
-
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/android.md b/src/site/markdown/httpcomponents-client-5.4.x/android.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/android.md
rename to src/site/markdown/httpcomponents-client-5.4.x/android.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/logging.md b/src/site/markdown/httpcomponents-client-5.4.x/logging.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/logging.md
rename to src/site/markdown/httpcomponents-client-5.4.x/logging.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/migration-guide/index.md b/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/index.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/migration-guide/index.md
rename to src/site/markdown/httpcomponents-client-5.4.x/migration-guide/index.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-async-http2.md b/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-http2.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-async-http2.md
rename to src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-http2.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-async-simple.md b/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-simple.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-async-simple.md
rename to src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-simple.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-async-streaming.md b/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-streaming.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-async-streaming.md
rename to src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-async-streaming.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-classic.md b/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-classic.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/migration-guide/migration-to-classic.md
rename to src/site/markdown/httpcomponents-client-5.4.x/migration-guide/migration-to-classic.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/migration-guide/preparation.md b/src/site/markdown/httpcomponents-client-5.4.x/migration-guide/preparation.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/migration-guide/preparation.md
rename to src/site/markdown/httpcomponents-client-5.4.x/migration-guide/preparation.md
diff --git a/src/site/markdown/httpcomponents-client-5.3.x/related-projects.md b/src/site/markdown/httpcomponents-client-5.4.x/related-projects.md
similarity index 100%
rename from src/site/markdown/httpcomponents-client-5.3.x/related-projects.md
rename to src/site/markdown/httpcomponents-client-5.4.x/related-projects.md
diff --git a/src/site/markdown/news.md b/src/site/markdown/news.md
index 20b4359..da59354 100644
--- a/src/site/markdown/news.md
+++ b/src/site/markdown/news.md
@@ -20,6 +20,39 @@
 HttpComponents Project News
 ===========================
 
+###### 23 September 2024 - HttpComponents Client 5.4 GA released
+
+This is the first GA release in the 5.4 release series. This release finalizes the 5.4 APIs,
+upgrades HttpCore to version 5.3 and improves the Public Suffix matching algorithm implementation.
+
+Notable changes and features included in the 5.4 series:
+
+* Improved conformance to RFC 9110 (HTTP Semantics), RFC 7616 (HTTP Digest Access
+  Authentication), RFC 2617 (’Basic’ HTTP Authentication Scheme).
+
+* UTF-8 encoding is used by default for text where appropriate.
+
+* Compatibility with Java Virtual Threads and Java 21 Runtime.
+
+* Redesign and rewrite of the HTTP caching protocol layer for better efficiency
+  and improved conformance to RFC 9111 (HTTP Caching).
+
+* Cache control and context APIs.
+
+* ETag APIs.
+
+* TLS SNI and endpoint identification improvements.
+
+* Support for RFC 2817 (Upgrading to TLS Within HTTP/1.1).
+
+* Auth cache no longer makes use of Java serialization.
+
+* Deprecation of ConnectionSocketFactory and LayeredConnectionSocketFactory.
+
+* HttpContext optimization and performance improvement.
+
+* Async cache is no longer considered experimental.
+
 ###### 12 September 2024 - HttpComponents Core 5.3 GA released
 
 This is the first GA release in the 5.3 release series. This release finalizes the 5.3 APIs
@@ -51,32 +84,6 @@ release 5.2.4.
 This is the first BETA release in the 5.4 release series. It upgrades HttpCore to version
 5.3-beta1 and adds a few minor improvements and fixes.
 
-Notable changes and features included in the 5.4 series:
-
-* Improved conformance to RFC 9110 (HTTP Semantics), RFC 7616 (HTTP Digest Access
-  Authentication), RFC 2617 (’Basic’ HTTP Authentication Scheme).
-
-* UTF-8 encoding is used by default for text where appropriate.
-
-* Compatibility with Java Virtual Threads and Java 21 Runtime.
-
-* Redesign and rewrite of the HTTP caching protocol layer for better efficiency
-  and improved conformance to RFC 9111 (HTTP Caching).
-
-* Cache control and context APIs.
-
-* ETag APIs.
-
-* TLS SNI and endpoint identification improvements.
-
-* Support for RFC 2817 (Upgrading to TLS Within HTTP/1.1).
-
-* Auth cache no longer makes use of Java serialization.
-
-* Deprecation of ConnectionSocketFactory and LayeredConnectionSocketFactory.
-
-* HttpContext optimization and performance improvement.
-
 ###### 26 June 2024 - HttpComponents Core 5.3-beta1 released
 
 This is the first BETA release in the 5.3 release series. It features a re-designed
diff --git a/src/site/markdown/status.md b/src/site/markdown/status.md
index 1023227..87f146f 100644
--- a/src/site/markdown/status.md
+++ b/src/site/markdown/status.md
@@ -23,32 +23,19 @@ HttpComponents Project Status
 HttpComponents HttpClient 5.4.x
 -------------------------------
 
-HttpClient 5.4.x branch is the current development branch. The 5.4.x release series upgrades HTTP protocol
-conformance level to RFC 9110, replaces `synchronized` blocks with lock primitives, redesigns the HTTP caching 
-protocol layer for better efficiency and improved conformance to RFC 9111, introduces support for RFC 2817 
-(Upgrading to TLS Within HTTP/1.1), and provides a number of other API enhancements. This branch also seeks 
-to optimize common HTTP context operations that should translate in a better performance of HTTP message 
-exchanges.
-
-HttpComponents HttpClient 5.3.x
--------------------------------
-
-HttpClient 5.2.x branch is considered stable and production ready. It is being actively maintained and supported. 
-The 5.3.x release series introduces support for the Bearer authentication scheme (RFC 6750) and will deprecate 
-NTLM and GSS based experimental authentication schemes in favor of Basic / Bearer authentication with TLS.
+HttpClient 5.4.x branch is considered stable and production ready. It is being actively maintained and supported.
+The 5.4.x release series upgrades HTTP protocol  conformance level to RFC 9110, replaces `synchronized` blocks 
+with lock primitives, redesigns the HTTP caching protocol layer for better efficiency and improved conformance 
+to RFC 9111, introduces support for RFC 2817 (Upgrading to TLS Within HTTP/1.1), and provides a number of 
+other API enhancements. This branch also seeks to optimize common HTTP context operations that should translate 
+in a better performance of HTTP message exchanges.
 
 HttpComponents HttpCore 5.3.x
 -------------------------------
 
-HttpClient 5.3.x branch is the current development branch. The 5.3.x release series will upgrade HTTP protocol 
-conformance level to RFC 9110 and will replace `synchronized` blocks with lock primitives.
-
-HttpComponents HttpCore 5.2.x
------------------------------
-
-HttpCore 5.2.x branch is considered stable and production ready. It is being actively maintained and supported. The
-5.2.x release series provides comprehensive support for HTTP/1.1 and HTTP/2 protocol, full conformance with mandatory
-requirements of RFC 7230, RFC 7231, RFC 7540 and RFC 7541 and conditional conformance to RFC 3986.
+HttpCore 5.2.x branch is considered stable and production ready. It is being actively maintained and supported. 
+The 5.3.x release series upgrades HTTP protocol conformance level to RFC 9110 and replaces `synchronized` 
+blocks with lock primitives.
 
 HttpComponents HttpClient 4.5.x
 -------------------------------
diff --git a/src/site/resources/.htaccess b/src/site/resources/.htaccess
index 2cef84c..f087bcf 100644
--- a/src/site/resources/.htaccess
+++ b/src/site/resources/.htaccess
@@ -7,9 +7,9 @@ Redirect permanent  "/httpcomponents-core-5.1.x"       "/httpcomponents-core-5.3
 Redirect permanent  "/httpcomponents-core-5.2.x"       "/httpcomponents-core-5.3.x"
 Redirect permanent  "/httpcomponents-core"             "/httpcomponents-core-5.3.x"
 Redirect permanent  "/httpcomponents-core-ga"          "/httpcomponents-core-5.3.x"
-Redirect permanent  "/httpcomponents-client-5.0.x"     "/httpcomponents-client-5.2.x"
-Redirect permanent  "/httpcomponents-client"           "/httpcomponents-client-5.2.x"
-Redirect permanent  "/httpcomponents-client-ga"        "/httpcomponents-client-5.2.x"
-
-Redirect temp       "/httpcomponents-core-dev"         "/httpcomponents-core-5.2.x"
-Redirect temp       "/httpcomponents-client-dev"       "/httpcomponents-client-5.2.x"
+Redirect permanent  "/httpcomponents-client-5.0.x"     "/httpcomponents-client-5.4.x"
+Redirect permanent  "/httpcomponents-client-5.1.x"     "/httpcomponents-client-5.4.x"
+Redirect permanent  "/httpcomponents-client-5.2.x"     "/httpcomponents-client-5.4.x"
+Redirect permanent  "/httpcomponents-client-5.3.x"     "/httpcomponents-client-5.4.x"
+Redirect permanent  "/httpcomponents-client"           "/httpcomponents-client-5.4.x"
+Redirect permanent  "/httpcomponents-client-ga"        "/httpcomponents-client-5.4.x"
\ No newline at end of file
diff --git a/src/site/resources/httpcomponents-client-5.4.x/documentation.links b/src/site/resources/httpcomponents-client-5.4.x/documentation.links
index f329f17..8f37d0c 100644
--- a/src/site/resources/httpcomponents-client-5.4.x/documentation.links
+++ b/src/site/resources/httpcomponents-client-5.4.x/documentation.links
@@ -4,4 +4,5 @@
 5.4-alpha1  ../components/httpcomponents-client-5.4.x/5.4-alpha1
 5.4-alpha2  ../components/httpcomponents-client-5.4.x/5.4-alpha2
 5.4-beta1   ../components/httpcomponents-client-5.4.x/5.4-beta1
-current     ../components/httpcomponents-client-5.4.x/5.4-beta1
+5.4         ../components/httpcomponents-client-5.4.x/5.4
+current     ../components/httpcomponents-client-5.4.x/5.4
diff --git a/src/site/site.xml b/src/site/site.xml
index 5b5c0ad..22caf3b 100644
--- a/src/site/site.xml
+++ b/src/site/site.xml
@@ -72,40 +72,23 @@ under the License.
       <item name="Get Involved" href="get-involved.html"/>
     </menu>
     <menu name="Components">
-      <item name="HttpClient 5.4 BETA" collapse="true" href="httpcomponents-client-5.4.x/index.html">
+      <item name="HttpClient 5.4" collapse="true" href="httpcomponents-client-5.4.x/index.html">
         <item name="Quick Start" href="httpcomponents-client-5.4.x/quickstart.html"/>
-        <item name="Migration Guide" collapse="true" href="httpcomponents-client-5.3.x/migration-guide/index.html">
-          <item name="Preparation" href="httpcomponents-client-5.3.x/migration-guide/preparation.html"/>
-          <item name="Classic" href="httpcomponents-client-5.3.x/migration-guide/migration-to-classic.html"/>
-          <item name="Async Simple" href="httpcomponents-client-5.3.x/migration-guide/migration-to-async-simple.html"/>
-          <item name="Async Streaming" href="httpcomponents-client-5.3.x/migration-guide/migration-to-async-streaming.html"/>
-          <item name="Async HTTP/2 only" href="httpcomponents-client-5.3.x/migration-guide/migration-to-async-http2.html"/>
+        <item name="Migration Guide" collapse="true" href="httpcomponents-client-5.4.x/migration-guide/index.html">
+          <item name="Preparation" href="httpcomponents-client-5.4.x/migration-guide/preparation.html"/>
+          <item name="Classic" href="httpcomponents-client-5.4.x/migration-guide/migration-to-classic.html"/>
+          <item name="Async Simple" href="httpcomponents-client-5.4.x/migration-guide/migration-to-async-simple.html"/>
+          <item name="Async Streaming" href="httpcomponents-client-5.4.x/migration-guide/migration-to-async-streaming.html"/>
+          <item name="Async HTTP/2 only" href="httpcomponents-client-5.4.x/migration-guide/migration-to-async-http2.html"/>
         </item>
         <item name="Examples (Classic)" href="httpcomponents-client-5.4.x/examples.html"/>
         <item name="Examples (Async)" href="httpcomponents-client-5.4.x/examples-async.html"/>
         <item name="Examples (Reactive)" href="httpcomponents-client-5.4.x/examples-reactive.html"/>
-        <item name="Logging Guide" href="httpcomponents-client-5.3.x/logging.html"/>
-        <item name="Android" href="httpcomponents-client-5.3.x/android.html"/>
-        <item name="Related" href="httpcomponents-client-5.3.x/related-projects.html"/>
+        <item name="Logging Guide" href="httpcomponents-client-5.4.x/logging.html"/>
+        <item name="Android" href="httpcomponents-client-5.4.x/android.html"/>
+        <item name="Related" href="httpcomponents-client-5.4.x/related-projects.html"/>
         <item name="Download" href="httpcomponents-client-5.4.x/download.html"/>
       </item>
-      <item name="HttpClient 5.3" collapse="true" href="httpcomponents-client-5.3.x/index.html">
-        <item name="Quick Start" href="httpcomponents-client-5.3.x/quickstart.html"/>
-        <item name="Migration Guide" collapse="true" href="httpcomponents-client-5.3.x/migration-guide/index.html">
-          <item name="Preparation" href="httpcomponents-client-5.3.x/migration-guide/preparation.html"/>
-          <item name="Classic" href="httpcomponents-client-5.3.x/migration-guide/migration-to-classic.html"/>
-          <item name="Async Simple" href="httpcomponents-client-5.3.x/migration-guide/migration-to-async-simple.html"/>
-          <item name="Async Streaming" href="httpcomponents-client-5.3.x/migration-guide/migration-to-async-streaming.html"/>
-          <item name="Async HTTP/2 only" href="httpcomponents-client-5.3.x/migration-guide/migration-to-async-http2.html"/>
-        </item>
-        <item name="Examples (Classic)" href="httpcomponents-client-5.3.x/examples.html"/>
-        <item name="Examples (Async)" href="httpcomponents-client-5.3.x/examples-async.html"/>
-        <item name="Examples (Reactive)" href="httpcomponents-client-5.3.x/examples-reactive.html"/>
-        <item name="Logging Guide" href="httpcomponents-client-5.3.x/logging.html"/>
-        <item name="Android" href="httpcomponents-client-5.3.x/android.html"/>
-        <item name="Related" href="httpcomponents-client-5.3.x/related-projects.html"/>
-        <item name="Download" href="httpcomponents-client-5.3.x/download.html"/>
-      </item>
       <item name="HttpCore 5.3" collapse="true" href="httpcomponents-core-5.3.x/index.html">
         <item name="Examples" href="httpcomponents-core-5.3.x/examples.html"/>
         <item name="Related" href="httpcomponents-core-5.3.x/related-projects.html"/>
diff --git a/src/site/xdoc/downloads.xml b/src/site/xdoc/downloads.xml
index 9fbc142..7cf940b 100644
--- a/src/site/xdoc/downloads.xml
+++ b/src/site/xdoc/downloads.xml
@@ -64,34 +64,34 @@
    <code>sha512</code> link downloads the SHA 512 checksum from the main site.
   </p>
 
-    <subsection name="HttpClient 5.3.1 (GA)">
+    <subsection name="HttpClient 5.4 (GA)">
       <a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
-      <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-5.3.x.txt">Release Notes</a>
+      <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-5.4.x.txt">Release Notes</a>
       <br/>
       <p>Binary</p>
       <ul>
         <li>
-          <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.3.1-bin.tar.gz">5.3.1.tar.gz</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.3.1-bin.tar.gz.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.3.1-bin.tar.gz.asc">pgp</a>]
+          <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-bin.tar.gz">5.4.tar.gz</a>
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-bin.tar.gz.sha512">sha512</a>]
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-bin.tar.gz.asc">pgp</a>]
         </li>
         <li>
-          <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.3.1-bin.zip">5.3.1.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.3.1-bin.zip.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.3.1-bin.zip.asc">pgp</a>]
+          <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-bin.zip">5.4.zip</a>
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-bin.zip.sha512">sha512</a>]
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-bin.zip.asc">pgp</a>]
         </li>
       </ul>
       <p>Source</p>
       <ul>
         <li>
-          <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.3.1-src.tar.gz">5.3.1.tar.gz</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.3.1-src.tar.gz.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.3.1-src.tar.gz.asc">pgp</a>]
+          <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-src.tar.gz">5.4.tar.gz</a>
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-src.tar.gz.sha512">sha512</a>]
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-src.tar.gz.asc">pgp</a>]
         </li>
         <li>
-          <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.3.1-src.zip">5.3.1.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.3.1-src.zip.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.3.1-src.zip.asc">pgp</a>]
+          <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-src.zip">5.4.zip</a>
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-src.zip.sha512">sha512</a>]
+          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-src.zip.asc">pgp</a>]
         </li>
       </ul>
     </subsection>
@@ -138,38 +138,6 @@
       </ul>
     </subsection>
 
-    <subsection name="HttpClient 5.4-beta1">
-      <a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
-      <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-5.4.x.txt">Release Notes</a>
-      <br/>
-      <p>Binary</p>
-      <ul>
-        <li>
-          <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.tar.gz">5.4-beta1.tar.gz</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.tar.gz.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.tar.gz.asc">pgp</a>]
-        </li>
-        <li>
-          <a href="[preferred]/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.zip">5.4-beta1.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.zip.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/binary/httpcomponents-client-5.4-beta1-bin.zip.asc">pgp</a>]
-        </li>
-      </ul>
-      <p>Source</p>
-      <ul>
-        <li>
-          <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.tar.gz">5.4-beta1.tar.gz</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.tar.gz.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.tar.gz.asc">pgp</a>]
-        </li>
-        <li>
-          <a href="[preferred]/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.zip">5.4-beta1.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.zip.sha512">sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpclient/source/httpcomponents-client-5.4-beta1-src.zip.asc">pgp</a>]
-        </li>
-      </ul>
-    </subsection>
-
     <subsection name="HttpClient 4.5.14 (GA)">
     <a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
     <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-4.5.x.txt">Release Notes</a>


(httpcomponents-website) 01/02: Updated project website for HttpCore 5.3 release

Posted by ol...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

olegk pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/httpcomponents-website.git

commit f2f8da7bb15841f3f68bfff1f5427c89e7de8dea
Author: Oleg Kalnichevski <ol...@apache.org>
AuthorDate: Thu Sep 12 13:35:10 2024 +0200

    Updated project website for HttpCore 5.3 release
---
 .../markdown/httpcomponents-core-5.1.x/download.md | 38 ---------
 .../markdown/httpcomponents-core-5.1.x/examples.md | 92 ----------------------
 .../markdown/httpcomponents-core-5.1.x/index.md    | 54 -------------
 .../markdown/httpcomponents-core-5.2.x/download.md | 38 ---------
 .../markdown/httpcomponents-core-5.2.x/examples.md | 92 ----------------------
 .../markdown/httpcomponents-core-5.2.x/index.md    | 54 -------------
 .../related-projects.md                            |  0
 src/site/markdown/news.md                          | 39 +++++----
 src/site/resources/.htaccess                       |  8 +-
 .../httpcomponents-core-5.3.x/documentation.links  |  3 +-
 src/site/site.xml                                  |  9 +--
 src/site/xdoc/downloads.xml                        | 72 ++++-------------
 12 files changed, 47 insertions(+), 452 deletions(-)

diff --git a/src/site/markdown/httpcomponents-core-5.1.x/download.md b/src/site/markdown/httpcomponents-core-5.1.x/download.md
deleted file mode 100644
index 5d24696..0000000
--- a/src/site/markdown/httpcomponents-core-5.1.x/download.md
+++ /dev/null
@@ -1,38 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpCore Downloads
-==================
-
-The latest release available for download:
-
-[Release packages](https://hc.apache.org/downloads.cgi) -
-[Release Notes](https://www.apache.org/dist/httpcomponents/httpcore/RELEASE_NOTES-5.1.x.txt) -
-[License](https://www.apache.org/licenses/LICENSE-2.0.html)
-
-Dependency management
----------------------
-
-If you are using a dependency manager for your project such as [Apache Maven](https://maven.apache.org),
-[Gradle](https://gradle.org/) or [Apache Ivy](https://ant.apache.org/projects/ivy.html), you can create a dependency on
-HttpCore modules by using this information:
-
-- [HttpCore HTTP/1.1](https://search.maven.org/artifact/org.apache.httpcomponents.core5/httpcore5)
-- [HttpCore HTTP/2](https://search.maven.org/artifact/org.apache.httpcomponents.core5/httpcore5-h2)
-- [HttpCore Reactive Streams](https://search.maven.org/artifact/org.apache.httpcomponents.core5/httpcore5-reactive)
diff --git a/src/site/markdown/httpcomponents-core-5.1.x/examples.md b/src/site/markdown/httpcomponents-core-5.1.x/examples.md
deleted file mode 100644
index 025b1b9..0000000
--- a/src/site/markdown/httpcomponents-core-5.1.x/examples.md
+++ /dev/null
@@ -1,92 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpCore Examples
-=================
-
-- [ Classic (blocking) HTTP/1.1 GET requests](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicGetExecutionExample.java)
-
-  This example demonstrates synchronous execution of multiple HTTP/1.1 GET requests.
-
-- [ Classic (blocking) HTTP/1.1 POST requests](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicPostExecutionExample.java)
-
-  This example demonstrates synchronous execution of multiple HTTP/1.1 POST requests with enclosed content of various
-  types.
-
-- [ Asynchronous HTTP/1.1 GET requests](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncRequestExecutionExample.java)
-
-  This example demonstrates asynchronous execution of multiple HTTP/1.1 requests.
-
-- [ Asynchronous HTTP/2 GET requests](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2RequestExecutionExample.java)
-
-  This example demonstrates asynchronous execution of multiple HTTP/2 requests.
-
-- [ HTTP/2 requests over TLS connections with ALPN support](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2TlsAlpnRequestExecutionExample.java)
-
-  This example demonstrates how to execute HTTP/2 requests over TLS connections with ALPN support. It also explains how
-  to avoid the illegal reflective access operation warning when running Java 9 or older.
-
-- [ HTTP/2 requests over TLS connections with ALPN support on Java 1.7 and Java 1.8](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2ConscriptRequestExecutionExample.java)
-
-  This example demonstrates how to execute HTTP/2 requests over TLS connections with ALPN support on Java 1.7 and Java
-  1.8.
-
-- [ Asynchronous HTTP/1.1 GET requests with message pipelining](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncPipelinedRequestExecutionExample.java)
-
-  This example demonstrates asynchronous, pipelined execution multiple HTTP/1.1 requests.
-
-- [ Asynchronous HTTP/2 GET requests with multiple concurrent streams](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2MultiStreamExecutionExample.java)
-
-  This example demonstrates asynchronous, multistream execution of multiple HTTP/2 requests.
-
-- [ Classic (blocking) HTTP/1.1 file server](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicFileServerExample.java)
-
-  This is an example of an embedded HTTP/1.1 file server with a classic (blocking) message transport.
-
-- [ Request filters with classic (blocking) HTTP/1.1 server](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicServerFilterExample.java)
-
-  This is an example of using synchronous request filters with an embedded HTTP/1.1 server.
-
-- [ Asynchronous HTTP/1.1 file server](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncFileServerExample.java)
-
-  This is an example of an embedded HTTP/1.1 file server with an event driven, non-blocking message transport.
-
-- [ Request filters with asynchronous HTTP/1.1 server](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncServerFilterExample.java)
-
-  This is an example of using asynchronous request filters with an embedded HTTP/1.1 server.
-
-- [ Asynchronous HTTP/2 file server](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2FileServerExample.java)
-
-  This is an example of an embedded HTTP/2 file server with an event driven, non-blocking message transport.
-
-- [ Classic (blocking) HTTP reverse proxy](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicReverseProxyExample.java)
-
-  This is an example of an embedded HTTP/1.1 reverse proxy with a classic (blocking) message transport.
-
-- [ Asynchronous HTTP reverse proxy](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncReverseProxyExample.java)
-
-  This is an example of an embedded HTTP/1.1 reverse proxy with an event driven, non-blocking message transport.
-
-- [ Client Reactive Streams](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5-reactive/src/test/java/org/apache/hc/core5/reactive/examples/ReactiveFullDuplexClientExample.java)
-
-  This is an example of full-duplex HTTP/1.1 client side message exchanges using reactive streaming.
-
-- [ Server Reactive Streams](https://github.com/apache/httpcomponents-core/tree/5.1.x/httpcore5-reactive/src/test/java/org/apache/hc/core5/reactive/examples/ReactiveFullDuplexServerExample.java)
-
-  This is an example of full-duplex HTTP/1.1 server side message exchanges using reactive streaming.
diff --git a/src/site/markdown/httpcomponents-core-5.1.x/index.md b/src/site/markdown/httpcomponents-core-5.1.x/index.md
deleted file mode 100644
index b46484d..0000000
--- a/src/site/markdown/httpcomponents-core-5.1.x/index.md
+++ /dev/null
@@ -1,54 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpCore Overview
-=================
-
-HttpCore is a set of low level HTTP transport components that can be used to build custom client and server side HTTP
-services with a minimal footprint. HttpCore supports two I/O models: blocking I/O model based on the classic Java I/O
-and non-blocking, event driven I/O model based on Java NIO.
-
-Documentation
-=============
-
-1. Some examples of HttpCore components in action can be found [here](./examples.html)
-
-1. Javadocs
-    - [HttpCore HTTP/1.1](./current/httpcore5/apidocs/)
-    - [HttpCore HTTP/2](./current/httpcore5-h2/apidocs/)
-    - [HttpCore Reactive Streams](./current/httpcore5-reactive/apidocs/)
-
-1. API compatibility reports
-    - [HttpCore HTTP/1.1](./current/httpcore5/japicmp.html)
-    - [HttpCore HTTP/2](./current/httpcore5-h2/japicmp.html)
-    - [HttpCore Reactive Streams](./current/httpcore5-reactive/japicmp.html)
-
-Standards Compliance
---------------------
-
-HttpCore components strive to conform to the following specifications endorsed by the Internet Engineering Task Force
-(IETF) and the internet at large:
-
-- [RFC 7540](https://datatracker.ietf.org/doc/html/rfc7540) - Hypertext Transfer Protocol Version 2 (HTTP/2)
-- [RFC 7541](https://datatracker.ietf.org/doc/html/rfc7541) - HPACK: Header Compression for HTTP/2
-- [RFC 7230](https://datatracker.ietf.org/doc/html/rfc7230) - Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
-- [RFC 7231](https://datatracker.ietf.org/doc/html/rfc7231) - Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content
-- [RFC 1945](https://datatracker.ietf.org/doc/html/rfc1945) - Hypertext Transfer Protocol -- HTTP/1.0
-- [RFC 3986](https://datatracker.ietf.org/doc/html/rfc3986) - Uniform Resource Identifier (URI): Generic Syntax
-
diff --git a/src/site/markdown/httpcomponents-core-5.2.x/download.md b/src/site/markdown/httpcomponents-core-5.2.x/download.md
deleted file mode 100644
index e996c18..0000000
--- a/src/site/markdown/httpcomponents-core-5.2.x/download.md
+++ /dev/null
@@ -1,38 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpCore Downloads
-==================
-
-The latest release available for download:
-
-[Release packages](https://hc.apache.org/downloads.cgi) -
-[Release Notes](https://www.apache.org/dist/httpcomponents/httpcore/RELEASE_NOTES-5.2.x.txt) -
-[License](https://www.apache.org/licenses/LICENSE-2.0.html)
-
-Dependency management
----------------------
-
-If you are using a dependency manager for your project such as [Apache Maven](https://maven.apache.org),
-[Gradle](https://gradle.org/) or [Apache Ivy](https://ant.apache.org/projects/ivy.html), you can create a dependency on
-HttpCore modules by using this information:
-
-- [HttpCore HTTP/1.1](https://search.maven.org/artifact/org.apache.httpcomponents.core5/httpcore5)
-- [HttpCore HTTP/2](https://search.maven.org/artifact/org.apache.httpcomponents.core5/httpcore5-h2)
-- [HttpCore Reactive Streams](https://search.maven.org/artifact/org.apache.httpcomponents.core5/httpcore5-reactive)
diff --git a/src/site/markdown/httpcomponents-core-5.2.x/examples.md b/src/site/markdown/httpcomponents-core-5.2.x/examples.md
deleted file mode 100644
index 0efcbaf..0000000
--- a/src/site/markdown/httpcomponents-core-5.2.x/examples.md
+++ /dev/null
@@ -1,92 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpCore Examples
-=================
-
-- [ Classic (blocking) HTTP/1.1 GET requests](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicGetExecutionExample.java)
-
-  This example demonstrates synchronous execution of multiple HTTP/1.1 GET requests.
-
-- [ Classic (blocking) HTTP/1.1 POST requests](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicPostExecutionExample.java)
-
-  This example demonstrates synchronous execution of multiple HTTP/1.1 POST requests with enclosed content of various
-  types.
-
-- [ Asynchronous HTTP/1.1 GET requests](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncRequestExecutionExample.java)
-
-  This example demonstrates asynchronous execution of multiple HTTP/1.1 requests.
-
-- [ Asynchronous HTTP/2 GET requests](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2RequestExecutionExample.java)
-
-  This example demonstrates asynchronous execution of multiple HTTP/2 requests.
-
-- [ HTTP/2 requests over TLS connections with ALPN support](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2TlsAlpnRequestExecutionExample.java)
-
-  This example demonstrates how to execute HTTP/2 requests over TLS connections with ALPN support. It also explains how
-  to avoid the illegal reflective access operation warning when running Java 9 or older.
-
-- [ HTTP/2 requests over TLS connections with ALPN support on Java 1.7 and Java 1.8](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2ConscriptRequestExecutionExample.java)
-
-  This example demonstrates how to execute HTTP/2 requests over TLS connections with ALPN support on Java 1.7 and Java
-  1.8.
-
-- [ Asynchronous HTTP/1.1 GET requests with message pipelining](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncPipelinedRequestExecutionExample.java)
-
-  This example demonstrates asynchronous, pipelined execution multiple HTTP/1.1 requests.
-
-- [ Asynchronous HTTP/2 GET requests with multiple concurrent streams](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2MultiStreamExecutionExample.java)
-
-  This example demonstrates asynchronous, multistream execution of multiple HTTP/2 requests.
-
-- [ Classic (blocking) HTTP/1.1 file server](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicFileServerExample.java)
-
-  This is an example of an embedded HTTP/1.1 file server with a classic (blocking) message transport.
-
-- [ Request filters with classic (blocking) HTTP/1.1 server](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicServerFilterExample.java)
-
-  This is an example of using synchronous request filters with an embedded HTTP/1.1 server.
-
-- [ Asynchronous HTTP/1.1 file server](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncFileServerExample.java)
-
-  This is an example of an embedded HTTP/1.1 file server with an event driven, non-blocking message transport.
-
-- [ Request filters with asynchronous HTTP/1.1 server](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncServerFilterExample.java)
-
-  This is an example of using asynchronous request filters with an embedded HTTP/1.1 server.
-
-- [ Asynchronous HTTP/2 file server](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5-h2/src/test/java/org/apache/hc/core5/http2/examples/H2FileServerExample.java)
-
-  This is an example of an embedded HTTP/2 file server with an event driven, non-blocking message transport.
-
-- [ Classic (blocking) HTTP reverse proxy](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/ClassicReverseProxyExample.java)
-
-  This is an example of an embedded HTTP/1.1 reverse proxy with a classic (blocking) message transport.
-
-- [ Asynchronous HTTP reverse proxy](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5/src/test/java/org/apache/hc/core5/http/examples/AsyncReverseProxyExample.java)
-
-  This is an example of an embedded HTTP/1.1 reverse proxy with an event driven, non-blocking message transport.
-
-- [ Client Reactive Streams](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5-reactive/src/test/java/org/apache/hc/core5/reactive/examples/ReactiveFullDuplexClientExample.java)
-
-  This is an example of full-duplex HTTP/1.1 client side message exchanges using reactive streaming.
-
-- [ Server Reactive Streams](https://github.com/apache/httpcomponents-core/tree/5.2.x/httpcore5-reactive/src/test/java/org/apache/hc/core5/reactive/examples/ReactiveFullDuplexServerExample.java)
-
-  This is an example of full-duplex HTTP/1.1 server side message exchanges using reactive streaming.
diff --git a/src/site/markdown/httpcomponents-core-5.2.x/index.md b/src/site/markdown/httpcomponents-core-5.2.x/index.md
deleted file mode 100644
index 918b406..0000000
--- a/src/site/markdown/httpcomponents-core-5.2.x/index.md
+++ /dev/null
@@ -1,54 +0,0 @@
-<!--
-    Licensed to the Apache Software Foundation (ASF) under one
-    or more contributor license agreements.  See the NOTICE file
-    distributed with this work for additional information
-    regarding copyright ownership.  The ASF licenses this file
-    to you under the Apache License, Version 2.0 (the
-    "License"); you may not use this file except in compliance
-    with the License.  You may obtain a copy of the License at
-    
-      http://www.apache.org/licenses/LICENSE-2.0
-    
-    Unless required by applicable law or agreed to in writing,
-    software distributed under the License is distributed on an
-    "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-    KIND, either express or implied.  See the License for the
-    specific language governing permissions and limitations
-    under the License.
--->
-
-HttpCore Overview
-=================
-
-HttpCore is a set of low level HTTP transport components that can be used to build custom client and server side HTTP
-services with a minimal footprint. HttpCore supports two I/O models: blocking I/O model based on the classic Java I/O
-and non-blocking, event driven I/O model based on Java NIO.
-
-Documentation
-=============
-
-1. Some examples of HttpCore components in action can be found [here](./examples.html)
-
-1. Javadocs
-    - [HttpCore HTTP/1.1](./current/httpcore5/apidocs/)
-    - [HttpCore HTTP/2](./current/httpcore5-h2/apidocs/)
-    - [HttpCore Reactive Streams](./current/httpcore5-reactive/apidocs/)
-
-1. API compatibility reports
-    - [HttpCore HTTP/1.1](./current/httpcore5/japicmp.html)
-    - [HttpCore HTTP/2](./current/httpcore5-h2/japicmp.html)
-    - [HttpCore Reactive Streams](./current/httpcore5-reactive/japicmp.html)
-
-Standards Compliance
---------------------
-
-HttpCore components strive to conform to the following specifications endorsed by the Internet Engineering Task Force
-(IETF) and the internet at large:
-
-- [RFC 7540](https://datatracker.ietf.org/doc/html/rfc7540) - Hypertext Transfer Protocol Version 2 (HTTP/2)
-- [RFC 7541](https://datatracker.ietf.org/doc/html/rfc7541) - HPACK: Header Compression for HTTP/2
-- [RFC 7230](https://datatracker.ietf.org/doc/html/rfc7230) - Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
-- [RFC 7231](https://datatracker.ietf.org/doc/html/rfc7231) - Hypertext Transfer Protocol (HTTP/1.1): Semantics and Content
-- [RFC 1945](https://datatracker.ietf.org/doc/html/rfc1945) - Hypertext Transfer Protocol -- HTTP/1.0
-- [RFC 2396](https://datatracker.ietf.org/doc/html/rfc2396) - Uniform Resource Identifiers (URI): Generic Syntax
-
diff --git a/src/site/markdown/httpcomponents-core-5.2.x/related-projects.md b/src/site/markdown/httpcomponents-core-5.3.x/related-projects.md
similarity index 100%
rename from src/site/markdown/httpcomponents-core-5.2.x/related-projects.md
rename to src/site/markdown/httpcomponents-core-5.3.x/related-projects.md
diff --git a/src/site/markdown/news.md b/src/site/markdown/news.md
index 2c7e091..20b4359 100644
--- a/src/site/markdown/news.md
+++ b/src/site/markdown/news.md
@@ -20,7 +20,28 @@
 HttpComponents Project News
 ===========================
 
-###### 3 July 2024 - HttpComponents Core 5.2.5 (GA) released
+###### 12 September 2024 - HttpComponents Core 5.3 GA released
+
+This is the first GA release in the 5.3 release series. This release finalizes the 5.3 APIs
+and improves integration test configuration APIs along with many test code improvements
+
+Notable changes and features included in the 5.3 series:
+
+* Improved conformance to RFC 9110 and RFC 9112.
+
+* UTF-8 encoding to be used by default for text where appropriate.
+
+* Compatibility with Java Virtual Threads and Java 21 Runtime.
+
+* Message parsing API improvements and performance optimization
+
+* TLS client endpoints to make use of JSSE Endpoint Identification by default.
+
+* Redesign of server-side request routing API.
+
+* Redesign of TLS session handling by classic (blocking) connections.
+
+###### 3 July 2024 - HttpComponents Core 5.2.5 GA released
 
 This is a maintenance release that corrects several minor defects discovered since
 release 5.2.4.
@@ -62,22 +83,6 @@ This is the first BETA release in the 5.3 release series. It features a re-desig
 classic (blocking) TLS session management and server-side request routing APIs.
 It is likely to be the last BETA release in the 5.3 release series.
 
-Notable changes and features included in the 5.3 series:
-
-* Improved conformance to RFC 9110 and RFC 9112.
-
-* UTF-8 encoding to be used by default for text where appropriate.
-
-* Compatibility with Java Virtual Threads and Java 21 Runtime.
-
-* Message parsing API improvements and performance optimization
-
-* TLS client endpoints to make use of JSSE Endpoint Identification by default.
-
-* Redesign of server-side request routing API.
-
-* Redesign of TLS session handling by classic (blocking) connections.
-
 ###### 11 March 2024 - HttpComponents Client 5.4-alpha2 released
 
 This is the second and likely the last ALPHA release in the 5.3 release series.
diff --git a/src/site/resources/.htaccess b/src/site/resources/.htaccess
index df78e00..2cef84c 100644
--- a/src/site/resources/.htaccess
+++ b/src/site/resources/.htaccess
@@ -2,9 +2,11 @@ Redirect permanent  "/httpclient-3.x"                  "/httpclient-legacy"
 Redirect permanent  "/httpcomponents-asyncclient"      "/httpcomponents-asyncclient-4.1.x"
 Redirect permanent  "/httpcomponents-asyncclient-ga"   "/httpcomponents-asyncclient-4.1.x"
 
-Redirect permanent  "/httpcomponents-core-5.0.x"       "/httpcomponents-core-5.2.x"
-Redirect permanent  "/httpcomponents-core"             "/httpcomponents-core-5.2.x"
-Redirect permanent  "/httpcomponents-core-ga"          "/httpcomponents-core-5.2.x"
+Redirect permanent  "/httpcomponents-core-5.0.x"       "/httpcomponents-core-5.3.x"
+Redirect permanent  "/httpcomponents-core-5.1.x"       "/httpcomponents-core-5.3.x"
+Redirect permanent  "/httpcomponents-core-5.2.x"       "/httpcomponents-core-5.3.x"
+Redirect permanent  "/httpcomponents-core"             "/httpcomponents-core-5.3.x"
+Redirect permanent  "/httpcomponents-core-ga"          "/httpcomponents-core-5.3.x"
 Redirect permanent  "/httpcomponents-client-5.0.x"     "/httpcomponents-client-5.2.x"
 Redirect permanent  "/httpcomponents-client"           "/httpcomponents-client-5.2.x"
 Redirect permanent  "/httpcomponents-client-ga"        "/httpcomponents-client-5.2.x"
diff --git a/src/site/resources/httpcomponents-core-5.3.x/documentation.links b/src/site/resources/httpcomponents-core-5.3.x/documentation.links
index 4bf26c8..0fa423b 100644
--- a/src/site/resources/httpcomponents-core-5.3.x/documentation.links
+++ b/src/site/resources/httpcomponents-core-5.3.x/documentation.links
@@ -4,4 +4,5 @@
 5.3-alpha1  ../components/httpcomponents-core-5.3.x/5.3-alpha1
 5.3-alpha2  ../components/httpcomponents-core-5.3.x/5.3-alpha2
 5.3-beta1   ../components/httpcomponents-core-5.3.x/5.3-beta1
-current     ../components/httpcomponents-core-5.3.x/5.3-beta1
+5.3         ../components/httpcomponents-core-5.3.x/5.3
+current     ../components/httpcomponents-core-5.3.x/5.3
diff --git a/src/site/site.xml b/src/site/site.xml
index 2d962f9..5b5c0ad 100644
--- a/src/site/site.xml
+++ b/src/site/site.xml
@@ -106,16 +106,11 @@ under the License.
         <item name="Related" href="httpcomponents-client-5.3.x/related-projects.html"/>
         <item name="Download" href="httpcomponents-client-5.3.x/download.html"/>
       </item>
-      <item name="HttpCore 5.3 BETA" collapse="true" href="httpcomponents-core-5.3.x/index.html">
+      <item name="HttpCore 5.3" collapse="true" href="httpcomponents-core-5.3.x/index.html">
         <item name="Examples" href="httpcomponents-core-5.3.x/examples.html"/>
-        <item name="Related" href="httpcomponents-core-5.2.x/related-projects.html"/>
+        <item name="Related" href="httpcomponents-core-5.3.x/related-projects.html"/>
         <item name="Download" href="httpcomponents-core-5.3.x/download.html"/>
       </item>
-      <item name="HttpCore 5.2" collapse="true" href="httpcomponents-core-5.2.x/index.html">
-        <item name="Examples" href="httpcomponents-core-5.2.x/examples.html"/>
-        <item name="Related" href="httpcomponents-core-5.2.x/related-projects.html"/>
-        <item name="Download" href="httpcomponents-core-5.2.x/download.html"/>
-      </item>
       <item name="HttpClient 4.5" collapse="true" href="httpcomponents-client-4.5.x/index.html">
         <item name="Quick Start" href="httpcomponents-client-4.5.x/quickstart.html"/>
         <item name="Tutorial" href="httpcomponents-client-4.5.x/current/tutorial/html/index.html"/>
diff --git a/src/site/xdoc/downloads.xml b/src/site/xdoc/downloads.xml
index a467622..9fbc142 100644
--- a/src/site/xdoc/downloads.xml
+++ b/src/site/xdoc/downloads.xml
@@ -96,41 +96,43 @@
       </ul>
     </subsection>
 
-    <subsection name="HttpCore 5.2.5 (GA)">
+    <subsection name="HttpCore 5.3 (GA)">
       <a href="https://downloads.apache.org/httpcomponents/httpcore/KEYS">KEYS</a>
-      <a href="https://downloads.apache.org/httpcomponents/httpcore/RELEASE_NOTES-5.2.x.txt">Release Notes</a>
+      <a href="https://downloads.apache.org/httpcomponents/httpcore/RELEASE_NOTES-5.3.x.txt">Release Notes</a>
       <br/>
       <p>Binary</p>
       <ul>
         <li>
-          <a href="[preferred]/httpcomponents/httpcore/binary/httpcomponents-core-5.2.5-bin.tar.gz">5.2.5.tar.gz</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.2.5-bin.tar.gz.sha512">
+          <a href="[preferred]/httpcomponents/httpcore/binary/httpcomponents-core-5.3-bin.tar.gz">5.3.tar.gz</a>
+          [<a
+                href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-bin.tar.gz.sha512">
           sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.2.5-bin.tar.gz.asc">
+          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-bin.tar.gz.asc">
           pgp</a>]
         </li>
         <li>
-          <a href="[preferred]/httpcomponents/httpcore/binary/httpcomponents-core-5.2.5-bin.zip">5.2.5.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.2.5-bin.zip.sha512">
+          <a href="[preferred]/httpcomponents/httpcore/binary/httpcomponents-core-5.3-bin.zip">5.3.zip</a>
+          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-bin.zip.sha512">
           sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.2.5-bin.zip.asc">
+          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-bin.zip.asc">
           pgp</a>]
         </li>
       </ul>
       <p>Source</p>
       <ul>
         <li>
-          <a href="[preferred]/httpcomponents/httpcore/source/httpcomponents-core-5.2.5-src.tar.gz">5.2.5.tar.gz</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.2.5-src.tar.gz.sha512">
+          <a href="[preferred]/httpcomponents/httpcore/source/httpcomponents-core-5.3-src.tar.gz">5.3.tar.gz</a>
+          [<a
+                href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-src.tar.gz.sha512">
           sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.2.5-src.tar.gz.asc">
+          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-src.tar.gz.asc">
           pgp</a>]
         </li>
         <li>
-          <a href="[preferred]/httpcomponents/httpcore/source/httpcomponents-core-5.2.5-src.zip">5.2.5.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.2.5-src.zip.sha512">
+          <a href="[preferred]/httpcomponents/httpcore/source/httpcomponents-core-5.3-src.zip">5.3.zip</a>
+          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-src.zip.sha512">
           sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.2.5-src.zip.asc">
+          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-src.zip.asc">
           pgp</a>]
         </li>
       </ul>
@@ -168,48 +170,6 @@
       </ul>
     </subsection>
 
-    <subsection name="HttpCore 5.3-beta1">
-      <a href="https://downloads.apache.org/httpcomponents/httpcore/KEYS">KEYS</a>
-      <a href="https://downloads.apache.org/httpcomponents/httpcore/RELEASE_NOTES-5.3.x.txt">Release Notes</a>
-      <br/>
-      <p>Binary</p>
-      <ul>
-        <li>
-          <a href="[preferred]/httpcomponents/httpcore/binary/httpcomponents-core-5.3-beta1-bin.tar.gz">5.3-beta1.tar.gz</a>
-          [<a
-                href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-beta1-bin.tar.gz.sha512">
-          sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-beta1-bin.tar.gz.asc">
-          pgp</a>]
-        </li>
-        <li>
-          <a href="[preferred]/httpcomponents/httpcore/binary/httpcomponents-core-5.3-beta1-bin.zip">5.3-beta1.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-beta1-bin.zip.sha512">
-          sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/binary/httpcomponents-core-5.3-beta1-bin.zip.asc">
-          pgp</a>]
-        </li>
-      </ul>
-      <p>Source</p>
-      <ul>
-        <li>
-          <a href="[preferred]/httpcomponents/httpcore/source/httpcomponents-core-5.3-beta1-src.tar.gz">5.3-beta1.tar.gz</a>
-          [<a
-                href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-beta1-src.tar.gz.sha512">
-          sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-beta1-src.tar.gz.asc">
-          pgp</a>]
-        </li>
-        <li>
-          <a href="[preferred]/httpcomponents/httpcore/source/httpcomponents-core-5.3-beta1-src.zip">5.3-beta1.zip</a>
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-beta1-src.zip.sha512">
-          sha512</a>]
-          [<a href="https://downloads.apache.org/httpcomponents/httpcore/source/httpcomponents-core-5.3-beta1-src.zip.asc">
-          pgp</a>]
-        </li>
-      </ul>
-    </subsection>
-
     <subsection name="HttpClient 4.5.14 (GA)">
     <a href="https://downloads.apache.org/httpcomponents/httpclient/KEYS">KEYS</a>
     <a href="https://downloads.apache.org/httpcomponents/httpclient/RELEASE_NOTES-4.5.x.txt">Release Notes</a>