You are viewing a plain text version of this content. The canonical link for it is here.
Posted to server-dev@james.apache.org by "Benoit Tellier (Jira)" <ji...@apache.org> on 2019/12/06 04:37:00 UTC

[jira] [Created] (MAILBOX-393) MailboxManager::deleteMailbox by mailboxId

Benoit Tellier created MAILBOX-393:
--------------------------------------

             Summary: MailboxManager::deleteMailbox by mailboxId
                 Key: MAILBOX-393
                 URL: https://issues.apache.org/jira/browse/MAILBOX-393
             Project: James Mailbox
          Issue Type: Improvement
          Components: api
            Reporter: Benoit Tellier


Currently we can only delete a mailbox by it's mailboxPath.

MailboxPath is mutable as a mailbox can be renamed.

Mutable identifiers are bad, and thus race conditions can arise upon mailbox deletion:


{code:java}
Given a mailboxId
I read the corresponding mailboxPath
and a concurrent session renames the mailbox (switch name) after my read
When I delete the mailbox using the previously read path
Then I bloew up the wrong mailbox (!!!)
{code}




--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: server-dev-unsubscribe@james.apache.org
For additional commands, e-mail: server-dev-help@james.apache.org