You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Hudson (JIRA)" <ji...@apache.org> on 2016/10/21 20:52:58 UTC

[jira] [Commented] (MNG-6081) Log refactoring - Method Invocation Replaced By Variable

    [ https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15596332#comment-15596332 ] 

Hudson commented on MNG-6081:
-----------------------------

SUCCESS: Integrated in Jenkins build maven-3.x #1403 (See [https://builds.apache.org/job/maven-3.x/1403/])
[MNG-6081] Log refactoring - Method Invocation Replaced By Variable (michaelo: rev e07978bdca0fe80ba059c686ac92229065b0fd44)
* (edit) maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java


> Log refactoring - Method Invocation Replaced By Variable
> --------------------------------------------------------
>
>                 Key: MNG-6081
>                 URL: https://issues.apache.org/jira/browse/MNG-6081
>             Project: Maven
>          Issue Type: Improvement
>          Components: core
>    Affects Versions: 3.3.9
>            Reporter: Nemo Chen
>            Assignee: Michael Osipov
>            Priority: Minor
>             Fix For: 3.4.0
>
>         Attachments: MNG-6081.patch
>
>
> *Method Invocation Replaced By Variable*
> In file: apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java
> from line 70:
> {code}
> String keptVersion = kept.getVersion();
> if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : keptVersion != null )
> {
>     logger.debug( indent + omitted + " (removed - nearer found: " + kept.getVersion() + ")" );
> }
> {code}
> the "kept.getVersion()" can be replaced with "keptVersion" for the sake of simplicity and readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)