You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Owen O'Malley (JIRA)" <ji...@apache.org> on 2006/06/29 19:30:29 UTC

[jira] Created: (HADOOP-335) factor out the namespace image/transaction log writing

factor out the namespace image/transaction log writing
------------------------------------------------------

         Key: HADOOP-335
         URL: http://issues.apache.org/jira/browse/HADOOP-335
     Project: Hadoop
        Type: Improvement

    Reporter: Owen O'Malley


Factor the checkpoint/transaction log handling code out of FSNameSystem into its own class.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (HADOOP-335) factor out the namespace image/transaction log writing

Posted by "Konstantin Shvachko (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/HADOOP-335?page=all ]

Konstantin Shvachko updated HADOOP-335:
---------------------------------------

    Attachment: FSImage_Refactor2.patch

- I synchronized the patch with the current trunk,
- and reversed indentation changes.


> factor out the namespace image/transaction log writing
> ------------------------------------------------------
>
>                 Key: HADOOP-335
>                 URL: http://issues.apache.org/jira/browse/HADOOP-335
>             Project: Hadoop
>          Issue Type: Improvement
>            Reporter: Owen O'Malley
>         Assigned To: Konstantin Shvachko
>         Attachments: FSImage_Refactor1.patch, FSImage_Refactor2.patch
>
>
> Factor the checkpoint/transaction log handling code out of FSNameSystem into its own class.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Resolved: (HADOOP-335) factor out the namespace image/transaction log writing

Posted by "Doug Cutting (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/HADOOP-335?page=all ]

Doug Cutting resolved HADOOP-335.
---------------------------------

    Fix Version/s: 0.5.0
       Resolution: Fixed

I just committed this.  Thanks, Konstantin.

> factor out the namespace image/transaction log writing
> ------------------------------------------------------
>
>                 Key: HADOOP-335
>                 URL: http://issues.apache.org/jira/browse/HADOOP-335
>             Project: Hadoop
>          Issue Type: Improvement
>            Reporter: Owen O'Malley
>         Assigned To: Konstantin Shvachko
>             Fix For: 0.5.0
>
>         Attachments: FSImage_Refactor1.patch, FSImage_Refactor2.patch
>
>
> Factor the checkpoint/transaction log handling code out of FSNameSystem into its own class.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Updated: (HADOOP-335) factor out the namespace image/transaction log writing

Posted by "Konstantin Shvachko (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/HADOOP-335?page=all ]

Konstantin Shvachko updated HADOOP-335:
---------------------------------------

    Attachment: FSImage_Refactor1.patch

I factored out two new classes FSImage and FSEditLog from FSDirectory.
FSImage maintains the dfs image file and checkpointing.
FSEditLog is responsible for the edits file and the namespace updates logging.
Thus, FSDirectory has only namespace methods and the INode class.
This should simplify implementation of checkpointing and logging
upgrades intended to improve the fs reliability.
It should also localize changes related to the namespace versioning.

The INode probably also needs to be factored out into a separate class,
since the type is already referenced in other classes, and it does not have
any dependencies on the outer class.

> factor out the namespace image/transaction log writing
> ------------------------------------------------------
>
>          Key: HADOOP-335
>          URL: http://issues.apache.org/jira/browse/HADOOP-335
>      Project: Hadoop
>         Type: Improvement

>     Reporter: Owen O'Malley
>  Attachments: FSImage_Refactor1.patch
>
> Factor the checkpoint/transaction log handling code out of FSNameSystem into its own class.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (HADOOP-335) factor out the namespace image/transaction log writing

Posted by "Doug Cutting (JIRA)" <ji...@apache.org>.
    [ http://issues.apache.org/jira/browse/HADOOP-335?page=comments#action_12421038 ] 

Doug Cutting commented on HADOOP-335:
-------------------------------------

You mix indentation and style changes with functional changes.  Can you please keep these separate?  If you like, make the style changes, but as a separate patch, so that your patch is easier to evaluate.  It's a good practice to preview your patches and make sure that each change in the patch is required by the issue the patch purports to fix.


> factor out the namespace image/transaction log writing
> ------------------------------------------------------
>
>          Key: HADOOP-335
>          URL: http://issues.apache.org/jira/browse/HADOOP-335
>      Project: Hadoop
>         Type: Improvement

>     Reporter: Owen O'Malley
>     Assignee: Konstantin Shvachko
>  Attachments: FSImage_Refactor1.patch
>
> Factor the checkpoint/transaction log handling code out of FSNameSystem into its own class.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Assigned: (HADOOP-335) factor out the namespace image/transaction log writing

Posted by "Konstantin Shvachko (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/HADOOP-335?page=all ]

Konstantin Shvachko reassigned HADOOP-335:
------------------------------------------

    Assign To: Konstantin Shvachko

> factor out the namespace image/transaction log writing
> ------------------------------------------------------
>
>          Key: HADOOP-335
>          URL: http://issues.apache.org/jira/browse/HADOOP-335
>      Project: Hadoop
>         Type: Improvement

>     Reporter: Owen O'Malley
>     Assignee: Konstantin Shvachko
>  Attachments: FSImage_Refactor1.patch
>
> Factor the checkpoint/transaction log handling code out of FSNameSystem into its own class.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (HADOOP-335) factor out the namespace image/transaction log writing

Posted by "Konstantin Shvachko (JIRA)" <ji...@apache.org>.
    [ http://issues.apache.org/jira/browse/HADOOP-335?page=comments#action_12421272 ] 
            
Konstantin Shvachko commented on HADOOP-335:
--------------------------------------------

Sorry, this probably needed more explanation than I provided.
This is a pure refactoring patch. It does not introduce new
functionality, or improve performance, or fix a bug. The idea is to
make the code modular, easy to understand, and simplify further
modifications. So restyling seems rather appropriate in the case.
Besides, I restyle only the parts that I change. I find it reasonable
to stick to the same style at least within the same method.
I believe this patch does a minimal modification to the existing code
that achieves the goal stated by Owen in the initial comment to the issue.
Doug, I do not know what tools you use to evaluate patches.
Does it provide "ignore white spaces" option? That usually helps to
distinguish real changes from restyling.
>From your comment I did not realize is there anything I need to
change in my code, please clarify.


> factor out the namespace image/transaction log writing
> ------------------------------------------------------
>
>                 Key: HADOOP-335
>                 URL: http://issues.apache.org/jira/browse/HADOOP-335
>             Project: Hadoop
>          Issue Type: Improvement
>            Reporter: Owen O'Malley
>         Assigned To: Konstantin Shvachko
>         Attachments: FSImage_Refactor1.patch
>
>
> Factor the checkpoint/transaction log handling code out of FSNameSystem into its own class.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira