You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@sqoop.apache.org by "Abraham Elmahrek (JIRA)" <ji...@apache.org> on 2014/09/13 21:40:33 UTC

[jira] [Commented] (SQOOP-1497) Sqoop2: Sqoop2 Entity Nomenclature Revisited

    [ https://issues.apache.org/jira/browse/SQOOP-1497?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14132904#comment-14132904 ] 

Abraham Elmahrek commented on SQOOP-1497:
-----------------------------------------

+1 as long as:
# We rename contexts to configs (since contexts are overloaded with ActorContext, PrefixContext, etc. in the code base).
# Document the relationship between links and connectors.

> Sqoop2: Sqoop2 Entity Nomenclature Revisited
> --------------------------------------------
>
>                 Key: SQOOP-1497
>                 URL: https://issues.apache.org/jira/browse/SQOOP-1497
>             Project: Sqoop
>          Issue Type: Improvement
>            Reporter: Veena Basavaraj
>            Assignee: Veena Basavaraj
>         Attachments: SimplifySqoopEntityNomenclature.pdf
>
>
> See the attached PDF.
> Naming Entities is as important as the functionality :). In sqoop2, we have evolved Sqoop to support a lot more things and it is good to reconsider /revisit the entity nomenclature we currently have



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)