You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Mirko Friedenhagen (JIRA)" <ji...@apache.org> on 2016/08/20 20:37:20 UTC

[jira] [Updated] (MNG-6081) Log refactoring - Method Invocation Replaced By Variable

     [ https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Mirko Friedenhagen updated MNG-6081:
------------------------------------
    Priority: Minor  (was: Major)

> Log refactoring - Method Invocation Replaced By Variable
> --------------------------------------------------------
>
>                 Key: MNG-6081
>                 URL: https://issues.apache.org/jira/browse/MNG-6081
>             Project: Maven
>          Issue Type: Bug
>    Affects Versions: 3.3.9
>            Reporter: Nemo Chen
>            Priority: Minor
>
> *Method Invocation Replaced By Variable*
> In file: apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java
> from line 70:
> {code}
> String keptVersion = kept.getVersion();
> if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : keptVersion != null )
> {
>     logger.debug( indent + omitted + " (removed - nearer found: " + kept.getVersion() + ")" );
> }
> {code}
> the "kept.getVersion()" can be replaced with "keptVersion" for the sake of simplicity and readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)