You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-dev@axis.apache.org by ro...@apache.org on 2008/01/11 19:45:06 UTC

svn commit: r611258 - /webservices/axis2/trunk/java/modules/kernel/src/org/apache/axis2/description/AxisService.java

Author: rott
Date: Fri Jan 11 10:45:04 2008
New Revision: 611258

URL: http://svn.apache.org/viewvc?rev=611258&view=rev
Log:
comments added to AxisService.getOperationBySOAPAction for clarity

Modified:
    webservices/axis2/trunk/java/modules/kernel/src/org/apache/axis2/description/AxisService.java

Modified: webservices/axis2/trunk/java/modules/kernel/src/org/apache/axis2/description/AxisService.java
URL: http://svn.apache.org/viewvc/webservices/axis2/trunk/java/modules/kernel/src/org/apache/axis2/description/AxisService.java?rev=611258&r1=611257&r2=611258&view=diff
==============================================================================
--- webservices/axis2/trunk/java/modules/kernel/src/org/apache/axis2/description/AxisService.java (original)
+++ webservices/axis2/trunk/java/modules/kernel/src/org/apache/axis2/description/AxisService.java Fri Jan 11 10:45:04 2008
@@ -1412,6 +1412,9 @@
 
         AxisOperation operation = null;
         Iterator children = getChildren();
+        // I could not find any spec statement that explicitly forbids using a short name in the SOAPAction header or wsa:Action element,
+        // so I believe this to be valid.  There may be customers using the shortname as the SOAPAction in their client code that would
+        // also require this support.
         while(children.hasNext() && (operation == null)){
         	AxisOperation op = (AxisOperation)children.next();
         	if(op.getName().getLocalPart().equals(soapAction)){



---------------------------------------------------------------------
To unsubscribe, e-mail: axis-cvs-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-cvs-help@ws.apache.org