You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Aaron T. Myers (JIRA)" <ji...@apache.org> on 2011/06/30 19:28:28 UTC

[jira] [Created] (HADOOP-7435) Make pre-commit checks run against the correct branch

Make pre-commit checks run against the correct branch
-----------------------------------------------------

                 Key: HADOOP-7435
                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
             Project: Hadoop Common
          Issue Type: Improvement
          Components: test
    Affects Versions: 0.23.0
            Reporter: Aaron T. Myers
             Fix For: 0.23.0


The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Harsh J (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Harsh J updated HADOOP-7435:
----------------------------

    Fix Version/s:     (was: 0.24.0)
    
> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>            Assignee: Matt Foley
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Updated] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Dennis Y (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dennis Y updated HADOOP-7435:
-----------------------------

    Attachment: HADOOP-7435-for-trunk-do-not-apply-this.patch
                HADOOP-7435-for-branch-2.patch
                HADOOP-7435-for-branch-0.23.patch

Last patch is intended for pass through pre-commit job ONLY. No need to apply 'HADOOP-7435-for-trunk-do-not-apply-this.patch'
                
> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>            Assignee: Matt Foley
>         Attachments: HADOOP-7435-for-branch-0.23.patch, HADOOP-7435-for-branch-2.patch, HADOOP-7435-for-trunk-do-not-apply-this.patch
>
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

[jira] [Assigned] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Matt Foley (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Matt Foley reassigned HADOOP-7435:
----------------------------------

    Assignee: Matt Foley

> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>            Assignee: Matt Foley
>             Fix For: 0.23.0
>
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Matt Foley (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13105667#comment-13105667 ] 

Matt Foley commented on HADOOP-7435:
------------------------------------

A naming convention has now been established in the wiki page [HowToContribute|http://wiki.apache.org/hadoop/HowToContribute].  It says:

bq. Patches for trunk should be named jira-xyz.patch, eg hdfs-123.patch. Patches for a specific branch should be named jira-xyz-branch.patch, eg hdfs-123-branch-0.20-security. ... The branch name allows the pre-commit tests to run against the correct branch.

Okay, so we need to tweak the patch-testing robot to examine the trailing set of hyphen-separated components of the patch name to see if it matches any Hadoop branch names.  Not a perfect spec, but sounds usable.


> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>             Fix For: 0.23.0
>
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Matt Foley (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13058159#comment-13058159 ] 

Matt Foley commented on HADOOP-7435:
------------------------------------

Definitely a good idea. Does Hudson handle any arbitrary branch, or only ones that have a current nightly build job?  

I'd be okay with a patch naming convention, and don't really like overloading "Fix versions".  But there is one more piece of info available:  Patches generated with "svn diff" have svn release numbers next to each pre-existing file name.  That release number should be uniquely associated with a particular branch, which test-patch could identify and use.  But git patch tags probably don't allow for the same trick.

At any rate, the patch naming convention has the advantage of letting the developer specify what branch to test against.  That's probably the best approach.

> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>             Fix For: 0.23.0
>
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Aaron T. Myers (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13057941#comment-13057941 ] 

Aaron T. Myers commented on HADOOP-7435:
----------------------------------------

I'm envisioning something like this:

# If there's only a single "fix version" set on the relevant JIRA, try to apply the patch/test against that branch.
# If there's multiple "fix versions" set on the relevant JIRA, we could have a convention for naming the patch to indicate which branch it should be tested against, e.g. "*-22.patch" for 0.22.
# If there's no fix version set, default to testing the patch against trunk.

> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>             Fix For: 0.23.0
>
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Matt Foley (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13105745#comment-13105745 ] 

Matt Foley commented on HADOOP-7435:
------------------------------------

When we succeed in providing this feature, the wiki page at [HowToContribute|http://wiki.apache.org/hadoop/HowToContribute] should be updated to document the test-patch behavior.

> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>            Assignee: Matt Foley
>             Fix For: 0.23.0
>
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Jonathan Eagles (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13058008#comment-13058008 ] 

Jonathan Eagles commented on HADOOP-7435:
-----------------------------------------

Thanks, Aaron for this great idea. Here are some of my thoughts on this.

Having patch file naming convention would allow for some interesting use cases. Though a simple version of this patch naming scheme would be a great addition, here is a full blown implementation I was thinking about.

<ISSUE-#>-<full branch name>-v<version #>.patch

(e.g. MAPREDUCE-2569-MR-279-v2.patch)

- This naming scheme makes the patch completely stand-alone, allowing for emailing the patch
- Sanity of managing multiple patch files simultaneously in dev env
- Programmatic detection of which branch to apply
- Versioning of patches helps those who are submitting and testing out patches, and prevents hudson/jenkins from applying several versions of the same patch and instead tests only the latest version of the patch.
- JIRA attach file pre-commit detects "*.patch" and verifies patch naming convention.

Personally, I do not prefer to overload "Fix version/s" since that implies what branches the patch is already committed to, leading to confusion. Additionally, newbie hadoop developers may be able to attach files to issues, but are not allowed to edit issue fields.

> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>             Fix For: 0.23.0
>
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (HADOOP-7435) Make pre-commit checks run against the correct branch

Posted by "Dennis Y (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-7435?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dennis Y updated HADOOP-7435:
-----------------------------

    Status: Patch Available  (was: Open)
    
> Make pre-commit checks run against the correct branch
> -----------------------------------------------------
>
>                 Key: HADOOP-7435
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7435
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.23.0
>            Reporter: Aaron T. Myers
>            Assignee: Matt Foley
>
> The Hudson pre-commit tests are presently only capable of testing a patch against trunk. It'd be nice if this could be extended to automatically run against the correct branch.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira