You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Chris Douglas (JIRA)" <ji...@apache.org> on 2016/07/13 23:12:20 UTC

[jira] [Commented] (YARN-5164) CapacityOvertimePolicy does not take advantaged of plan RLE

    [ https://issues.apache.org/jira/browse/YARN-5164?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15375971#comment-15375971 ] 

Chris Douglas commented on YARN-5164:
-------------------------------------

Only minor nits, otherwise +1:
{{CapacityOverTimePolicy}}
- Avoid importing java.util.\*
- Where the intermediate points are added, the code would be more readable if the key were assigned to a named variable (instead of multiple calls to {{e.getKey()}}). Same with the point-wise integral computation
- checkstyle (spacing): {{+      if(e.getValue()!=null) {}}
- A comment briefly sketching the algorithm would help future maintainers

{{NoOverCommitPolicy}}
- The exception message should be reformatted (some redundant string concats) and omit references to the time it no longer reports
- Should the {{PlanningException}} be added as a cause, rather than concatenated with the ReservationID?

> CapacityOvertimePolicy does not take advantaged of plan RLE
> -----------------------------------------------------------
>
>                 Key: YARN-5164
>                 URL: https://issues.apache.org/jira/browse/YARN-5164
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>          Components: capacityscheduler, fairscheduler, resourcemanager
>            Reporter: Carlo Curino
>            Assignee: Carlo Curino
>         Attachments: YARN-5164-example.pdf, YARN-5164-inclusive.4.patch, YARN-5164-inclusive.5.patch, YARN-5164.1.patch, YARN-5164.2.patch, YARN-5164.5.patch, YARN-5164.6.patch
>
>
> As a consequence small time granularities (e.g., 1 sec) and long time horizon for a reservation (e.g., months) run rather slow (10 sec). 
> Proposed resolution is to switch to interval math in checking, similar to how YARN-4359 does for agents.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org