You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@avalon.apache.org by J Aaron Farr <fa...@apache.org> on 2004/01/13 20:38:45 UTC

Re: [MERLIN] New "launch" parameter?

On Wed, 2004-01-14 at 00:22, Alex Karasulu wrote:


> > The one caveat I can think of would be figuring out the type of resource,
> > since it could be a jar (with embedded block.xml) or one of those .bar
> > things that Stephen had once.  I'd prefer to just reference an XML page
> > since that requires less network traffic.  So maybe:
> > 
> >       merlin -launch appGroup:appName:type-VERSION
> > 
> 
> I agree with the XML reference.  But perhaps it might be worth keeping
> the type incase you switch the way you access the directory of 
> applications at your disposal :-).  Or better yet what about using a 
> URL instead?

A URL is definitely an option.  In fact, that's where the idea kinda
started.  As Niclas pointed out, you can already do something like:

  merlin -execute http://myserver.org/myCoolProject/block.xml

The idea of using the other naming approach (more of URN than URL) is
that:

   - It follows the same naming conventions in the block.xml
   - It works well with the whole repository idea 
     (and makes the repository transparent)
   - If you have more than one repository, it should protect
     against failing to hit one of the servers
   - It makes it easy to handling Merlin caching the resource
     for offline use (ie- a SNAPSHOT approach will work if nothing else)

But I'm sure it isn't perfect.

-- 
 jaaron  <http://jadetower.org>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Re: [MERLIN] New "launch" parameter?

Posted by Niclas Hedhman <ni...@hedhman.org>.
On Wednesday 14 January 2004 05:41, Stephen McConnell wrote:
>    a) the spec external form currently uses [group]:[name];[version]
>       but the ";" character is problematic on a unix command line
>       unless quoted (but this isn't a problem when used in a
>       properties file)
>
>    b) the spec external form does not provide a way of declaring the
>       type
>
> I'm currently thinking that a separate url cache would be better.

My GUT (high authority in design issues) says that the separate caching is 
probably NOT better.
I like the concept of central declaration of available repositories, and don't 
have to worry about the absolute URLs.

In respect to the "semicolon" on Linux/Unix systems, and being a user of these 
systems, _I_ have NoProblem with a quoting requirement. 9 out 10 case, I 
would have either have a shell script OR launching via the GUI, which does 
not have problems with semicolon (it is only part of the SH syntax).

Niclas

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org


Re: [MERLIN] New "launch" parameter?

Posted by Stephen McConnell <mc...@apache.org>.
J Aaron Farr wrote:

> On Wed, 2004-01-14 at 00:22, Alex Karasulu wrote:
> 
> 
> 
>>>The one caveat I can think of would be figuring out the type of resource,
>>>since it could be a jar (with embedded block.xml) or one of those .bar
>>>things that Stephen had once.  I'd prefer to just reference an XML page
>>>since that requires less network traffic.  So maybe:
>>>
>>>      merlin -launch appGroup:appName:type-VERSION
>>>
>>
>>I agree with the XML reference.  But perhaps it might be worth keeping
>>the type incase you switch the way you access the directory of 
>>applications at your disposal :-).  Or better yet what about using a 
>>URL instead?
> 
> 
> A URL is definitely an option.  In fact, that's where the idea kinda
> started.  As Niclas pointed out, you can already do something like:
> 
>   merlin -execute http://myserver.org/myCoolProject/block.xml

Seems to me that we have two options here:

   URL
   Artifact spec

If we use a url we are not going through the repository, instead we 
would need to setup a separate cache with an index that keys resources 
against url.

If we use the artifact spec then we need to establish a more complete 
specification that what is currently recognized by Merlin.  Currently 
you can select the merlin implementation using an artifact spec, but 
this has two associated problems:

   a) the spec external form currently uses [group]:[name];[version]
      but the ";" character is problematic on a unix command line
      unless quoted (but this isn't a problem when used in a
      properties file)

   b) the spec external form does not provide a way of declaring the
      type

I'm currently thinking that a separate url cache would be better.

Stephen.

p.s. Thanks to Alexis for the note on the ";" issue


> The idea of using the other naming approach (more of URN than URL) is
> that:
> 
>    - It follows the same naming conventions in the block.xml
>    - It works well with the whole repository idea 
>      (and makes the repository transparent)
>    - If you have more than one repository, it should protect
>      against failing to hit one of the servers
>    - It makes it easy to handling Merlin caching the resource
>      for offline use (ie- a SNAPSHOT approach will work if nothing else)
> 
> But I'm sure it isn't perfect.
> 


-- 

|------------------------------------------------|
| Magic by Merlin                                |
| Production by Avalon                           |
|                                                |
| http://avalon.apache.org/merlin                |
| http://dpml.net/merlin/distributions/latest    |
|------------------------------------------------|

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@avalon.apache.org
For additional commands, e-mail: dev-help@avalon.apache.org