You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafficserver.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2014/04/20 21:21:33 UTC

[jira] [Commented] (TS-2660) rename state machine action values

    [ https://issues.apache.org/jira/browse/TS-2660?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13975236#comment-13975236 ] 

ASF subversion and git services commented on TS-2660:
-----------------------------------------------------

Commit c5c92b9491f3172e5f600502df65b1a99a2e535e in trafficserver's branch refs/heads/lua_config from [~zwoop]
[ https://git-wip-us.apache.org/repos/asf?p=trafficserver.git;h=c5c92b9 ]

Merge remote-tracking branch 'origin/master' into lua_config

* origin/master: (363 commits)
  TS-2564 Revert field token ordering.
  [TS-2664] atscppapi: Removing initializable value code
  [TS-2664] Removing initializable value code
  [TS-2664] Removing initializable value files
  TS-2660: rename StateMachineAction_t values with a consistent prefix
  [TS-2662] Re-enable KEEP_ALIVE_POST_OUT by default.
  [TS-2662] Re-enable KEEP_ALIVE_POST_OUT by default. This closes #66
  Fix harmless Ethread::schedule_in parameter mismatch
  TS-2661: Remove unused HttpSM::decide_cached_url method.
  Remaporder
  TS-2658: additional SSL certificate logging
  Cleanup the configure.ac in some sort of order... Minor.
  Update CHANGES with TS-2431
  TS-2431: Migrate Taobao SPDY plugin to ATS core
  TS-2431: Preparation of SPDY protocol
  TS-2431: Add autoconf options for SPDY
  [TS-2651] atscppapi: race conditions in destruction of async providers. This closes #64
  [TS-2651] atscppapi: race conditions in destruction of async providers
  [TS-2651] atscppapi: race conditions in destruction of async providers
  [TS-2651] atscppapi: race conditions in destruction of async providers
  ...

Conflicts:
	iocore/net/SSLUtils.cc
	proxy/Makefile.am


> rename state machine action values
> ----------------------------------
>
>                 Key: TS-2660
>                 URL: https://issues.apache.org/jira/browse/TS-2660
>             Project: Traffic Server
>          Issue Type: Bug
>          Components: Cleanup
>            Reporter: James Peach
>            Assignee: James Peach
>            Priority: Minor
>              Labels: Review
>             Fix For: 5.0.0
>
>
> The values of {{StateMachineAction_t}} do not adhere to any naming convention, making them hard to recognize and find in code. We should apply a naming convention and remove unused values.
> The patch I have ends up with this set of values:
> {code}
>     SM_ACTION_UNDEFINED = 0,
>     // SM_ACTION_AUTH_LOOKUP,
>     SM_ACTION_DNS_LOOKUP,
>     SM_ACTION_DNS_REVERSE_LOOKUP,
>     SM_ACTION_CACHE_LOOKUP,
>     SM_ACTION_CACHE_ISSUE_WRITE,
>     SM_ACTION_CACHE_ISSUE_WRITE_TRANSFORM,
>     SM_ACTION_CACHE_PREPARE_UPDATE,
>     SM_ACTION_CACHE_ISSUE_UPDATE,
>     SM_ACTION_ICP_QUERY,
>     SM_ACTION_ORIGIN_SERVER_OPEN,
>     SM_ACTION_ORIGIN_SERVER_RAW_OPEN,
>     SM_ACTION_ORIGIN_SERVER_RR_MARK_DOWN,
>     SM_ACTION_READ_PUSH_HDR,
>     SM_ACTION_STORE_PUSH_BODY,
>     SM_ACTION_INTERNAL_CACHE_DELETE,
>     SM_ACTION_INTERNAL_CACHE_NOOP,
>     SM_ACTION_INTERNAL_CACHE_UPDATE_HEADERS,
>     SM_ACTION_INTERNAL_CACHE_WRITE,
>     SM_ACTION_INTERNAL_100_RESPONSE,
>     SM_ACTION_INTERNAL_REQUEST,
>     SM_ACTION_SEND_ERROR_CACHE_NOOP,
> #ifdef PROXY_DRAIN
>     SM_ACTION_DRAIN_REQUEST_BODY,
> #endif /* PROXY_DRAIN */
>     SM_ACTION_SERVE_FROM_CACHE,
>     SM_ACTION_SERVER_READ,
>     SM_ACTION_SERVER_PARSE_NEXT_HDR,
>     SM_ACTION_TRANSFORM_READ,
>     SM_ACTION_SSL_TUNNEL,
>     SM_ACTION_CONTINUE,
>     SM_ACTION_API_SM_START,
>     SM_ACTION_API_READ_REQUEST_HDR,
>     SM_ACTION_API_PRE_REMAP,
>     SM_ACTION_API_POST_REMAP,
>     SM_ACTION_API_OS_DNS,
>     SM_ACTION_API_SEND_REQUEST_HDR,
>     SM_ACTION_API_READ_CACHE_HDR,
>     SM_ACTION_API_CACHE_LOOKUP_COMPLETE,
>     SM_ACTION_API_READ_RESPONSE_HDR,
>     SM_ACTION_API_SEND_RESPONSE_HDR,
>     SM_ACTION_API_SM_SHUTDOWN,
>     SM_ACTION_REMAP_REQUEST,
>     SM_ACTION_POST_REMAP_SKIP,
>     SM_ACTION_REDIRECT_READ
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)