You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Konstantin Boudnik (JIRA)" <ji...@apache.org> on 2009/05/19 05:22:45 UTC

[jira] Work started: (HADOOP-5868) FSDirectory.renameTo(String, String) has unclear logic around unprotectedRenameTo() call

     [ https://issues.apache.org/jira/browse/HADOOP-5868?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Work on HADOOP-5868 started by Konstantin Boudnik.

> FSDirectory.renameTo(String, String) has unclear logic around unprotectedRenameTo() call
> ----------------------------------------------------------------------------------------
>
>                 Key: HADOOP-5868
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5868
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>    Affects Versions: 0.20.0
>            Reporter: Konstantin Boudnik
>            Assignee: Konstantin Boudnik
>            Priority: Minor
>         Attachments: HADOOP-5868.patch
>
>
> Current implementation of renameTo(String, String) has this piece of the code at the end:
> ...
>     if (!unprotectedRenameTo(src, dst, now))
>       return false;
>     fsImage.getEditLog().logRename(src, dst, now);
>     return true;
> }
> The logic of the code isn't very clear from a very sight. A slight modification is recommended to make it more readable.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.