You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@cocoon.apache.org by Antonio Gallardo <ag...@agssa.net> on 2005/10/02 04:49:34 UTC
Re: [cforms] rethinking library naming
Sylvain Wallez wrote:
> Ugo Cei wrote:
>
>> Il giorno 26/set/05, alle 17:23, Sylvain Wallez ha scritto:
>>
>>> - rename <fd:class> to <fd:macro> (this is the wording used on the
>>> wiki [1][2])
>>> - rename <fd:new> to <fd:expand>: "expanding" is the word used
>>> traditionally to denote insertion of the macro contents at the
>>> current location.
>>
>>
>>
>> I'd rather use <fd:call-macro> or something like that to reinforce
>> the idea that what we are expanding is indeed a macro.
>
>
>
> Hmm... call-macro implies some kind of statement execution, while we
> are just expanding the contents of the macro...
Yes. What about <fd:expand-macro>, <fd:apply-macro> or <fd:use-macro>?
Best Regards,
Antonio Gallardo.
>
> Sylvain
>