You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Martin Furter <mf...@rola.ch> on 2008/06/19 23:56:06 UTC

[PATCH] use class to minimize duplicate code in kwallet.cpp

I can't test this patch since I do not have KDE4. But I compared it to the 
old code and I believe it does the same things.

[[[
Move the kwallet_password_get/kwallet_password_set code of
libsvn_auth_kwallet into a class to minimize duplicated code.

* subversion/libsvn_auth_kwallet/kwallet.cpp
   (SvnKWallet): New class containing the code of kwallet_password_get
     and kwallet_password_set.
   (kwallet_password_get): Use SvnKWallet to do the work.
   (kwallet_password_set): Ditto.
]]]