You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Hairong Kuang (JIRA)" <ji...@apache.org> on 2009/01/16 23:17:59 UTC

[jira] Updated: (HADOOP-5016) FSNamesystem should have an InvalidateBlockMap class to manage blocks scheduled to remove

     [ https://issues.apache.org/jira/browse/HADOOP-5016?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Hairong Kuang updated HADOOP-5016:
----------------------------------

    Attachment: invalidateBlocksMap.patch

This patch is mainly code refactoring, moving code related to invalidate blocks to a class called "InvalidateBlocksMap". But still it has two optimization:
1. when removing all replicas of a block, it does not traverse all nodes in the map. Instead it traverse only the nodes that the block is located.
2. When dispatching blocks to datanodes in ReplicationMonitor. It randomly chooses a predefined number of datanodes and dispatches blocks to those datanodes. This strategy provides fairness to all datanodes. The old strategy always starts from the first datanode.

> FSNamesystem should have an InvalidateBlockMap class to manage blocks scheduled to remove
> -----------------------------------------------------------------------------------------
>
>                 Key: HADOOP-5016
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5016
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Hairong Kuang
>            Assignee: Hairong Kuang
>             Fix For: 0.21.0
>
>         Attachments: invalidateBlocksMap.patch
>
>
> This jira intends to move the code that handles recentInvalideSet to a separate class InvalidateBlockMap.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.