You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "ASF GitHub Bot (Jira)" <ji...@apache.org> on 2023/11/30 16:03:00 UTC
[jira] [Updated] (HDDS-9806) Refactor TestBlockOutputStream
[ https://issues.apache.org/jira/browse/HDDS-9806?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
ASF GitHub Bot updated HDDS-9806:
---------------------------------
Labels: pull-request-available (was: )
> Refactor TestBlockOutputStream
> ------------------------------
>
> Key: HDDS-9806
> URL: https://issues.apache.org/jira/browse/HDDS-9806
> Project: Apache Ozone
> Issue Type: Improvement
> Components: test
> Reporter: Attila Doroszlai
> Assignee: Attila Doroszlai
> Priority: Major
> Labels: pull-request-available
>
> * {{TestBlockOutputStream}} is duplicated as {{TestBlockOutputStreamFlushDelay}}
> * {{TestBlockOutputStreamWithFailures}} is duplicated as {{TestBlockOutputStreamWithFailuresFlushDelay}}
> The main difference between the duplicates is that the ones without {{FlushDelay}} set {{OzoneClientConfig.setStreamBufferFlushDelay(false)}}, while the ones with {{FlushDelay}} rely on the default value for this property being {{true}}.
> The goal of this task is to reduce code duplication.
> Furthermore, {{streamBufferFlushDelay}} is a client-side config, so we can completely merge {{TestBlockOutputStream}} and {{TestBlockOutputStreamFlushDelay}} by:
> * making test cases parameterized
> * creating a new client for each test case
> {code}
> hadoop-ozone/integration-test/src/test/java/org/apache/hadoop/ozone/client/rpc/TestBlockOutputStream.java
> hadoop-ozone/integration-test/src/test/java/org/apache/hadoop/ozone/client/rpc/TestBlockOutputStreamFlushDelay.java
> hadoop-ozone/integration-test/src/test/java/org/apache/hadoop/ozone/client/rpc/TestBlockOutputStreamWithFailures.java
> hadoop-ozone/integration-test/src/test/java/org/apache/hadoop/ozone/client/rpc/TestBlockOutputStreamWithFailuresFlushDelay.java
> {code}
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org