You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@zookeeper.apache.org by "Thomas Koch (JIRA)" <ji...@apache.org> on 2011/09/26 17:47:27 UTC

[jira] [Created] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Shorten calls to ZooTrace
-------------------------

                 Key: ZOOKEEPER-1204
                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
             Project: ZooKeeper
          Issue Type: Sub-task
            Reporter: Thomas Koch
            Assignee: Thomas Koch
         Attachments: ZOOKEEPER-1204.patch

The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Posted by "Hadoop QA (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13114753#comment-13114753 ] 

Hadoop QA commented on ZOOKEEPER-1204:
--------------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12496489/ZOOKEEPER-1204.patch
  against trunk revision 1173949.

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit warnings.

    -1 core tests.  The patch failed core unit tests.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/589//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/589//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/589//console

This message is automatically generated.

> Shorten calls to ZooTrace
> -------------------------
>
>                 Key: ZOOKEEPER-1204
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>         Attachments: ZOOKEEPER-1204.patch
>
>
> The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
> Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Posted by "jiraposter@reviews.apache.org (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13128486#comment-13128486 ] 

jiraposter@reviews.apache.org commented on ZOOKEEPER-1204:
----------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/2045/
-----------------------------------------------------------

(Updated 2011-10-16 19:05:48.308818)


Review request for zookeeper.


Summary
-------


                
> Shorten calls to ZooTrace
> -------------------------
>
>                 Key: ZOOKEEPER-1204
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>         Attachments: ZOOKEEPER-1204.patch, ZOOKEEPER-1204.patch
>
>
> The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
> Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Posted by "Hadoop QA (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13128479#comment-13128479 ] 

Hadoop QA commented on ZOOKEEPER-1204:
--------------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12499215/ZOOKEEPER-1204.patch
  against trunk revision 1180217.

    +1 @author.  The patch does not contain any @author tags.

    -1 tests included.  The patch doesn't appear to include any new or modified tests.
                        Please justify why no new tests are needed for this patch.
                        Also please list what manual steps were performed to verify this patch.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit warnings.

    +1 core tests.  The patch passed core unit tests.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/623//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/623//artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Console output: https://builds.apache.org/job/PreCommit-ZOOKEEPER-Build/623//console

This message is automatically generated.
                
> Shorten calls to ZooTrace
> -------------------------
>
>                 Key: ZOOKEEPER-1204
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>         Attachments: ZOOKEEPER-1204.patch, ZOOKEEPER-1204.patch
>
>
> The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
> Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Posted by "Thomas Koch (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/ZOOKEEPER-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Thomas Koch updated ZOOKEEPER-1204:
-----------------------------------

    Attachment: ZOOKEEPER-1204.patch

> Shorten calls to ZooTrace
> -------------------------
>
>                 Key: ZOOKEEPER-1204
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>         Attachments: ZOOKEEPER-1204.patch
>
>
> The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
> Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Posted by "Patrick Hunt (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13131894#comment-13131894 ] 

Patrick Hunt commented on ZOOKEEPER-1204:
-----------------------------------------

ZooTrace is an artifact of version 1 days (before even log4j was used).

Rather than refactor around zootrace why don't we entirely remove the zoo trace facility (I don't know of anyone ever using it) and replace with traditional slf4j trace logging.

You want to do that as a separate patch, or just do it here?

                
> Shorten calls to ZooTrace
> -------------------------
>
>                 Key: ZOOKEEPER-1204
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>         Attachments: ZOOKEEPER-1204.patch, ZOOKEEPER-1204.patch
>
>
> The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
> Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Posted by "Thomas Koch (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/ZOOKEEPER-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Thomas Koch updated ZOOKEEPER-1204:
-----------------------------------

    Attachment: ZOOKEEPER-1204.patch
    
> Shorten calls to ZooTrace
> -------------------------
>
>                 Key: ZOOKEEPER-1204
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>         Attachments: ZOOKEEPER-1204.patch, ZOOKEEPER-1204.patch
>
>
> The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
> Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (ZOOKEEPER-1204) Shorten calls to ZooTrace

Posted by "jiraposter@reviews.apache.org (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/ZOOKEEPER-1204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13114733#comment-13114733 ] 

jiraposter@reviews.apache.org commented on ZOOKEEPER-1204:
----------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/2045/
-----------------------------------------------------------

Review request for zookeeper.


Summary
-------



> Shorten calls to ZooTrace
> -------------------------
>
>                 Key: ZOOKEEPER-1204
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-1204
>             Project: ZooKeeper
>          Issue Type: Sub-task
>            Reporter: Thomas Koch
>            Assignee: Thomas Koch
>         Attachments: ZOOKEEPER-1204.patch
>
>
> The calls to ZooTrace are kind of verbose and contain duplicated logic. This patch makes the calls as short as possible so that they do not distract that much from what's actually going on.
> Calls to LOG.isTraceEnabled() are removed at many places, because this check is done anyways inside ZooTracer. At some places it has been left, to avoid costly message creation.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira