You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by "Hadrian Zbarcea (JIRA)" <ji...@apache.org> on 2009/08/01 16:07:35 UTC

[jira] Commented: (CAMEL-1822) Cleanup unnecessary copy related methods in Exchange

    [ https://issues.apache.org/activemq/browse/CAMEL-1822?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=53420#action_53420 ] 

Hadrian Zbarcea commented on CAMEL-1822:
----------------------------------------

While working on this cleanup, I became more convinced that 
Exchange copy(boolean handoverOnCompletion);

...should be removed from Exchange api. This is not really a different flavor of copy, but it represents modifications required to a related exchange to be used in async messaging.  I will move this method to Exchange helper and rename it to createCorrelatedCopy().  This change won't affect package dependencies.

If there are any objections, please shout. 

> Cleanup unnecessary copy related methods in Exchange
> ----------------------------------------------------
>
>                 Key: CAMEL-1822
>                 URL: https://issues.apache.org/activemq/browse/CAMEL-1822
>             Project: Apache Camel
>          Issue Type: Improvement
>    Affects Versions: 2.0-M2
>            Reporter: Hadrian Zbarcea
>            Assignee: Hadrian Zbarcea
>             Fix For: 2.0.0
>
>
> There are currently 4 apis related to copying exchanges that overlap for the most part, are confusing and unnecessary.  The consensus is to replace:
>     Exchange newInstance();
>     Exchange copy();
>     Exchange newCopy(boolean handoverOnCompletion);
>     void copyFrom(Exchange source);
> with:
>     Exchange copy();
>     Exchange copy(boolean handoverOnCompletion);
> newInstance() does not bring much value,
> copyFrom() is semantically equivalent to copy()
> newCopy() will be just renamed to copy(boolean) 
>  
> See nabble thread:
> http://www.nabble.com/-DISCUSS--Exchange-copy-api-cleanup-td24400340.html

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.