You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ofbiz.apache.org by Jacopo Cappellato <ja...@hotwaxmedia.com> on 2008/09/29 12:51:50 UTC

Questions about PartyFinancialHistory screen

I had a quick look at the PartyFinancialHistory screen, and after a  
cursory review I have noticed some issues in some of the artifacts  
involved (typos, bad naming for variables, non standard formatting).
By the way, I have noticed, in the screen acrion, the following  
assignment:

  <set field="organizationPartyId" from-scope="user" to-scope="screen"  
from-field="productStoreId"/>

What is the meaning of this?

Cheers,

Jacopo


Re: Questions about PartyFinancialHistory screen

Posted by Hans Bakker <ma...@antwebsystems.com>.
These programs and screens were copied over from the sharedOfbiz system
where this data was used differently.
I already implemented the comments below, but the screens are not yet
perfect, but show now correct info using the demo data.
I will improve the screens in the next few weeks....

Regards,
Hans

On Mon, 2008-09-29 at 13:20 -0600, David E Jones wrote:
> On Sep 29, 2008, at 4:51 AM, Jacopo Cappellato wrote:
> 
> > I had a quick look at the PartyFinancialHistory screen, and after a  
> > cursory review I have noticed some issues in some of the artifacts  
> > involved (typos, bad naming for variables, non standard formatting).
> > By the way, I have noticed, in the screen acrion, the following  
> > assignment:
> >
> > <set field="organizationPartyId" from-scope="user" to-scope="screen"  
> > from-field="productStoreId"/>
> >
> > What is the meaning of this?
> 
> Looks like a mistake to me! I can't think of any reason to assign a  
> productStoreId to an organizationPartyId (ie why would you require  
> setting up data so that they are the same... bad idea).
> 
> My guess is that what was intended was to get the  
> ProductStore.ownerPartyId and assign it to the organizationPartyId, ie  
> that's how those things are meant to relate.
> 
> Something like:
> 
> <entity-one entity-name="ProductStore" value-name="productStore"/>
> <set field="organizationPartyId" from-scope="user" to-scope="screen"  
> from-field="productStore.ownerPartyId"/>
> 
> Warning: I didn't review that code, just commenting based on this email.
> 
> -David
> 
> 
-- 
Antwebsystems.com: Quality OFBiz services for competitive prices


Re: Questions about PartyFinancialHistory screen

Posted by David E Jones <jo...@hotwaxmedia.com>.
On Sep 29, 2008, at 4:51 AM, Jacopo Cappellato wrote:

> I had a quick look at the PartyFinancialHistory screen, and after a  
> cursory review I have noticed some issues in some of the artifacts  
> involved (typos, bad naming for variables, non standard formatting).
> By the way, I have noticed, in the screen acrion, the following  
> assignment:
>
> <set field="organizationPartyId" from-scope="user" to-scope="screen"  
> from-field="productStoreId"/>
>
> What is the meaning of this?

Looks like a mistake to me! I can't think of any reason to assign a  
productStoreId to an organizationPartyId (ie why would you require  
setting up data so that they are the same... bad idea).

My guess is that what was intended was to get the  
ProductStore.ownerPartyId and assign it to the organizationPartyId, ie  
that's how those things are meant to relate.

Something like:

<entity-one entity-name="ProductStore" value-name="productStore"/>
<set field="organizationPartyId" from-scope="user" to-scope="screen"  
from-field="productStore.ownerPartyId"/>

Warning: I didn't review that code, just commenting based on this email.

-David