You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@mynewt.apache.org by "Sterling Hughes (JIRA)" <ji...@apache.org> on 2017/01/25 19:31:26 UTC

[jira] [Commented] (MYNEWT-490) Move os_time_get() and parts of os_time_tick() into the HAL, rename os_tick HAL

    [ https://issues.apache.org/jira/browse/MYNEWT-490?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15838413#comment-15838413 ] 

Sterling Hughes commented on MYNEWT-490:
----------------------------------------

Have we fixed this yet?

> Move os_time_get() and parts of os_time_tick() into the HAL, rename os_tick HAL
> -------------------------------------------------------------------------------
>
>                 Key: MYNEWT-490
>                 URL: https://issues.apache.org/jira/browse/MYNEWT-490
>             Project: Mynewt
>          Issue Type: Bug
>            Reporter: Sterling Hughes
>            Assignee: Marko Kiiskila
>             Fix For: v1_0_0_beta2
>
>
> Right now the implementation of os_time_* is split between platform/idle tick handling (currently in the MCU directory), and the OS itself.  It is useful for the HAL to be able to access the ticker, and given that the os_tick handling implementation is already _largely_ in the HAL, it makes sense to centralize this in the MCU implementation itself.
> Also, we should rename os_tick_idle() to hal_os_tick_idle().
> This is a tracking ticket to make sure we review and potentially revise the division here prior to release.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)