You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@wicket.apache.org by "Pedro Santos (Jira)" <ji...@apache.org> on 2026/02/15 00:05:00 UTC

[jira] [Updated] (WICKET-7126) CdiConfiguration new API

     [ https://issues.apache.org/jira/browse/WICKET-7126?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Pedro Santos updated WICKET-7126:
---------------------------------
    Description: 
Context: originally BeanManagerLookup contained the entire logic to resolve the app BeanManager, with no option to set one manually, for instance. This was improved last year, but the code became a mix of states beingĀ  kept in CdiConfiguration and BeanManagerLookup.

Improvement:
 * move the entire logic + state to CdiConfiguration
 ** to remove the CdiConfiguration.set/getFallbackBeanManager and its related logic
 ** to remove the BeanManagerLookup lastSuccessful state

  was:
Context: given the options there are to create a BeanManager, I think it would be better to delegate to Wicket users what instance should be used instead of encapsulating this logic inside BeanManagerLookup.

Improvement:
 * to require the BeanManager at CdiConfiguration's constructor
 ** to remove the CdiConfiguration.set/getFallbackBeanManager and its related logic
 * rename BeanManagerLookup to JNDIBeanManagerLookup and simplify it by looking for BeanManager only in the JNDI context.
 ** to remove the BeanManagerLookup lastSuccessful state


> CdiConfiguration new API
> ------------------------
>
>                 Key: WICKET-7126
>                 URL: https://issues.apache.org/jira/browse/WICKET-7126
>             Project: Wicket
>          Issue Type: Improvement
>          Components: wicket-cdi
>            Reporter: Pedro Henrique Oliveira dos Santos
>            Assignee: Pedro Santos
>            Priority: Minor
>
> Context: originally BeanManagerLookup contained the entire logic to resolve the app BeanManager, with no option to set one manually, for instance. This was improved last year, but the code became a mix of states beingĀ  kept in CdiConfiguration and BeanManagerLookup.
> Improvement:
>  * move the entire logic + state to CdiConfiguration
>  ** to remove the CdiConfiguration.set/getFallbackBeanManager and its related logic
>  ** to remove the BeanManagerLookup lastSuccessful state



--
This message was sent by Atlassian Jira
(v8.20.10#820010)