You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@lucene.apache.org by cp...@apache.org on 2020/09/09 12:13:40 UTC

[lucene-solr] branch branch_8x updated (16a703f -> b40d6e0)

This is an automated email from the ASF dual-hosted git repository.

cpoerschke pushed a change to branch branch_8x
in repository https://gitbox.apache.org/repos/asf/lucene-solr.git.


    from 16a703f  LUCENE-9511: Increase RAM buffer in test since now we account more ram that get's allocated
     new 4008221  Rename TestDirectoryFactory to DirectoryFactoriesTest (which is different from DirectoryFactoryTest). (#1790)
     new b40d6e0  SOLR-14831: remove deprecated-and-unused "facet.distrib.mco" constant in FacetParams.java (#1832)

The 2 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 ...ectoryFactory.java => DirectoryFactoriesTest.java} |  2 +-
 .../org/apache/solr/common/params/FacetParams.java    | 19 -------------------
 2 files changed, 1 insertion(+), 20 deletions(-)
 rename solr/core/src/test/org/apache/solr/core/{TestDirectoryFactory.java => DirectoryFactoriesTest.java} (98%)


[lucene-solr] 02/02: SOLR-14831: remove deprecated-and-unused "facet.distrib.mco" constant in FacetParams.java (#1832)

Posted by cp...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

cpoerschke pushed a commit to branch branch_8x
in repository https://gitbox.apache.org/repos/asf/lucene-solr.git

commit b40d6e0509c2352ec6cc44637988a937f070c33a
Author: Christine Poerschke <cp...@apache.org>
AuthorDate: Wed Sep 9 13:09:21 2020 +0100

    SOLR-14831: remove deprecated-and-unused "facet.distrib.mco" constant in FacetParams.java (#1832)
---
 .../org/apache/solr/common/params/FacetParams.java    | 19 -------------------
 1 file changed, 19 deletions(-)

diff --git a/solr/solrj/src/java/org/apache/solr/common/params/FacetParams.java b/solr/solrj/src/java/org/apache/solr/common/params/FacetParams.java
index b61df07..625de96 100644
--- a/solr/solrj/src/java/org/apache/solr/common/params/FacetParams.java
+++ b/solr/solrj/src/java/org/apache/solr/common/params/FacetParams.java
@@ -125,25 +125,6 @@ public interface FacetParams {
   public static final String FACET_DISTRIB = FACET + ".distrib";
   
   /**
-   * If we are returning facet field counts, are sorting those facets by their count, and the minimum count to return is &gt; 0,
-   * then allow the use of facet.mincount = 1 in cloud mode. To enable this use facet.distrib.mco=true.
-   *
-   * i.e. If the following three conditions are met in cloud mode: facet.sort=count, facet.limit &gt; 0, facet.mincount &gt; 0.
-   * Then use facet.mincount=1.
-   *
-   * Previously and by default facet.mincount will be explicitly set to 0 when in cloud mode for this condition.
-   * In SOLR-8599 and SOLR-8988, significant performance increase has been seen when enabling this optimization.
-   *
-   * Note: enabling this flag has no effect when the conditions above are not met. For those other cases the default behavior is sufficient.
-   *
-   * @deprecated
-   * This option is no longer used nor will if affect any queries as the fix has been built in. (SOLR-11711)
-   * This will be removed entirely in 8.0.0
-   */
-  @Deprecated
-  public static final String FACET_DISTRIB_MCO = FACET_DISTRIB + ".mco";
-  
-  /**
    * Comma separated list of fields to pivot
    * 
    * example: author,type  (for types by author / types within author)


[lucene-solr] 01/02: Rename TestDirectoryFactory to DirectoryFactoriesTest (which is different from DirectoryFactoryTest). (#1790)

Posted by cp...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

cpoerschke pushed a commit to branch branch_8x
in repository https://gitbox.apache.org/repos/asf/lucene-solr.git

commit 4008221c9c63425b0085538af4463403c58f9775
Author: Christine Poerschke <cp...@apache.org>
AuthorDate: Wed Sep 9 13:08:20 2020 +0100

    Rename TestDirectoryFactory to DirectoryFactoriesTest (which is different from DirectoryFactoryTest). (#1790)
---
 .../core/{TestDirectoryFactory.java => DirectoryFactoriesTest.java}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/solr/core/src/test/org/apache/solr/core/TestDirectoryFactory.java b/solr/core/src/test/org/apache/solr/core/DirectoryFactoriesTest.java
similarity index 98%
rename from solr/core/src/test/org/apache/solr/core/TestDirectoryFactory.java
rename to solr/core/src/test/org/apache/solr/core/DirectoryFactoriesTest.java
index 3f6b18b..c06dabd 100644
--- a/solr/core/src/test/org/apache/solr/core/TestDirectoryFactory.java
+++ b/solr/core/src/test/org/apache/solr/core/DirectoryFactoriesTest.java
@@ -35,7 +35,7 @@ import java.util.List;
  * TODO: test more methods besides exists(String)
  * </p>
  */
-public class TestDirectoryFactory extends SolrTestCaseJ4 {
+public class DirectoryFactoriesTest extends SolrTestCaseJ4 {
 
   // TODO: what do we need to setup to be able to test HdfsDirectoryFactory?
   public static final List<Class<? extends DirectoryFactory>> ALL_CLASSES